cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anil lakineni <anilkumar459.lakin...@gmail.com>
Subject Usage service not working in CS 4.3.1
Date Wed, 16 Sep 2015 13:18:48 GMT
Dears,

>From past three days, I have been facing issues with usage service in
CS4.3.1 with Xen host 6.2.0

In the CS mgmt server when check with usage service status, it is saying
running. But usage records are not generating in the cloud_usage

In the management-server.log I am getting below error,

*2015-09-16 02:48:09,180 INFO  [c.c.h.HighAvailabilityManagerImpl]
(HA-5:ctx-9e572072) checking health of usage server*
*2015-09-16 02:48:09,184 DEBUG [c.c.h.HighAvailabilityManagerImpl]
(HA-5:ctx-9e572072) usage server running? false, heartbeat: Mon Sep 14
22:46:09 GMT-08:00 2015*
*2015-09-16 02:48:09,184 WARN  [o.a.c.alerts] (HA-5:ctx-9e572072)
 alertType:: 13 // dataCenterId:: 0 // podId:: 0 // clusterId:: null //
message:: No usage server process running*
*2015-09-16 02:48:09,187 DEBUG [c.c.a.AlertManagerImpl] (HA-5:ctx-9e572072)
Have already sent: 1 emails for alert type '13' -- skipping send email*

When I was check at vi /var/log/cloudstack/usage/cloudstack-usage.err, the
below error is showing

*com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException:
Could not create connection to database server. Attempted reconnect 3
times. Giving up*
*--------*
*--------*
*Caused by: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException:
Communications link failure*

The full log of cloudstack-usage.err is copied and pasted in
http://pastebin.com/y9t7ebN4

I have checked and symbolic link mysql-connector-java.jar is available for
usage server at usage lib.

Please help me if I am missing something to fix this issue and let me know
if you need any other information from my side.

Thanks in advance,

Regards,
Anil.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message