cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luciano Castro <luciano.cas...@gmail.com>
Subject cloudstack-agent requires python 2.6 in Centos 7
Date Wed, 02 Sep 2015 19:33:45 GMT
I´m trying to move my KVM hosts from Centos 6.6 to Centos 7, but when I´m
trying to install the cloudstack-agent, I had some problems
with dependencies:

root@15s ~]# cat /etc/yum.repos.d/cloudstack.repo
[cloudstack]
name=cloudstack
baseurl=http://packages.shapeblue.com/cloudstack/upstream/centos/4.5
enabled=1
gpgcheck=0


The error below shows me that I need install python 2.6. But when I
"googled it" some link said me to instal python2.6-dev, but I didn´t find
repositories with it.


--> Finished Dependency Resolution
Error: Package: cloudstack-common-4.5.2-shapeblue0.el6.x86_64 (cloudstack)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-18.el7_1.1.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python-2.7.5-16.el7.x86_64 (base)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python34-3.4.3-2.el7.x86_64 (epel)
               python(abi) = 3.4
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 Is there´s a solution for it?

 thanks

-- 
Luciano Castro

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message