cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Borhan Asgharnejad <b.asgharne...@gmail.com>
Subject Re: Register iso so slow.
Date Sat, 15 Aug 2015 15:33:23 GMT
Hi
I have this problem in cloudstack 4.5.1 but after changed this version to
previous version the problem vanished. finally iso file registered but in
cloudstack 4.4.
Thank's

On Fri, Aug 14, 2015 at 10:39 PM, Somesh Naidu <Somesh.Naidu@citrix.com>
wrote:

> Ok, can you share the output of SQL query - select id,name,type,status
> from host where id=461;
>
> Has there been any progress in the download status since your last email,
> you may just grep the agent logs for "83957b05-5dd7-4e47-9e65-b512f5bed735"?
>
> Regards,
> Somesh
>
>
> -----Original Message-----
> From: Borhan Asgharnejad [mailto:b.asgharnejad@gmail.com]
> Sent: Friday, August 14, 2015 1:19 PM
> To: users@cloudstack.apache.org
> Subject: Re: Register iso so slow.
>
> Hi
> 1. no i have never been able register any ISO in this environment.
> 2. KVM
> 3. yes i tried but nothing changed and the problem exist.
> 4. cloud.log in ssvm like:
>  ///////////////////////
> 2015-08-14 17:15:08,268 DEBUG [cloud.agent.Agent]
> (agentRequest-Handler-3:null) Request:Seq 461-5216294268401877072:  { Cmd ,
> MgmtId: 279278805450954, via: 461, Ver: v1, Flags: 100011,
>
> [{"org.apache.cloudstack.storage.command.DownloadProgressCommand":{"jobId":"83957b05-5dd7-4e47-9e65-b512f5bed735","request":"GET_STATUS","hvm":true,"description":"iso","maxDownloadSizeInBytes":53687091200,"id":212,"resourceType":"TEMPLATE","installPath":"template/tmpl/2/212","_store":{"com.cloud.agent.api.to.NfsTO":{"_url":"nfs://
> 192.168.76.146/secondary","_role":"Image"}},"url":"
> http://192.168.76.147:8080/CentOS-6.4-x86_64-minimal.iso
>
> ","format":"ISO","accountId":2,"name":"212-2-bc224b91-d8d2-305a-818b-f87c3c387096","secUrl":"nfs://
> 192.168.76.146/secondary","wait":0}}] }
> 2015-08-14 17:15:08,269 DEBUG [cloud.agent.Agent]
> (agentRequest-Handler-3:null) Processing command:
> org.apache.cloudstack.storage.command.DownloadProgressCommand
> 2015-08-14 17:15:08,269 DEBUG [cloud.agent.Agent]
> (agentRequest-Handler-3:null) Seq 461-5216294268401877072:  { Ans: ,
> MgmtId: 279278805450954, via: 461, Ver: v1, Flags: 10,
>
> [{"com.cloud.agent.api.storage.DownloadAnswer":{"jobId":"83957b05-5dd7-4e47-9e65-b512f5bed735","downloadPct":0,"errorString":"
>
> ","downloadStatus":"NOT_DOWNLOADED","downloadPath":"/mnt/SecStorage/48148529-2b47-39ff-9476-b95d6a4f06ee/template/tmpl/2/212/dnld3810725773438490062tmp_","installPath":"template/tmpl/2/212","templateSize":0,"templatePhySicalSize":0,"result":true,"details":"
> ","wait":0}}] }
> ///////////////////////////////
> 5. template_store_ref is empty.
>
> On Fri, Aug 14, 2015 at 2:46 AM, Somesh Naidu <Somesh.Naidu@citrix.com>
> wrote:
>
> > @Sam,
> >
> > About running the webserver on port 80, we have this running in multiple
> > environments when using internal sites and it seems to work fine.
> >
> > @Borhan,
> > 1. have you ever been able to register a template/ISO in this
> environment?
> > 2. what hypervisor is being used? Xenserver?
> > 3. have you tried to recreate SSVM to see if that helps?
> > 4. were you able to spot any errors in either management or agent (SSVM)
> > logs related to this operation?
> > 5. look for this template in template_store_ref, what state is it in?
> >
> > Regards,
> > Somesh
> >
> >
> > -----Original Message-----
> > From: Borhan Asgharnejad [mailto:b.asgharnejad@gmail.com]
> > Sent: Thursday, August 13, 2015 4:55 AM
> > To: users@cloudstack.apache.org
> > Subject: Re: Register iso so slow.
> >
> > Hi
> > My Problem already exist.
> > As I check ssvm troubleshooting i notice something about systemVM.ISO
> What
> > is it and how check if  it is patch correct in my cloudstack.
> > i see it in my management server and it has 54.6 MB size
> > "/usr/share/cloudstack-common/vms/systemvm.iso".
> >
> > On Thu, Aug 13, 2015 at 12:40 AM, Borhan Asgharnejad <
> > b.asgharnejad@gmail.com> wrote:
> >
> > > not working at all.
> > >
> > > On Wed, Aug 12, 2015 at 11:44 PM, Sam Ceylani <sam@mistercertified.com
> >
> > > wrote:
> > >
> > >> First you need to tell me if it is slow or not working at all? Both
> > >> requires different troubleshooting...
> > >>
> > >> -----Original Message-----
> > >> From: Borhan Asgharnejad [mailto:b.asgharnejad@gmail.com]
> > >> Sent: Wednesday, August 12, 2015 1:57 PM
> > >> To: users@cloudstack.apache.org
> > >> Subject: Re: Register iso so slow.
> > >>
> > >> my gateway is 192.168.76.2, could the problem cause the Gateway? i
> read
> > >> in quick installation need /24 network with gateway XXX.XXX.XXX.1.
> > >> i install centos 6.6 on vmware workstation. and setup cloud stack on
> it.
> > >>
> > >> On Wed, Aug 12, 2015 at 10:23 PM, Borhan Asgharnejad <
> > >> b.asgharnejad@gmail.com> wrote:
> > >>
> > >> > hi Sam
> > >> > yes i did it. but still the problem exist.
> > >> >
> > >> > On Wed, Aug 12, 2015 at 10:15 PM, Sam Ceylani
> > >> > <sam@mistercertified.com>
> > >> > wrote:
> > >> >
> > >> >> Borhan, did you try running your server at port 8080? there are
> some
> > >> >> hard coded stuff for this port in the code and secstorage allowed
> > >> >> sites etc. I asked this yesterday but couldnt get an answer from
> you
> > >> >> :)
> > >> >>
> > >> >> Sent from my iPhone
> > >> >>
> > >> >> > On Aug 12, 2015, at 1:02 PM, Borhan Asgharnejad <
> > >> >> b.asgharnejad@gmail.com> wrote:
> > >> >> >
> > >> >> > sorry set secstorage.allowed.internal.sites to 192.168.76.0/24
> > >> >> > <http://192.168.76.9/24>
> > >> >> >
> > >> >> > On Wed, Aug 12, 2015 at 9:07 PM, Borhan Asgharnejad <
> > >> >> b.asgharnejad@gmail.com
> > >> >> >> wrote:
> > >> >> >
> > >> >> >> hi
> > >> >> >> this is ssvm check result and of course i set
> > >> >> >> secstorage.allowed.internal.sites to 192.168.76.9/24.
but after
> > >> >> register
> > >> >> >> iso it just create empty file in 192.168.76.5:/secondary
(i
> mean
> > >> >> >> the
> > >> >> size
> > >> >> >> of file 0kb)
> > >> >> >>
> > >> >> >>
> > >> >> >> First DNS server is  8.8.8.8
> > >> >> >> PING 8.8.8.8 (8.8.8.8): 48 data bytes
> > >> >> >> 56 bytes from 8.8.8.8: icmp_seq=0 ttl=128 time=670.263
ms
> > >> >> >> 56 bytes from 8.8.8.8: icmp_seq=1 ttl=128 time=749.591
ms
> > >> >> >> --- 8.8.8.8 ping statistics ---
> > >> >> >> 2 packets transmitted, 2 packets received, 0% packet
loss
> > >> >> >> round-trip min/avg/max/stddev = 670.263/709.927/749.591/39.664
> ms
> > >> >> >> Good: Can ping DNS server
> > >> >> >> ================================================
> > >> >> >> Good: DNS resolves download.cloud.com
> > >> >> >> ================================================
> > >> >> >> nfs is currently mounted
> > >> >> >> Mount point is
> > >> >> >> /mnt/SecStorage/74b7fe22-5937-3f2a-b2a2-8f9dbdc54631
> > >> >> >> Good: Can write to mount point
> > >> >> >> ================================================
> > >> >> >> Management server is 192.168.76.5. Checking connectivity.
> > >> >> >> Good: Can connect to management server port 8250
> > >> >> >> ================================================
> > >> >> >> Good: Java process is running
> > >> >> >> ================================================
> > >> >> >> Tests Complete. Look for ERROR or WARNING above.
> > >> >> >>
> > >> >> >> On Wed, Aug 12, 2015 at 7:32 PM, Somesh Naidu
> > >> >> >> <Somesh.Naidu@citrix.com
> > >> >> >
> > >> >> >> wrote:
> > >> >> >>
> > >> >> >>> Hi Borhan,
> > >> >> >>>
> > >> >> >>>> i figure out when i try get iso
> > >> >> >>>> file on SSVM by wget command (wget
> > >> >> >>>> http://192.168.76.5/isoname.iso) <
> http://10.39.1.9/isoname.iso>
> > >> >> >>>> say cannot write to 'isoname <http://10.39.1.9/isoname.iso
> > >.iso'
> > >> (No space left on device).
> > >> >> >>>
> > >> >> >>> This probably won't work if you were using SSVM's
root disk as
> a
> > >> >> target
> > >> >> >>> for download as it size is limited to 2 GB.
> > >> >> >>>
> > >> >> >>> I believe this is internal IP "192.168.76.5", if
that's true,
> > >> >> >>> have you added this IP to the global config
> > >> >> "secstorage.allowed.internal.sites"?
> > >> >> >>>
> > >> >> >>> Also, as Prashant and Sam recommended, validate all
is fine
> with
> > >> >> >>> SSVM
> > >> >> by
> > >> >> >>> performing troubleshooting as mentioned on the wiki.
> > >> >> >>>
> > >> >> >>> Regards,
> > >> >> >>> Somesh
> > >> >> >>>
> > >> >> >>>
> > >> >> >>> -----Original Message-----
> > >> >> >>> From: Sam Ceylani [mailto:sam@mistercertified.com]
> > >> >> >>> Sent: Wednesday, August 12, 2015 2:58 AM
> > >> >> >>> To: users@cloudstack.apache.org
> > >> >> >>> Subject: RE: Register iso so slow.
> > >> >> >>>
> > >> >> >>> It only accepts it on port 8080 don’t ask me why,
in theory yes
> > >> >> >>> port
> > >> >> 80
> > >> >> >>> is ok and yes you can but I never get it to work,
try running
> > >> >> >>> your web server on port 8080 and give it a try :)
> > >> >> >>>
> > >> >> >>> -----Original Message-----
> > >> >> >>> From: Vadim Kimlaychuk [mailto:Vadim.Kimlaychuk@Elion.ee]
> > >> >> >>> Sent: Wednesday, August 12, 2015 2:55 AM
> > >> >> >>> To: users@cloudstack.apache.org
> > >> >> >>> Subject: RE: Register iso so slow.
> > >> >> >>>
> > >> >> >>> Hi, Borhan
> > >> >> >>>
> > >> >> >>>        Is your SSVM up and agent status is "connected"?
 Can
> you
> > >> >> confirm
> > >> >> >>> that troubleshooting SSVM (
> > >> >> >>>
> > >> >>
> > https://cwiki.apache.org/confluence/display/CLOUDSTACK/SSVM,+template
> > >> >> s,+Secondary+storage+troubleshooting
> > >> >> )
> > >> >> >>> gives OK status?
> > >> >> >>>
> > >> >> >>> Regards,
> > >> >> >>>
> > >> >> >>> Vadim.
> > >> >> >>>
> > >> >> >>>
> > >> >> >>> -----Original Message-----
> > >> >> >>> From: Borhan Asgharnejad [mailto:b.asgharnejad@gmail.com]
> > >> >> >>> Sent: Wednesday, August 12, 2015 9:44 AM
> > >> >> >>> To: users@cloudstack.apache.org
> > >> >> >>> Subject: Re: Register iso so slow.
> > >> >> >>>
> > >> >> >>> Hi Vadiam
> > >> >> >>> The SSVM and CPVM is running and up.
> > >> >> >>> The status of registering iso is null, and i figure
out when i
> > >> >> >>> try get iso file on SSVM by wget command (wget
> > >> >> http://192.168.76.5/isoname.iso) <
> > >> >> >>> http://10.39.1.9/isoname.iso> say cannot write
to 'isoname <
> > >> >> >>> http://10.39.1.9/isoname.iso>.iso' (No space left
on device).
> i
> > >> >> >>> have problem to register iso could you please tell
me what can
> i
> > >> >> >>> do. by
> > >> >> the way
> > >> >> >>> i have about 400 GB free space on secondary storage.
> > >> >> >>>
> > >> >> >>> On Wed, Aug 12, 2015 at 9:45 AM, Vadim Kimlaychuk
<
> > >> >> >>> Vadim.Kimlaychuk@elion.ee
> > >> >> >>>> wrote:
> > >> >> >>>
> > >> >> >>>> Hello Borhan,
> > >> >> >>>>
> > >> >> >>>>
> > >> >> >>>>
> > >> >> >>>> 1.       It all depends on the speed of you network,
storage
> and
> > >> >> size of
> > >> >> >>>> the ISO image.  If you analyze the whole process
chain -- you
> > >> >> >>>> can
> > >> >> find
> > >> >> >>>> bottlenecks. Then you can (probably) optimize
something. It is
> > >> >> >>>> better to show numbers here to be able to judge.
> > >> >> >>>>
> > >> >> >>>> 2.       Go to ISO, Zone tab, klick on zone and
you will see
> ISO
> > >> >> details
> > >> >> >>>> tab with downloaded % and status.
> > >> >> >>>>
> > >> >> >>>>
> > >> >> >>>>
> > >> >> >>>> Vadim.
> > >> >> >>>>
> > >> >> >>>>
> > >> >> >>>>
> > >> >> >>>> -----Original Message-----
> > >> >> >>>> From: Borhan Asgharnejad [mailto:b.asgharnejad@gmail.com]
> > >> >> >>>> Sent: Wednesday, August 12, 2015 8:53 AM
> > >> >> >>>> To: users@cloudstack.apache.org
> > >> >> >>>> Subject: Register iso so slow.
> > >> >> >>>>
> > >> >> >>>>
> > >> >> >>>>
> > >> >> >>>> Hi All,
> > >> >> >>>>
> > >> >> >>>> 1- Could you please guide me how i increase speed
of
> registering
> > >> >> >>>> iso template.
> > >> >> >>>>
> > >> >> >>>> 2- how could  see percentage of iso that uploaded
to ssvm in
> > >> >> >>>> cloud stack 4.5.
> > >> >> >>
> > >> >> >>
> > >> >>
> > >> >
> > >> >
> > >>
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message