cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Reategui <create...@gmail.com>
Subject Xenserver 6.0.2 in alert state after upgrade to 4.5.1
Date Tue, 28 Jul 2015 18:27:54 GMT
I have upgraded to 4.5.1 and my hosts are now in Alert state.

The logs show::

2015-07-28 10:24:16,412 WARN  [c.c.h.x.r.CitrixResourceBase]
(DirectAgent-2:ctx-5f118670) Failed to configure brige firewall

2015-07-28 10:24:16,413 WARN  [c.c.h.x.r.CitrixResourceBase]
(DirectAgent-2:ctx-5f118670) Check host 10.110.106.33 for CSP is installed
or not and check network mode for bridge

2015-07-28 10:24:16,413 DEBUG [c.c.a.m.DirectAgentAttache]
(DirectAgent-2:ctx-5f118670) Seq 1-6652942549533065217: Response Received:

2015-07-28 10:24:16,414 DEBUG [c.c.a.t.Request]
(DirectAgent-2:ctx-5f118670) Seq 1-6652942549533065217: Processing:  { Ans:
, MgmtId: 233845174730253, via: 1, Ver: v1, Flags: 110,
[{"com.cloud.agent.api.SetupAnswer":{"_reconnect":true,"result":false,"details":"Failed
to configure brige firewall","wait":0}}] }

2015-07-28 10:24:16,415 DEBUG [c.c.a.t.Request]
(AgentTaskPool-1:ctx-91ed8e17) Seq 1-6652942549533065217: Received:  { Ans:
, MgmtId: 233845174730253, via: 1, Ver: v1, Flags: 110, { SetupAnswer } }

2015-07-28 10:24:16,415 DEBUG [c.c.a.m.AgentAttache]
(DirectAgent-2:ctx-5f118670) Seq 1-6652942549533065217: No more commands
found

2015-07-28 10:24:16,415 WARN  [c.c.h.x.d.XcpServerDiscoverer]
(AgentTaskPool-1:ctx-91ed8e17) Unable to setup agent 1 due to Failed to
configure brige firewall

2015-07-28 10:24:16,416 INFO  [c.c.u.e.CSExceptionErrorCode]
(AgentTaskPool-1:ctx-91ed8e17) Could not find exception:
com.cloud.exception.ConnectionException in error code list for exceptions

2015-07-28 10:24:16,416 WARN  [c.c.a.m.AgentManagerImpl]
(AgentTaskPool-1:ctx-91ed8e17) Monitor XcpServerDiscoverer says there is an
error in the connect process for 1 due to Reinitialize agent after setup.

2015-07-28 10:24:16,416 INFO  [c.c.a.m.AgentManagerImpl]
(AgentTaskPool-1:ctx-91ed8e17) Host 1 is disconnecting with event
AgentDisconnected

2015-07-28 10:24:16,419 DEBUG [c.c.a.m.AgentManagerImpl]
(AgentTaskPool-1:ctx-91ed8e17) The next status of agent 1is Alert, current
status is Connecting

2015-07-28 10:24:16,419 DEBUG [c.c.a.m.AgentManagerImpl]
(AgentTaskPool-1:ctx-91ed8e17) Deregistering link for 1 with state Alert

2015-07-28 10:24:16,419 DEBUG [c.c.a.m.AgentManagerImpl]
(AgentTaskPool-1:ctx-91ed8e17) Remove Agent : 1

I am using basic networking and my hosts do have bridge networking enabled.

On the hosts I see this error:

[30339] 2015-07-28 11:03:01.076524      FAILED: (rc 1) stdout: 'ipset v4.5,
protocol version 4.

', stderr: 'FATAL: Module ip_set not found.

ipset v4.5: Couldn't verify kernel module version!

'

This is problem I had a year ago on a different deployment, the CSP has not
been updated to be compatible with the latest XenServer patches/hotfixes.
That forced me to have to start from scratch on that deployment as I could
not figure out a solution then.  I would rather not go down that path this
time.

Looks like my options are:
1) Find/build a CSP compatible with my XenServer kernel.
2) Upgrade to XenServer 6.5.

>From my prior experience, option 1 does not seem likely.  This is as far as
I got last year:
http://mail-archives.apache.org/mod_mbox/cloudstack-dev/201407.mbox/%3CFA005FBB-C0D5-471C-92A8-EB79B3B89E90@gmail.com%3E

I would like to upgrade to 6.5 and was planning on following this blog post
after the ACS 4.5.1 upgrade:
http://www.shapeblue.com/how-to-upgrade-an-apache-cloudstack-citrix-xenserver-cluster/.
Is it safe to do so in the current state I am in?

Thanks,
Carlos

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message