cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Somesh Naidu <Somesh.Na...@citrix.com>
Subject RE: HA feature - KVM - CloudStack 4.5.1
Date Thu, 16 Jul 2015 22:27:16 GMT
What about other investigators, specifically " KVMInvestigator, PingInvestigator"? They report
the VMs as alive=false too?

Also, it is recommended that you look at the management-sever.log instead of catalina.out
(for one, the latter doesn’t have timestamp).

Regards,
Somesh


-----Original Message-----
From: Luciano Castro [mailto:luciano.castro@gmail.com] 
Sent: Thursday, July 16, 2015 1:14 PM
To: users@cloudstack.apache.org
Subject: Re: HA feature - KVM - CloudStack 4.5.1

Hi Somesh!


thanks for help.. I did again ,and I collected new logs:

My vm_instance name is i-2-39-VM. There was some routers in KVM host 'A'
(this one that I powered off now):


[root@1q2 ~]# grep -i -E 'SimpleInvestigator.*false'
/var/log/cloudstack/management/catalina.out
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-2:ctx-e2f91c9c work-3)
SimpleInvestigator found VM[DomainRouter|r-4-VM]to be alive? false
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-1:ctx-729acf4f work-7)
SimpleInvestigator found VM[User|i-23-33-VM]to be alive? false
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-4:ctx-a66a4941 work-8)
SimpleInvestigator found VM[DomainRouter|r-36-VM]to be alive? false
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-1:ctx-5977245e
work-10) SimpleInvestigator found VM[User|i-17-26-VM]to be alive? false
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-1:ctx-c7f39be0 work-9)
SimpleInvestigator found VM[DomainRouter|r-32-VM]to be alive? false
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-3:ctx-ad4f5fda
work-10) SimpleInvestigator found VM[DomainRouter|r-46-VM]to be alive? false
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-0:ctx-0257f5af
work-11) SimpleInvestigator found VM[User|i-4-52-VM]to be alive? false
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-4:ctx-7ddff382
work-12) SimpleInvestigator found VM[DomainRouter|r-32-VM]to be alive? false
INFO  [c.c.h.HighAvailabilityManagerImpl] (HA-Worker-1:ctx-9f79917e
work-13) SimpleInvestigator found VM[User|i-2-39-VM]to be alive? false



KVM  host 'B' agent log (where the machine would be migrate):

2015-07-16 16:58:56,537 INFO  [kvm.resource.LibvirtComputingResource]
(agentRequest-Handler-4:null) Live migration of instance i-2-39-VM initiated
2015-07-16 16:58:57,540 INFO  [kvm.resource.LibvirtComputingResource]
(agentRequest-Handler-4:null) Waiting for migration of i-2-39-VM to
complete, waited 1000ms
2015-07-16 16:58:58,541 INFO  [kvm.resource.LibvirtComputingResource]
(agentRequest-Handler-4:null) Waiting for migration of i-2-39-VM to
complete, waited 2000ms
2015-07-16 16:58:59,542 INFO  [kvm.resource.LibvirtComputingResource]
(agentRequest-Handler-4:null) Waiting for migration of i-2-39-VM to
complete, waited 3000ms
2015-07-16 16:59:00,543 INFO  [kvm.resource.LibvirtComputingResource]
(agentRequest-Handler-4:null) Waiting for migration of i-2-39-VM to
complete, waited 4000ms
2015-07-16 16:59:01,245 INFO  [kvm.resource.LibvirtComputingResource]
(agentRequest-Handler-4:null) Migration thread for i-2-39-VM is done

It said done for my i-2-39-VM instance, but I can´t ping this host.

Luciano
Mime
View raw message