cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Weber <terbol...@gmail.com>
Subject Re: [ACS 4.5.1] vhd-util problems on systemvms
Date Fri, 12 Jun 2015 18:43:40 GMT
On Fri, Jun 12, 2015 at 8:36 PM, Erik Weber <terbolous@gmail.com> wrote:

> Has anyone else experienced issues with vhd-util on the secondary storage
> vms when running xenserver?
>
> I recently set up a lab, and see this in the template view:
> Failed post download script:
> /usr/local/cloud/systemvm/scripts/storage/secondary/createtmplt.sh: line
> 211: /bin/vhd-util: No such file or directoryvhd check of
> /mnt/SecStorage/df45201d-8613-3215-8039-b01a87a462ea/template/tmpl/2/202/dnld373471545309258453
>
>
>
> I've checked the ssvm manually, and the file is there, but seems to be
> 32-bit while the systemvm is 64-bit.
>
> I can work around it by installing ia32-libs on the ssvm, but that's not
> really a proper fix (first of all, ia32-libs is huge).
>
> Which makes me wonder if anyone else has seen this recently.
>
> SystemVM was downloaded from apt-get.eu as the install docs say.
>
> If time allows, I'll do a new setup with template from jenkins to see if
> the problem persists, but that probably won't be until next week.
>


Just to answer myself.

I'm guess this commit fixes the issue:
https://github.com/apache/cloudstack/commit/9d8a62d0ee379bf8b67405944c86f68587245db6

The systemvm templates on apt-get.eu is from march, thus older than this
commit.
Would it make sense to update the templates considering they are mentioned
in the official docs?

-- 
Erik

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message