cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Hair <j...@greenqloud.com>
Subject Re: Cloud Instance Manager only sets password after reboot on Windows 2012 R2
Date Tue, 02 Jun 2015 11:26:33 GMT
Hi,

We confirmed that the IP=password line is in the router at the time of the
machine starting up.

On Tue, Jun 2, 2015 at 10:37 AM, Andrija Panic <andrija.panic@gmail.com>
wrote:

> "We're building a Windows 2012 template on KVM. It works fine except that
> it
> only sets the password for the VM after rebooting it once."
>
> we observed this behaviour with 4.3.1/2 because when you check inside VR,
> there is file /var/cache/cloud/passwords that should indicate that the
> IP=password line is not present during VM boot (or at least that is the
> behaviour we saw).
> Meaning VR is late with password provisioning inside this file so VM doesnt
> get to fetch it during first time boot...
>
> But if you reboot the instance, in the meantime the line with IP=password
> is provisioned, so simpe reboot works fine.
>
> If instead reboot, you shutodnw VM, reset pass again, you will not be able
> to fetch it again - so reseting pass is simly not the solution.
>
> Simple VM reboot will fetch pass...
>
>
> On 2 June 2015 at 12:21, Vadim Kimlaychuk <Vadim.Kimlaychuk@elion.ee>
> wrote:
>
> > Jeff,
> >
> >         Try to reset password for existing VM. Will it take 2 reboots?
> >         There is may be a problem with Cloud Instance Manager. It is
> quite
> > old - as I have checked at
> >
> http://sourceforge.net/projects/cloudstack/files/Password%20Management%20Scripts/
> > it is almost 4 years old.
> >
> > Vadim.
> >
> > -----Original Message-----
> > From: Jeff Hair [mailto:jeff@greenqloud.com]
> > Sent: Tuesday, June 02, 2015 1:15 PM
> > To: users@cloudstack.apache.org
> > Subject: Re: Cloud Instance Manager only sets password after reboot on
> > Windows 2012 R2
> >
> > Hi,
> >
> > This is specifically for when the VM first starts up. Don't think it is
> > specifically a CloudStack problem, it's more of a question about how to
> > properly configure the Cloud Instance Manager. Basically when the machine
> > first starts up, it tries to auto-login (despite no registry setting for
> > that), but fails due to invalid password. The password to log in is the
> > default password from when I created the template. Cloud Instance Manager
> > has the garbled output I described in the first post. If I reboot the
> > machine, it starts up and Cloud Instance Manager works fine, and thus I
> can
> > log in with the CloudStack-set password.
> >
> > On Tue, Jun 2, 2015 at 10:11 AM, Vadim Kimlaychuk <
> > Vadim.Kimlaychuk@elion.ee
> > > wrote:
> >
> > > Hello Jeff,
> > >
> > >         Actually to reset password you need to power-off VM first.
> > > Then after start-up it picks up new password from VR.
> > >                If you create VM from password-enabled template then
> > > you should get it immediately upon VM start-up.
> > >
> > >         Whether Windows have to log-in automatically or not -- depends
> > > on windows OS settings. This issue seems does not belong to Cloudstack
> > > or KVM hypervisor. Check your template OS.
> > >
> > >         I don't see any problems related to CS  here.
> > >
> > > Vadim.
> > >
> > > -----Original Message-----
> > > From: Jeff Hair [mailto:jeff@greenqloud.com]
> > > Sent: Tuesday, June 02, 2015 12:57 PM
> > > To: users@cloudstack.apache.org
> > > Subject: Cloud Instance Manager only sets password after reboot on
> > > Windows
> > > 2012 R2
> > >
> > > Hi,
> > >
> > > We're building a Windows 2012 template on KVM. It works fine except
> > > that it only sets the password for the VM after rebooting it once.
> > > When the machine first starts up, there is garbled output in the Cloud
> > > Instance Manager logs. For example "Added DHCP server: i#x"
> > >
> > > After rebooting the machine, Cloud Instance Manager works and the
> > > password is set.
> > >
> > > Also on the first boot it is trying to auto-login but failing with the
> > > wrong password, if that helps.
> > >
> > > Any ideas?
> > >
> > > Thanks,
> > >
> > > Jeff
> > >
> >
> >
> >
> > --
> > *Jeff Hair*
> > Core Systems Developer
> >
> > Tel: (+354) 415 0200
> > jeff@greenqloud.com
> > www.greenqloud.com
> >
>
>
>
> --
>
> Andrija Panić
>



-- 
*Jeff Hair*
Core Systems Developer

Tel: (+354) 415 0200
jeff@greenqloud.com
www.greenqloud.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message