cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Firxiaowork <firxiaow...@gmail.com>
Subject question about ha.tag
Date Thu, 18 Jun 2015 01:59:38 GMT
Hi all:
	My test environment is  4.4.3 + kvm . and only has one agent.
        I am in a puzzle about the ha.tag.

        when I set ha.tag to “ha” and set host tag to “ha” too.
        the systemvm just can’t start, and can’t crete new vm which use no host tag offering.
        log like this:
       … Checking resources in Cluster: 1 under Pod: 1
    ...ctx-51a5fe9e FirstFitRoutingAllocator) Looking for hosts in dc: 1  pod:1  cluster:1
    ... FirstFitAllocator has 0 hosts to check for allocation: []
    ...Found 0 hosts for allocation after prioritization: []
    ...Looking for speed=500Mhz, Ram=256
    ...Host Allocator returning 0 suitable hosts
    ...No suitable hosts found
    ...No suitable hosts found under this Cluster: 1
    ...Could not find suitable Deployment Destination for this VM under any clusters, returning.

        


        I have tried to clear host tag, everything worked well!
        and I have tried with clear ha.tag and keep host tag to “ha” .  everything worked
well!!
        
        but I saw this in https://cwiki.apache.org/confluence/display/CLOUDSTACK/Host+tags+and+Storage+tags
<https://cwiki.apache.org/confluence/display/CLOUDSTACK/Host+tags+and+Storage+tags>
        "“If  offerings are tagged, then only the host with matching tag will be chosen.

         But while deploying a VM with a non-tagged service offering, 
         we consider both untagged and tagged hosts.
         So a VM with non-tagged offering may reside on a tagged host. Same goes with storage
pools.”"
         
         maybe I don’t fully understood the ha.tag ,
          is there must have untagged ha.tag hosts and tagged.ha hosts in  cluster if I set
ha.tag?
         or If I let all hosts tagged ha tag ,I have to change all offering with host tag
?
       
      
        	


thank you!

----------
Firxiao






Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message