cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nux! <...@li.nux.ro>
Subject Re: Cloud Instance Manager only sets password after reboot on Windows 2012 R2
Date Tue, 02 Jun 2015 12:06:17 GMT
If you VM tries to autologin, then I would check the sysprep/xml it was built from, at least
that is one of the places where this can be set.

--
Sent from the Delta quadrant using Borg technology!

Nux!
www.nux.ro

----- Original Message -----
> From: "Jeff Hair" <jeff@greenqloud.com>
> To: users@cloudstack.apache.org
> Sent: Tuesday, 2 June, 2015 11:15:23
> Subject: Re: Cloud Instance Manager only sets password after reboot on Windows 2012 R2

> Hi,
> 
> This is specifically for when the VM first starts up. Don't think it is
> specifically a CloudStack problem, it's more of a question about how to
> properly configure the Cloud Instance Manager. Basically when the machine
> first starts up, it tries to auto-login (despite no registry setting for
> that), but fails due to invalid password. The password to log in is the
> default password from when I created the template. Cloud Instance Manager
> has the garbled output I described in the first post. If I reboot the
> machine, it starts up and Cloud Instance Manager works fine, and thus I can
> log in with the CloudStack-set password.
> 
> On Tue, Jun 2, 2015 at 10:11 AM, Vadim Kimlaychuk <Vadim.Kimlaychuk@elion.ee
>> wrote:
> 
>> Hello Jeff,
>>
>>         Actually to reset password you need to power-off VM first. Then
>> after start-up it picks up new password from VR.
>>                If you create VM from password-enabled template then you
>> should get it immediately upon VM start-up.
>>
>>         Whether Windows have to log-in automatically or not -- depends on
>> windows OS settings. This issue seems does not belong to Cloudstack or KVM
>> hypervisor. Check your template OS.
>>
>>         I don't see any problems related to CS  here.
>>
>> Vadim.
>>
>> -----Original Message-----
>> From: Jeff Hair [mailto:jeff@greenqloud.com]
>> Sent: Tuesday, June 02, 2015 12:57 PM
>> To: users@cloudstack.apache.org
>> Subject: Cloud Instance Manager only sets password after reboot on Windows
>> 2012 R2
>>
>> Hi,
>>
>> We're building a Windows 2012 template on KVM. It works fine except that
>> it only sets the password for the VM after rebooting it once. When the
>> machine first starts up, there is garbled output in the Cloud Instance
>> Manager logs. For example "Added DHCP server: i#x"
>>
>> After rebooting the machine, Cloud Instance Manager works and the password
>> is set.
>>
>> Also on the first boot it is trying to auto-login but failing with the
>> wrong password, if that helps.
>>
>> Any ideas?
>>
>> Thanks,
>>
>> Jeff
>>
> 
> 
> 
> --
> *Jeff Hair*
> Core Systems Developer
> 
> Tel: (+354) 415 0200
> jeff@greenqloud.com
> www.greenqloud.com

Mime
View raw message