cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anshul Gangwar <anshul.gang...@citrix.com>
Subject Re: Hyper-V AgentShell install failure
Date Fri, 08 May 2015 04:33:21 GMT
Its nice to hear that you resolved the problem.

There was other problem earlier https://issues.apache.org/jira/browse/CLOUDSTACK-6663  which
was fixed by setting hostname workaround.

Regards,
Anshul

On 07-May-2015, at 11:35 pm, Ben Hines <bhines@gmail.com<mailto:bhines@gmail.com>>
wrote:

Well, i didn't really do anything, but after running AgentShell.exe
--uninstall once, AgentShell.exe --install worked.

Seems similar to the problem someone else had in the past where the
installer crashed until they ran uninstall (they thought it was setting the
hostname, but appearntly it was just the uninstall step)

Note: It had never been installed before.

-Ben

On Wed, May 6, 2015 at 9:23 PM, Ben Hines <bhines@gmail.com<mailto:bhines@gmail.com>>
wrote:

Certificate installed fine. Service install fails, ie:

AgentShell.exe --install

with or without an install user.

On Wed, May 6, 2015 at 9:15 PM, Anshul Gangwar <anshul.gangwar@citrix.com<mailto:anshul.gangwar@citrix.com>>
wrote:

Its functional and working fine. What's the exact command you have tried?

To install certificate you have to run installer as administrator.

Regards,
Anshul

On 07-May-2015, at 8:19 am, Ben Hines <bhines@gmail.com<mailto:bhines@gmail.com><mailto:
bhines@gmail.com<mailto:bhines@gmail.com>>> wrote:

Just tried it on a full Windows 2012 r2 server (same AD domain), and it
installed successfully.

So, only occurs when installing on Hyper-V 2012r2 server. Can someone
confirm that this is functional?

On Wed, May 6, 2015 at 1:45 PM, Ben Hines <bhines@gmail.com<mailto:bhines@gmail.com><mailto:
bhines@gmail.com<mailto:bhines@gmail.com>>> wrote:

We have changed/added no settings other than joining our AD domain. It's
also connected to a Windows 8 hyper-v management server.

Not sure what you mean by the second line there.

-Ben

On Tue, May 5, 2015 at 9:30 PM, Anshul Gangwar <anshul.gangwar@citrix.com<mailto:anshul.gangwar@citrix.com>
<mailto:anshul.gangwar@citrix.com>>
wrote:

This is some environment issue on Hyper-V host. Please post settings
which you have changed/added on your Hyper-V host.

Also make sure that you have not given smb-share/ network path for
virtual hard disks and virtual machines.

Regards,
Anshul

On 06-May-2015, at 2:03 am, Ben Hines <bhines@gmail.com<mailto:bhines@gmail.com><mailto:
bhines@gmail.com<mailto:bhines@gmail.com>><mailto:
bhines@gmail.com<mailto:bhines@gmail.com><mailto:bhines@gmail.com>>> wrote:

Howdy,

I'm attempting to install the Hyper-V AgentShell service on Hyper-V 2012
r2
and i just get an error message:

" 'unknown software exception (0xe0434352) occurred in the application at
location 0x541b8384'

I've attempted using built binaries from github as well as a build taken
directly from the CloudStack jenkins CI server.

Any ideas?

If anyone wants some serverfault points, also posted here..



http://serverfault.com/questions/688567/cloudstack-hyper-v-agentshell-installer-crashes

Thanks!

-Ben








Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message