cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Kimlaychuk <Vadim.Kimlayc...@Elion.ee>
Subject RE: Re: CPVM does not listen on port 443
Date Thu, 14 May 2015 05:56:10 GMT
Hubo,

	You are right, it seems it should be port 80. Management server log shows https:// but this
is connection URI to hypervisor
	CPVM services are up and running:

tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN
tcp        0      0 169.254.1.119:3922      0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:8001            0.0.0.0:*               LISTEN
tcp6       0      0 :::111                  :::*                    LISTEN

	So I guess this is routing problem. Or firewall.   I still get "Access is denied for the
console session. Please close the window and retry again".

Vadim.

-----Original Message-----
From: hubo [mailto:hub@chinatelecom.com.cn] 
Sent: Thursday, May 14, 2015 8:45 AM
To: users
Subject: Re: Re: CPVM does not listen on port 443

I remember that ACS 4.3 use http(80) instead of https(443) because the public https real-ip-host
service is expired.

------------------				 
hubo
2015-05-14

-------------------------------------------------------------
发件人:Rajani Karuturi <rajani@apache.org>
发送日期:2015-05-14 19:07
收件人:users
抄送:
主题:Re: CPVM does not listen on port 443

which version of ACS are you using?
Can you check the property values in consoleproxy.properties file?  Its at /usr/local/cloud/systemvm/conf/consoleproxy.properties
on CPVM

~Rajani

On Thu, May 14, 2015 at 9:56 AM, Vadim Kimlaychuk <Vadim.Kimlaychuk@elion.ee
> wrote:

> Hello all,
>
>
>           I have replaced router at my network and after that noticed 
> CPVM has stopped to work. Connection to management server has been 
> established correctly. Agent state at UI is "UP"
>
> Troubleshooting console proxy I have found that there is no listener 
> on public interface port 443.  I have tried to restart VM several 
> times with no success.  Reading cloud.out file shows some strange lines:
>
> 2015-05-14 03:53:04,339 INFO  [cloud.consoleproxy.ConsoleProxy]
> (Console-Proxy-Main:null) Property name: v-2-VM
> 2015-05-14 03:53:04,339 INFO  [cloud.consoleproxy.ConsoleProxy]
> (Console-Proxy-Main:null) Property consoleproxy.reconnectMaxRetry: 5
> 2015-05-14 03:53:04,339 INFO  [cloud.consoleproxy.ConsoleProxy]
> (Console-Proxy-Main:null) Property consoleproxy.tcpListenPort: 0
>
>               ..... and further on...
> 2015-05-14 03:53:04,344 INFO  [cloud.consoleproxy.ConsoleProxy]
> (Console-Proxy-Main:null) Property mgmtcidr: 192.2.0.1/24 -- I have 
> mgmt network at 172.17.0.0/24 and public net has /25 net mask so this 
> is totally wrong
>
> Should 443 port be mentioned here or consoleproxy.tcpListenPort: 0 is 
> bogus?
> How router replacement has interfered local process start-up ? Where 
> to search errors  -- cloud.out does not give me a hint about wrong behaviour?
>
>
> Please, help me to find the reason why listener is not starting.
>
>
> Thanks,
>
>
> Vadim
>


Mime
View raw message