cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <and...@arhont.com>
Subject ACS 4.5.1 KVM live migration problem
Date Tue, 12 May 2015 19:53:16 GMT
Hi, 

I am having an issue migrating some of vms after recently upgrading to ACS 4.5.1. I am running
Ubuntu 14.04 on both host and management servers. Here is the output from the log file on
a client agent : 


2015-05-12 20:42:34,154 DEBUG [kvm.resource.LibvirtComputingResource] (agentRequest-Handler-1:null)
Preparing host for migrating com.cloud.agent.api.to.VirtualMachineTO@21a038ac 
2015-05-12 20:42:34,157 DEBUG [kvm.resource.LibvirtConnection] (agentRequest-Handler-1:null)
can't find connection: KVM, for vm: i-9-1162-VM, continue 
2015-05-12 20:42:34,159 DEBUG [kvm.resource.LibvirtConnection] (agentRequest-Handler-1:null)
can't find connection: LXC, for vm: i-9-1162-VM, continue 
2015-05-12 20:42:34,159 DEBUG [kvm.resource.LibvirtConnection] (agentRequest-Handler-1:null)
can't find which hypervisor the vm used , then use the default hypervisor 
2015-05-12 20:42:34,160 DEBUG [kvm.resource.BridgeVifDriver] (agentRequest-Handler-1:null)
nic=[Nic:Guest-178.248.108.205-vlan://2014] 
2015-05-12 20:42:34,160 DEBUG [kvm.resource.BridgeVifDriver] (agentRequest-Handler-1:null)
creating a vNet dev and bridge for guest traffic per traffic label cloudstackbr0 
2015-05-12 20:42:34,160 DEBUG [kvm.resource.BridgeVifDriver] (agentRequest-Handler-1:null)
Executing: /usr/share/cloudstack-common/scripts/vm/network/vnet/modifyvlan.sh -v 2014 -p bond0
-b brbond0-2014 -o add 
2015-05-12 20:42:34,211 DEBUG [kvm.resource.BridgeVifDriver] (agentRequest-Handler-1:null)
Execution is successful. 
2015-05-12 20:42:34,211 DEBUG [kvm.resource.BridgeVifDriver] (agentRequest-Handler-1:null)
nic=[Nic:Guest-10.1.1.66-null] 
2015-05-12 20:42:34,212 DEBUG [kvm.storage.KVMStoragePoolManager] (agentRequest-Handler-1:null)
Disconnecting disk 23add201-e4ee-447b-a448-ecd152aea4ad 
2015-05-12 20:42:34,212 DEBUG [kvm.storage.LibvirtStorageAdaptor] (agentRequest-Handler-1:null)
Trying to fetch storage pool cf771bc7-8998-354d-8e10-5564585a3c20 from libvirt 
2015-05-12 20:42:34,223 DEBUG [kvm.storage.KVMStoragePoolManager] (agentRequest-Handler-1:null)
Disconnecting disk 55100d25-410e-4fa3-a38b-7717f74d2afe 
2015-05-12 20:42:34,223 DEBUG [kvm.storage.LibvirtStorageAdaptor] (agentRequest-Handler-1:null)
Trying to fetch storage pool cf771bc7-8998-354d-8e10-5564585a3c20 from libvirt 
2015-05-12 20:42:34,232 DEBUG [kvm.storage.KVMStoragePoolManager] (agentRequest-Handler-1:null)
Disconnecting disk 2db59d16-d17f-49a1-b913-7fbe4025a549 
2015-05-12 20:42:34,233 DEBUG [kvm.storage.LibvirtStorageAdaptor] (agentRequest-Handler-1:null)
Trying to fetch storage pool cf771bc7-8998-354d-8e10-5564585a3c20 from libvirt 
2015-05-12 20:42:34,243 DEBUG [kvm.storage.KVMStoragePoolManager] (agentRequest-Handler-1:null)
Disconnecting disk 17afbf31-ac89-46f7-a2c8-f8aed796e4c6 
2015-05-12 20:42:34,243 DEBUG [kvm.storage.LibvirtStorageAdaptor] (agentRequest-Handler-1:null)
Trying to fetch storage pool d8d5ec36-3cb0-39af-8fc6-084a4abd5d28 from libvirt 
2015-05-12 20:42:34,254 WARN [cloud.agent.Agent] (agentRequest-Handler-1:null) Caught: 
java.lang.NullPointerException 
at com.cloud.network.Networks$BroadcastDomainType.getSchemeValue(Networks.java:172) 
at com.cloud.network.Networks$BroadcastDomainType.getValue(Networks.java:226) 
at com.cloud.hypervisor.kvm.resource.BridgeVifDriver.plug(BridgeVifDriver.java:105) 
at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.execute(LibvirtComputingResource.java:3230)

at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.executeRequest(LibvirtComputingResource.java:1307)

at com.cloud.agent.Agent.processRequest(Agent.java:503) 
at com.cloud.agent.Agent$AgentRequestHandler.doTask(Agent.java:808) 
at com.cloud.utils.nio.Task.run(Task.java:84) 
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) 
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) 
at java.lang.Thread.run(Thread.java:745) 
2015-05-12 20:42:34,256 DEBUG [cloud.agent.Agent] (agentRequest-Handler-1:null) Seq 7-7525233502359390941:
{ Ans: , MgmtId: 115129173025118, via: 7, Ver: v1, Flags: 110, [{"com.cloud.agent.api.Answer":{"result":false,"details":"java.lang.NullPointerException\n\tat
com.cloud.network.Networks$BroadcastDomainType.getSchemeValue(Networks.java:172)\n\tat com.cloud.network.Networks$BroadcastDomainType.getValue(Networks.java:226)\n\tat
com.cloud.hypervisor.kvm.resource.BridgeVifDriver.plug(BridgeVifDriver.java:105)\n\tat com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.execute(LibvirtComputingResource.java:3230)\n\tat
com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.executeRequest(LibvirtComputingResource.java:1307)\n\tat
com.cloud.agent.Agent.processRequest(Agent.java:503)\n\tat com.cloud.agent.Agent$AgentRequestHandler.doTask(Agent.java:808)\n\tat
com.cloud.utils.nio.Task.run(Task.java:84)\n\tat java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)\n\tat
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)\n\tat java.lang.Thread.run(Thread.java:745)\n","wait":0}}]
} 



Any idea how to get this fixed? Not sure why all of a sudden the migration stopped working
for a handful of vms. I can successfully migrate some vms, but not others. 

Thanks 

Andrei 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message