cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan-Arve Nygård <jan.arve.nyg...@gmail.com>
Subject Re: XenServer 6.5
Date Fri, 24 Apr 2015 07:29:49 GMT
Tomasz:

Did you have dynamic scaling and HVM enabled for the Ubuntu 14.04 template
you tested with? If we change the OS-type to Ubuntu 12.04 (PV) or disable
dynamic scaling everything works as it should.

The disabling of intremap didn't solve this for us so we have locked the
issue down to affect snapshot w/memory / live migration for Ubuntu 14.04
(HVM). The hosts still crashes like earlier but no crash dump / kernel
panic is logged like earlier. We managed to get the data from serial port
so we have a case filed for this. However it would be very interesting to
know if this also affect others.


2015-04-10 13:36 GMT+02:00 Jan-Arve Nygård <jan.arve.nygard@gmail.com>:

> Yep! Btw, the host are HP ProLiant BL460c Gen9 so anyone with a similar
> setup can be aware of this.
>
> 2015-04-10 10:15 GMT+02:00 Vadim Kimlaychuk <Vadim.Kimlaychuk@elion.ee>:
>
>> Holy Moly ! This is something really important to consider. Luckiliy you
>> don't need to change motherboard and have workaround.
>>
>> Vadim.
>>
>> -----Original Message-----
>> From: Jan-Arve Nygård [mailto:jan.arve.nygard@gmail.com]
>> Sent: Thursday, April 09, 2015 6:36 PM
>> To: users@cloudstack.apache.org
>> Subject: Re: XenServer 6.5
>>
>> Even though the identifications steps don't match, disabling intremap in
>> XS
>> 6.5 seems to have solved the issue for us:
>> http://support.citrix.com/article/CTX136517
>>
>> 2015-04-08 22:15 GMT+02:00 Tomasz Zięba <t.a.zieba@gmail.com>:
>>
>> > Yes, XenTools65
>> >
>> > Regards,
>> > Tomasz Zięba
>> >
>> > Twitter: @TZieba
>> > LinkedIn: pl.linkedin.com/pub/tomasz-zięba-ph-d/3b/7a8/ab6/
>> <http://pl.linkedin.com/pub/tomasz-zi%C4%99ba-ph-d/3b/7a8/ab6/>
>> > <http://pl.linkedin.com/pub/tomasz-zi%C4%99ba-ph-d/3b/7a8/ab6/>
>> > <http://pl.linkedin.com/pub/tomasz-zi%C4%99ba-ph-d/3b/7a8/ab6/>
>> >
>> > sent from mobile
>> > 8 kwi 2015 21:17 "Jan-Arve Nygård" <jan.arve.nygard@gmail.com>
>> napisał(a):
>> >
>> > > Thanks for testing and feedback. I suppose you are using the tools
>> > provided
>> > > with XS 6.5 as well?
>> > >
>> > > I have sent our crash dumps to Citrix and are awaiting their analysis.
>> > Will
>> > > update with the root cause when it's found.
>> > >
>> > > -thinktwo
>> > >
>> > > 2015-04-08 20:56 GMT+02:00 Tomasz Zięba <t.a.zieba@gmail.com>:
>> > >
>> > > > Hi,
>> > > >
>> > > > Test 1
>> > > >
>> > > > 1. XS6.5 without updates
>> > > > 2. XenCenter only
>> > > > 3. Storage
>> > > > a) NFS primary storage
>> > > > b) FC primary storage
>> > > > 4. VM Ubuntu 14.04.02 with Tools
>> > > > 5. Snapshots
>> > > > a) VM Snapshots disks
>> > > > b) VM Snapshots disks and memory
>> > > >
>> > > > Test 2
>> > > >
>> > > > 1. XS6.5 all updates: XS65E001, XS65E002, XS65E003, XS65E005,
>> > > > XS65E006,
>> > > > XS65E008
>> > > > 2. XenCenter only
>> > > > 3. Storage
>> > > > a) NFS primary storage
>> > > > b) FC primary storage
>> > > > 4. VM Ubuntu 14.04.02 with Tools
>> > > > 5. Snapshots
>> > > > a) VM Snapshots disks
>> > > > b) VM Snapshots disks and memory
>> > > > Summary
>> > > > VM Reverts (with all combinations of hardware and updates) works
>> fine.
>> > > >
>> > > >
>> > > > --
>> > > > Regards,
>> > > > Tomasz Zięba
>> > > > Twitter: @TZieba
>> > > > LinkedIn: pl.linkedin.com/pub/tomasz-zięba-ph-d/3b/7a8/ab6/
>> <http://pl.linkedin.com/pub/tomasz-zi%C4%99ba-ph-d/3b/7a8/ab6/>
>> > <http://pl.linkedin.com/pub/tomasz-zi%C4%99ba-ph-d/3b/7a8/ab6/>
>> > > <http://pl.linkedin.com/pub/tomasz-zi%C4%99ba-ph-d/3b/7a8/ab6/>
>> > > > <http://pl.linkedin.com/pub/tomasz-zi%C4%99ba-ph-d/3b/7a8/ab6/>
>> > > > <http://pl.linkedin.com/pub/tomasz-zi%C4%99ba-ph-d/3b/7a8/ab6/>
>> > > >
>> > > > 2015-04-08 17:30 GMT+02:00 Jan-Arve Nygård
>> > > > <jan.arve.nygard@gmail.com
>> > >:
>> > > >
>> > > > > Thanks,
>> > > > >
>> > > > > We are running a build based on 4.5.1. Snapshots with memory
>> > > > > (from CloudStack or XenCenter) and a revert works as expected
>> > > > > with a CentOS
>> > > 6.6
>> > > > > install and XenServer 6.5 and the same version of
>> > xen-guest-utilities.
>> > > > >
>> > > > > I also just tested with a new install of Ubuntu 14.04.2 LTS from
>> > > running
>> > > > > kernel 3.16.0-30-generic #40~14.04.1-Ubuntu with a new
>> > > > > installation
>> > of
>> > > > > xe-guest-utilities_6.5.0-1400_amd64.deb installed (from Xens
>> > > > xs-tools.iso)
>> > > > > and the XenServer 6.5 hosts running the VM still crashed when
>> > > > > taking snapshot with memory.
>> > > > >
>> > > > > It would be very interesting to know if you also experience this
>> > > behavior
>> > > > > so let me know when you have had time to test it.
>> > > > >
>> > > > >
>> > > > > -thinktwo
>> > > > >
>> > > > > 2015-04-08 16:46 GMT+02:00 Vadim Kimlaychuk <
>> > Vadim.Kimlaychuk@elion.ee
>> > > >:
>> > > > >
>> > > > > > Hi,
>> > > > > >
>> > > > > >         This is really scary. Can test within couple of
days,
>> > > > > > but I
>> > > > will
>> > > > > > put 4.5.1 version as 4.5 is broken.  Memory snapshots are
not
>> > > available
>> > > > > for
>> > > > > > the XenServer as far as I know, but they just failed at
CS
>> before.
>> > > > Host
>> > > > > > did crash definately.
>> > > > > >
>> > > > > > Vadim.
>> > > > > >
>> > > > > > -----Original Message-----
>> > > > > > From: Jan-Arve Nygård [mailto:jan.arve.nygard@gmail.com]
>> > > > > > Sent: Wednesday, April 08, 2015 2:43 PM
>> > > > > > To: users@cloudstack.apache.org
>> > > > > > Subject: XenServer 6.5
>> > > > > >
>> > > > > > Hi all,
>> > > > > >
>> > > > > > We recently experienced a host crash on XenServer 6.5 (all
>> > available
>> > > > > > patches applied) when running snapshot of the virtual machines
>> > disks
>> > > > and
>> > > > > > memory. Snapshots of disks only (not memory) does not cause
a
>> > > XenServer
>> > > > > > crash. This happens both when initiating the snapshots from
>> > > CloudStack
>> > > > > 4.5
>> > > > > > or directly from XenServer/Center.
>> > > > > >
>> > > > > > We are able to reproduce this with Ubuntu 14.04.2 and
>> > > > xe-guest-utilities
>> > > > > > 6.5.0-1400, XenServer 6.5 with all available patches and
FC as
>> > > primary
>> > > > > > storage. We will continue to test with other
>> versions/combinations.
>> > > > > >
>> > > > > > Could someone else with XenServer 6.5 please try a full
>> > > > > > snapshot of
>> > > VM
>> > > > > > with disks and memory to see if you experience the same?
We
>> > > > > > have
>> > the
>> > > > > crash
>> > > > > > dumps and will report this but it would be useful with some
>> > > > > > more
>> > > > > feedback.
>> > > > > >
>> > > > > >
>> > > > > > Thanks,
>> > > > > >
>> > > > > > -thinktwo
>> > > > > >
>> > > > >
>> > > >
>> > >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message