cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mvs babu <mvsbabu0...@outlook.com>
Subject Re: CloudStack agent for HyperV
Date Mon, 20 Apr 2015 09:03:42 GMT
I have followed below steps to build CloudStack agent for Hyper-V in windows machine.



Follow instructions of step 1 at https://cwiki.apache.org/confluence/display/CLOUDSTACK/Setting+up+a+CloudStack+dev+environment+on+Windows



Don’t forget to select git, wget, vim, mv etc.. (mention in above link)

Download Mono from http://www.mono-project.com/download/#download-win and install it on windows
machine.



Execute below command in Cygwin with administrator privileges.

mozroots --import --ask-remove



Execute below command on Cygwin to clone CloudStack using git,  
git clone https://git-wip-us.apache.org/repos/asf/cloudstack.git



Set environment variable for mono in Windows, 
Goto MyComputer Properties --> Advanced system settings --> Environment Variables -->
Select Path from System Variables tab --> Append the value ";C:\Program Files (x86)\Mono\bin"
to Variable value and click ok.


Goto the path “cloudstack/plugins/hypervisors/hyperv/” and modify the shell script “buildagent.sh”
as follows

#!/bin/bash

export EnableNuGetPackageRestore=true

wget http://nuget.org/nuget.exe

mv nuget.exe ./DotNet/ServerResource/.nuget/NuGet.exe

chmod a+x ./DotNet/ServerResource/.nuget/NuGet.exe

if [ "$1" == "true" ] ; then

echo " skipping tests"

"/cyg/c/Program Files (x86)/Mono/bin/xbuild" /p:BuildWithMono="true" ./DotNet/ServerResource/ServerResource.sln

else

echo " running tests "

"/cyg/c/Program Files (x86)/Mono/bin/xbuild" /p:BuildWithMono="true" ./DotNet/ServerResource/ServerResource.sln

fi





In Cygwin you can execute  buildagent.sh script to build the agent.



After building you will get the output in /plugins/hypervisors/hyperv/DotNet/ServerResource/AgentShell/bin/Debug



That output folder can be zipped and can be distributed. In that output folder there is one
executable generated AgentShell.exe.



To install service, “AgentShell.exe --install -u <username> -p <password>”




References:

https://cwiki.apache.org/confluence/display/CLOUDSTACK/Creating+Hyperv+Agent+Installer

https://cwiki.apache.org/confluence/display/CLOUDSTACK/Setting+up+a+CloudStack+dev+environment+on+Windows

http://www.computerhope.com/issues/ch000549.htm


Thank you,

Suneel.





Sent from Windows Mail





From: jmoody
Sent: ‎Sunday‎, ‎April‎ ‎19‎, ‎2015 ‎12‎:‎33‎ ‎AM
To: cloudusersusers





Suneel,

Can you provide more explicit instructions as to what you set so that the documentation can
be updates to help others in the future?

Thanks,
Jeff
 

On Friday, April 17, 2015 02:35 EDT, mvs babu <mvsbabu0308@outlook.com> wrote: 
 
> Hi All,
> 
> 
> I am able to build CloudStack agent for HYperV by configuring mono as windows system
variable.
> 
> 
> Thank you,
> 
> Suneel.
> 
> 
> 
> 
> 
> 
> Sent from Windows Mail
> 
> 
> 
> 
> 
> From: mvs babu
> Sent: ‎Thursday‎, ‎April‎ ‎16‎, ‎2015 ‎7‎:‎51‎ ‎PM
> To: cloudusersusers
> 
> 
> 
> 
> 
> 
> Hi All,
> 
> I am trying to build CloudStack Agent for HyperV from Windows 8.1. When I am executing
buildagent.sh script it is giving below error. 
> 
> Please suggest how to resolve this error?
> 
> ------------------------------------------------------
> 
> mvs@Suneel ~/cloudstack-oss/cloudstack/plugins/hypervisors/hyperv
> 
> $ ./buildagent.sh
> 
> --2015-04-16 19:36:03-- http://nuget.org/nuget.exe
> 
> Resolving nuget.org (nuget.org)... 168.62.110.126
> 
> Connecting to nuget.org (nuget.org)|168.62.110.126|:80... connected.
> 
> HTTP request sent, awaiting response... 301 Moved Permanently
> 
> Location: http://www.nuget.org/nuget.exe [following]
> 
> --2015-04-16 19:36:03-- http://www.nuget.org/nuget.exe
> 
> Resolving www.nuget.org (www.nuget.org)... 168.62.110.126
> 
> Reusing existing connection to nuget.org:80.
> 
> HTTP request sent, awaiting response... 302 Found
> 
> Location: https://www.nuget.org/nuget.exe [following]
> 
> --2015-04-16 19:36:04-- https://www.nuget.org/nuget.exe
> 
> Connecting to www.nuget.org (www.nuget.org)|168.62.110.126|:443... connected.
> 
> HTTP request sent, awaiting response... 302 Found
> 
> Location: https://api.nuget.org/downloads/nuget.exe [following]
> 
> --2015-04-16 19:36:06-- https://api.nuget.org/downloads/nuget.exe
> 
> Resolving api.nuget.org (api.nuget.org)... 103.245.222.64
> 
> Connecting to api.nuget.org (api.nuget.org)|103.245.222.64|:443... connected.
> 
> HTTP request sent, awaiting response... 200 OK
> 
> Length: 1664512 (1.6M) [application/x-msdownload]
> 
> Saving to: ‘nuget.exe’
> 
> nuget.exe 100%[=========================================================================================================>]
1.59M 2.04MB/s in 0.8s
> 
> 2015-04-16 19:36:08 (2.04 MB/s) - ‘nuget.exe’ saved [1664512/1664512]
> 
> running tests
> 
> XBuild Engine Version 12.0
> 
> Mono, Version 3.12.1.0
> 
> Copyright (C) 2005-2013 Various Mono authors
> 
> Build started 04/16/2015 19:36:08.
> 
> __________________________________________________
> 
> Project "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\ServerResource.sln"
(default target(s)):
> 
> Target ValidateSolutionConfiguration:
> 
> Building solution configuration "Debug|Any CPU".
> 
> Target Build:
> 
> Project "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\WmiWrappers.csproj"
(default target(s)):
> 
> Target PrepareForBuild:
> 
> Configuration: Debug Platform: AnyCPU
> 
> Created directory "bin\Debug\"
> 
> Created directory "obj\Debug\"
> 
> Target ResolveAssemblyReferences:
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'AWSSDK' not resolved
> 
> For searchpath {CandidateAssemblyFiles}
> 
> Warning: {CandidateAssemblyFiles} not supported currently
> 
> For searchpath {HintPathFromItem}
> 
> Considered ..\packages\AWSSDK.1.5.23.0\lib\AWSSDK.dll, but it does not exist.
> 
> For searchpath {TargetFrameworkDirectory}
> 
> Considered 'C:\Program Files (x86)\Mono\lib\mono\4.5\nunit-console-runner.dll' as a file,
but it is an invalid assembly
> 
> Considered 'C:\Program Files (x86)\Mono\lib\mono\4.5\nunit.core.dll' as a file, but it
is an invalid assembly
> 
> Considered 'C:\Program Files (x86)\Mono\lib\mono\4.5\nunit.core.extensions.dll' as a
file, but it is an invalid assembly
> 
> Considered 'C:\Program Files (x86)\Mono\lib\mono\4.5\nunit.core.interfaces.dll' as a
file, but it is an invalid assembly
> 
> Considered 'C:\Program Files (x86)\Mono\lib\mono\4.5\nunit.framework.dll' as a file,
but it is an invalid assembly
> 
> Considered 'C:\Program Files (x86)\Mono\lib\mono\4.5\nunit.framework.extensions.dll'
as a file, but it is an invalid assembly
> 
> Considered 'C:\Program Files (x86)\Mono\lib\mono\4.5\nunit.mocks.dll' as a file, but
it is an invalid assembly
> 
> Considered 'C:\Program Files (x86)\Mono\lib\mono\4.5\nunit.util.dll' as a file, but it
is an invalid assembly
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5,
assembly named 'AWSSDK' not found.
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\Facades\,
assembly named 'AWSSDK' not found.
> 
> For searchpath {PkgConfig}
> 
> Considered AWSSDK, but could not find in any pkg-config files.
> 
> For searchpath {GAC}
> 
> Considered AWSSDK, but could not find in the GAC.
> 
> For searchpath {RawFileName}
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\AWSSDK'
as a file, but the file does not exist
> 
> For searchpath bin\Debug\
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\AWSSDK'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\AWSSDK.exe'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\AWSSDK.dll'
as a file, but the file does not exist
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'Ionic.Zip' not resolved
> 
> For searchpath {CandidateAssemblyFiles}
> 
> Warning: {CandidateAssemblyFiles} not supported currently
> 
> For searchpath {HintPathFromItem}
> 
> Considered ..\packages\DotNetZip.1.9.1.8\lib\net20\Ionic.Zip.dll, but it does not exist.
> 
> For searchpath {TargetFrameworkDirectory}
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5,
assembly named 'Ionic.Zip' not found.
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\Facades\,
assembly named 'Ionic.Zip' not found.
> 
> For searchpath {PkgConfig}
> 
> Considered Ionic.Zip, but could not find in any pkg-config files.
> 
> For searchpath {GAC}
> 
> Considered Ionic.Zip, but could not find in the GAC.
> 
> For searchpath {RawFileName}
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\Ionic.Zip'
as a file, but the file does not exist
> 
> For searchpath bin\Debug\
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Ionic.Zip'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Ionic.Zip.exe'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Ionic.Zip.dll'
as a file, but the file does not exist
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'log4net' not resolved
> 
> For searchpath {CandidateAssemblyFiles}
> 
> Warning: {CandidateAssemblyFiles} not supported currently
> 
> For searchpath {HintPathFromItem}
> 
> Considered ..\packages\log4net.2.0.0\lib\net40-full\log4net.dll, but it does not exist.
> 
> For searchpath {TargetFrameworkDirectory}
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5,
assembly named 'log4net' not found.
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\Facades\,
assembly named 'log4net' not found.
> 
> For searchpath {PkgConfig}
> 
> Considered log4net, but could not find in any pkg-config files.
> 
> For searchpath {GAC}
> 
> Considered log4net, but could not find in the GAC.
> 
> For searchpath {RawFileName}
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\log4net'
as a file, but the file does not exist
> 
> For searchpath bin\Debug\
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\log4net'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\log4net.exe'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\log4net.dll'
as a file, but the file does not exist
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'Newtonsoft.Json' not resolved
> 
> For searchpath {CandidateAssemblyFiles}
> 
> Warning: {CandidateAssemblyFiles} not supported currently
> 
> For searchpath {HintPathFromItem}
> 
> Considered ..\packages\Newtonsoft.Json.4.5.11\lib\net40\Newtonsoft.Json.dll, but it does
not exist.
> 
> For searchpath {TargetFrameworkDirectory}
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5,
assembly named 'Newtonsoft.Json' not found.
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\Facades\,
assembly named 'Newtonsoft.Json' not found.
> 
> For searchpath {PkgConfig}
> 
> Considered Newtonsoft.Json, but could not find in any pkg-config files.
> 
> For searchpath {GAC}
> 
> Considered Newtonsoft.Json, but could not find in the GAC.
> 
> For searchpath {RawFileName}
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\Newtonsoft.Json'
as a file, but the file does not exist
> 
> For searchpath bin\Debug\
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Newtonsoft.Json'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Newtonsoft.Json.exe'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Newtonsoft.Json.dll'
as a file, but the file does not exist
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'NSubstitute' not resolved
> 
> For searchpath {CandidateAssemblyFiles}
> 
> Warning: {CandidateAssemblyFiles} not supported currently
> 
> For searchpath {HintPathFromItem}
> 
> Considered ..\packages\NSubstitute.1.6.1.0\lib\NET40\NSubstitute.dll, but it does not
exist.
> 
> For searchpath {TargetFrameworkDirectory}
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5,
assembly named 'NSubstitute' not found.
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\Facades\,
assembly named 'NSubstitute' not found.
> 
> For searchpath {PkgConfig}
> 
> Considered NSubstitute, but could not find in any pkg-config files.
> 
> For searchpath {GAC}
> 
> Considered NSubstitute, but could not find in the GAC.
> 
> For searchpath {RawFileName}
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\NSubstitute'
as a file, but the file does not exist
> 
> For searchpath bin\Debug\
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\NSubstitute'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\NSubstitute.exe'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\NSubstitute.dll'
as a file, but the file does not exist
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'xunit' not resolved
> 
> For searchpath {CandidateAssemblyFiles}
> 
> Warning: {CandidateAssemblyFiles} not supported currently
> 
> For searchpath {HintPathFromItem}
> 
> Considered ..\packages\xunit.1.9.2\lib\net20\xunit.dll, but it does not exist.
> 
> For searchpath {TargetFrameworkDirectory}
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5,
assembly named 'xunit' not found.
> 
> Considered target framework dir C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\Facades\,
assembly named 'xunit' not found.
> 
> For searchpath {PkgConfig}
> 
> Considered xunit, but could not find in any pkg-config files.
> 
> For searchpath {GAC}
> 
> Considered xunit, but could not find in the GAC.
> 
> For searchpath {RawFileName}
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\xunit'
as a file, but the file does not exist
> 
> For searchpath bin\Debug\
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\xunit'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\xunit.exe'
as a file, but the file does not exist
> 
> Considered 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\xunit.dll'
as a file, but the file does not exist
> 
> Target GenerateSatelliteAssemblies:
> 
> No input files were specified for target GenerateSatelliteAssemblies, skipping.
> 
> Target CoreCompile:
> 
> Tool C:\Program Files (x86)\Mono\lib\mono\4.5\mcs.exe execution started with arguments:
/noconfig /debug:full /debug+ /optimize- /out:obj\Debug\WmiWrappers.dll ROOT.CIMV2.Win32_OperatingSystem.cs
root.CIMV2.Win32_PerfFormattedData_Counters_ProcessorInformation.cs ROOT.CIMV2.Win32_Processor.cs
ROOT.virtualization.v2.Msvm_ComputerSystem.cs ROOT.virtualization.v2.Msvm_ConcreteJob.cs ROOT.virtualization.v2.Msvm_EthernetPortAllocationSettingData.cs
ROOT.virtualization.v2.Msvm_EthernetSwitchPort.cs ROOT.virtualization.v2.Msvm_EthernetSwitchPortBandwidthSettingData.cs
ROOT.virtualization.v2.Msvm_EthernetSwitchPortVlanSettingData.cs ROOT.virtualization.v2.Msvm_ExternalEthernetPort.cs
ROOT.virtualization.v2.Msvm_ImageManagementService.cs ROOT.virtualization.v2.Msvm_KvpExchangeComponent.cs
ROOT.virtualization.v2.Msvm_KvpExchangeComponentSettingData.cs ROOT.virtualization.v2.Msvm_KvpExchangeDataItem.cs
ROOT.virtualization.v2.Msvm_LANEndpoint.cs ROOT.virtualization.v2.Msvm_MemorySettingData.cs
ROOT.virtualization.v2.Msvm_MigrationJob.cs ROOT.virtualization.v2.Msvm_ProcessorSettingData.cs
ROOT.virtualization.v2.Msvm_ResourceAllocationSettingData.cs ROOT.virtualization.v2.Msvm_ShutdownComponent.cs
ROOT.virtualization.v2.Msvm_StorageAllocationSettingData.cs ROOT.virtualization.v2.Msvm_StorageJob.cs
ROOT.virtualization.v2.Msvm_SummaryInformation.cs ROOT.virtualization.v2.Msvm_SyntheticEthernetPortSettingData.cs
ROOT.virtualization.v2.Msvm_VirtualEthernetSwitch.cs ROOT.virtualization.v2.Msvm_VirtualEthernetSwitchManagementService.cs
ROOT.virtualization.v2.Msvm_VirtualHardDiskSettingData.cs ROOT.virtualization.v2.Msvm_VirtualSystemManagementService.cs
ROOT.virtualization.v2.Msvm_VirtualSystemManagementServiceSettingData.cs ROOT.virtualization.v2.Msvm_VirtualSystemMigrationService.cs
ROOT.virtualization.v2.Msvm_VirtualSystemMigrationSettingData.cs ROOT.virtualization.v2.Msvm_VirtualSystemSettingData.cs
obj\Debug\.NETFramework,Version=v4.5.AssemblyAttribute.cs /target:library /define:"DEBUG;TRACE"
/nostdlib /reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.dll"
/reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Management.dll"
/reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Xml.Linq.dll"
/reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Data.DataSetExtensions.dll"
/reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\Microsoft.CSharp.dll"
/reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Data.dll"
/reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Xml.dll"
/reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\..\xbuild-frameworks\.NETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Core.dll"
/reference:"C:\Program Files (x86)\Mono\lib\mono\4.5\mscorlib.dll" /warn:4
> 
> Target DeployOutputFiles:
> 
> Copying file from 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\obj\Debug\WmiWrappers.dll.mdb'
to 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\WmiWrappers.dll.mdb'
> 
> Copying file from 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\obj\Debug\WmiWrappers.dll'
to 'C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\WmiWrappers.dll'
> 
> Done building project "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\WmiWrappers.csproj".
> 
> Project "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\HypervResource.csproj"
(default target(s)):
> 
> Target RestorePackages:
> 
> Executing: mono --runtime=v4.0.30319 C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\.nuget\NuGet.exe
install "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\packages.config"
-source "" -NonInteractive -RequireConsent -solutionDir "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\\"
> 
> 'mono' is not recognized as an internal or external command,
> 
> operable program or batch file.
> 
> C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\\.nuget\NuGet.targets:
error : Command 'mono --runtime=v4.0.30319 C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\.nuget\NuGet.exe
install "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\packages.config"
-source "" -NonInteractive -RequireConsent -solutionDir "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\\"
' exited with code: 1.
> 
> Task "Exec" execution -- FAILED
> 
> Done building target "RestorePackages" in project "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\HypervResource.csproj".--
FAILED
> 
> Done building project "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\HypervResource.csproj".--
FAILED
> 
> Task "MSBuild" execution -- FAILED
> 
> Done building target "Build" in project "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\ServerResource.sln".--
FAILED
> 
> Done building project "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\ServerResource.sln".--
FAILED
> 
> Build FAILED.
> 
> Warnings:
> 
> C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\ServerResource.sln
(default targets) ->
> 
> (Build target) ->
> 
> C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\WmiWrappers.csproj
(default targets) ->
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets (ResolveAssemblyReferences
target) ->
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'AWSSDK' not resolved
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'Ionic.Zip' not resolved
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'log4net' not resolved
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'Newtonsoft.Json' not resolved
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'NSubstitute' not resolved
> 
> C:\Program Files (x86)\Mono\lib\mono\4.5\Microsoft.Common.targets: warning : Reference
'xunit' not resolved
> 
> Errors:
> 
> C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\ServerResource.sln
(default targets) ->
> 
> (Build target) ->
> 
> C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\HypervResource.csproj
(default targets) ->
> 
> C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\\.nuget\NuGet.targets
(RestorePackages target) ->
> 
> C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\\.nuget\NuGet.targets:
error : Command 'mono --runtime=v4.0.30319 C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\.nuget\NuGet.exe
install "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\packages.config"
-source "" -NonInteractive -RequireConsent -solutionDir "C:\cygwin\home\mvs\cloudstack-oss\cloudstack\plugins\hypervisors\hyperv\DotNet\ServerResource\\"
' exited with code: 1.
> 
> 6 Warning(s)
> 
> 1 Error(s)
> 
> Time Elapsed 00:00:09.3104406
> -----------------------------------
> 
> 
> 
> Thank you,
> 
> Suneel.
> 
> 
> Sent from Windows Mail
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message