cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ching Lue <...@haystack.mit.edu>
Subject Using Boto to Interface with AWS compatible API
Date Wed, 04 Mar 2015 19:24:34 GMT
HI,

I had running the EC2 Boto example1 which is posted on
http://docs.cloudstack.apache.org/projects/cloudstack-installation/en/latest/optional_installation.html?highlight=ec2#supported-aws-api-calls

With Ubuntu and downloaded with "apt-get install python-boto", it will 
install the boto version 2.9.6,
then the above example works.

Later on I discovered that the newest boto is v2.36.0, after upgrade my 
boto tool, the above example
doesn't work any more,
I will get errors like this:

%python ec2_test.py
Traceback (most recent call last):
   File "ec2_test.py", line 33, in <module>
     main()
   File "ec2_test.py", line 24, in main
     images = conn.get_all_images()
   File "/usr/local/lib/python2.7/dist-packages/boto/ec2/connection.py", 
line 189, in get_all_images
     [('item', Image)], verb='POST')
   File "/usr/local/lib/python2.7/dist-packages/boto/connection.py", 
line 1185, in get_list
     raise self.ResponseError(response.status, response.reason, body)
boto.exception.EC2ResponseError: EC2ResponseError: 400 Bad Request
<?xml version="1.0" 
encoding="UTF-8"?><Response><Errors><Error><Code>MissingParamter</Code><Message>Missing

required parameter - 
AWSAccessKeyId</Message></Error></Errors><RequestID>c012537e-9f74-4673-90c2-c7fa5657a322</RequestID></Response>:

Can anyone enlight me what is going on with the latest boto V2.36.

Thank you very much.

Ching Lue

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message