cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Motty Cruz <motty.c...@gmail.com>
Subject Re: Job failed due to exception Unable to create a deployment for VM[User|i-2-192-VM] - ACS 4.4.1 XenServer 6.2
Date Wed, 18 Feb 2015 22:40:51 GMT
Hello Adriano,
I was not able to find the disk, however I found the UUID, took snapshot 
and exporting it to another cluster

[root@xen1 ~]# xe vdi-snapshot uuid=302df040-4306-45a4-a54e-e1256a0c24a3

f76d7726-7366-47c8-b9c1-1006b5132838

[root@xen1 ~]#

once I took the snapshot I plan to attach it to another VM;

[root@xen1 ~]# xe vdi-export uuid=f76d7726-7366-47c8-b9c1-1006b5132838 
filename= filename= | ssh 10.107.0.125 "dd of=/export/backup/hulk3dx.vdi"

root@10.107.0.125's password:

I would like to transfer data; A importing it to a xencenter cluster not 
manage by ACS, it a stand alone pool.

Thanks,
Motty



On 02/18/2015 01:35 PM, Adriano Paterlini wrote:
>
> Motty,
>
> Can you update logs. I am more used with NFS SRs than LUNs, are you 
> able to "ls" files at mounted folder? I would check if 
> fb60d71c-d161-4ac6-bff1-5508ec.vhd exists and using vhd-util confirm uuid.
>
> Em 18/02/2015 19:24, "Motty Cruz" <motty.cruz@gmail.com 
> <mailto:motty.cruz@gmail.com>> escreveu:
>
>     Thanks Adriano,
>
>     looks like Cloudstak is search for the disk in the wrong place. I
>     made a mistake of moving the virtual disk to another LUN using
>     XenCenter. I moved it back to its original place, however
>     Cloudstack complained about it.
>
>     Am still can't restart the VM.
>     mysql> SELECT folder,path,uuid,state FROM volumes WHERE name =
>     "ROOT-192";
>     +--------+--------------------------------------+--------------------------------------+---------+
>     | folder | path                                 | uuid            
>                  | state   |
>     +--------+--------------------------------------+--------------------------------------+---------+
>     | NULL   | fb60d71c-d161-4ac6-bff1-5508ec7b12a5 |
>     2cf5fc21-c6aa-4d39-80e7-f42696771877 | Ready   |
>     | /xen-3 | fb60d71c-d161-4ac6-bff1-5508ec7b12a5 |
>     3b219698-c57c-4a27-a172-7be4bdb1ac3d | Destroy |
>     | /xen-1 | fb60d71c-d161-4ac6-bff1-5508ec7b12a5 |
>     54763617-a7b8-4f15-9429-2d6fe68a69da | Destroy |
>     +--------+--------------------------------------+--------------------------------------+---------+
>     3 rows in set (0.00 sec)
>     mysql>
>
>     noticed is "NULL"
>     I manually updated now is showing ready:
>     mysql> SELECT folder,path,uuid,state FROM volumes WHERE name =
>     "ROOT-192";
>     +--------+--------------------------------------+--------------------------------------+---------+
>     | folder | path                                 | uuid            
>                  | state   |
>     +--------+--------------------------------------+--------------------------------------+---------+
>     | /xen-4 | fb60d71c-d161-4ac6-bff1-5508ec7b12a5 |
>     2cf5fc21-c6aa-4d39-80e7-f42696771877 | Ready   |
>     | /xen-3 | fb60d71c-d161-4ac6-bff1-5508ec7b12a5 |
>     3b219698-c57c-4a27-a172-7be4bdb1ac3d | Destroy |
>     | /xen-1 | fb60d71c-d161-4ac6-bff1-5508ec7b12a5 |
>     54763617-a7b8-4f15-9429-2d6fe68a69da | Destroy |
>     +--------+--------------------------------------+--------------------------------------+---------+
>     3 rows in set (0.00 sec)
>
>     mysql>
>
>     but unable to start VM. any ideas?
>     Thanks in Advance!
>     -Motty
>
>
>
>     On 02/18/2015 12:12 PM, Adriano Paterlini wrote:
>
>         Motty,
>
>         Did you use something like grep i-2-192-VM, to view and send
>         the logs? If
>         its is the case, I recommend using #grep -A 10 to include some
>         lines after,
>         I would expect some java exception after lines like:
>
>         Unable to start i-2-192-VM due to
>
>         Regards,
>         Adriano
>
>         On Wed, Feb 18, 2015 at 2:09 PM, Somesh Naidu
>         <Somesh.Naidu@citrix.com <mailto:Somesh.Naidu@citrix.com>>
>         wrote:
>
>             Motty,
>
>             Yeah, a VM won't exist on XS unless it is powered on. CCP
>             will destroy the
>             VM (domain) as soon as the VM is halted. Only the root
>             disk VDI will remain.
>
>             The mgmt. logs you shared point at "
>             InsufficientServerCapacityException"
>             though it is not clear what resource. A deeper look at the
>             mgmt. logs will
>             reveal more details. Try doing - grep "
>             DirectAgent-27:ctx-5720dc90" - and
>             see if you get more information related to the error.
>
>             Regards,
>             Somesh
>
>
>             -----Original Message-----
>             From: Motty Cruz [mailto:motty.cruz@gmail.com
>             <mailto:motty.cruz@gmail.com>]
>             Sent: Wednesday, February 18, 2015 10:53 AM
>             To: users@cloudstack.apache.org
>             <mailto:users@cloudstack.apache.org>
>             Subject: Re: Job failed due to exception Unable to create
>             a deployment for
>             VM[User|i-2-192-VM] - ACS 4.4.1 XenServer 6.2
>
>             Hello ilya,
>             I can't power VM on Xen directly because I don't see it,
>             xe vm-list, I
>             believe Cloudstack keep that in secondary storage. Does
>             anybody know how
>             to force power directly on xen?
>
>             Thanks,
>             Motty
>             On 02/17/2015 11:43 PM, ilya musayev wrote:
>
>                 Motty
>
>                 I'm not a Xen person, but looking at the logs, i dont
>                 see any specific
>                 error. Would you please check logs on XenServer?
>                 Can you force power on VM on Xen directly to see what
>                 happens?
>
>                 Regards,
>                 ilya
>                 On 2/17/15 2:35 PM, Motty Cruz wrote:
>
>                     Hello, I am unable to start VM in Cloudstack, I
>                     get a very generic
>                     error, unable to create deployment. I was working,
>                     however I need to
>                     detach a 2nd disk. I shutdown the VM, detach the
>                     2nd Disk, restart
>                     the VM. however, am unable to restart now. please
>                     help!
>
>                     Job failed due to exception Unable to create a
>                     deployment for
>                     VM[User|i-2-192-VM]
>                     here is the logs:
>                     http://pastebin.com/raw.php?i=6RjTSduU
>
>
>                     -Motty
>
>
>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message