cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Weber <terbol...@gmail.com>
Subject Re: booting instances via pxe/tftp
Date Mon, 26 Jan 2015 12:14:16 GMT
I've used the iPXE iso to boot successfully multiple times. Requires
nothing on the hypervisor as far as I know, but I don't know how it works
after you have an OS installed (I'm using it to bootstrap machines).

-- 
Erik

On Mon, Jan 26, 2015 at 12:52 PM, Stephan Seitz <
s.seitz@secretresearchfacility.com> wrote:

> Hi all,
>
> I'm trying to boot instances via pxe. During my experiments that worked
> a few times, but I've tried a lot and didn't document my single steps as
> needed :/ Never got to a "stable" point.
>
> By now, I'm quite unsure if a particular vm tries to boot pxe with the
> default boot-order (HVM d,c)
>
> For some VM's i've changed that to
>
> xe vm-param-clear uuid=$VMUUID param-name=HVM-boot-params
> xe vm-param-set uuid=$VMUUID HVM-boot-params: order="n"
>
> the BIOS output didn't change. For other Boot-Options it says, one has
> to press F12 (which is quite impossible due to the fact it's far to fast
> skipped. Not to mention usual browsers have there own interpretation of
> the "F"-Keys...).
>
> Maybe the timeout can also be set, but I didn't find any option for
> that, neither in ACS nor in XenServer.
>
> - Stephan
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message