cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohamed Infaz <infaz...@cse.mrt.ac.lk>
Subject Re: SSVM agent state is Disconnected
Date Tue, 13 Jan 2015 15:57:42 GMT
Hi Abdul,

Can you ping the SSVM and also i am not sure that whether the agent is
running on the host machine. Make sure the agent is running and also check
whether you can download a ISO image. If it doesn't work out then try to
reinstall the system vm's.

Thank you.

On 13 January 2015 at 21:08, Abdul Rasool <rasoolsam@gmail.com> wrote:

> Hi,
>
> Can some one help me with my issue posted below.
>
> My SSVM agent is in disconnected state also when I try to mount it manually
> it is giving me connection timeout. but primary store is mounted in my
> hypervisors.
>
> as per the connectivity part I can able to reach out to NFS storage server
>
> Please help me what could be the issue
>
> Thanks
> AR
>
> On 12 January 2015 at 17:44, Abdul Rasool <rasoolsam@gmail.com> wrote:
>
> > Hi Gopal,
> >
> > Thanks for your reply.
> >
> > When I restarted management process I get this below logs. also I have
> > checked my hypersivor cloudstack-agent process is running.
> >
> > This same setup was working till the maintenance after all the management
> > & hypervisor are rebooted I am facing this issue.
> >
> >
> >
> > *Management Log :-*
> >
> > root@cloud-mgmt001:~# /etc/init.d/cloudstack-management restart
> >  * Stopping CloudStack-specific Tomcat servlet engine
> > cloudstack-management
> >               [ OK ]
> >  * Starting CloudStack-specific Tomcat servlet engine
> > cloudstack-management
> >               [ OK ]
> > root@cloud-mgmt001:~# tail -f
> > /var/log/cloudstack/management/management-server.log | grep -i -E
> > 'exception|unable|fail|invalid|leak|warn|error'
> >
> > 2015-01-12 16:56:56,670 DEBUG [c.c.s.ConfigurationServerImpl] (main:null)
> > mount: warning: /var/lib/cloud/management/systemvm_mnt seems to be
> mounted
> > read-only.
> > 2015-01-12 16:56:56,843 ERROR [c.c.c.ClusterManagerImpl] (main:null)
> > Unable to ping management server at 172.16.206.50:9090 due to
> > ConnectException
> > java.net.ConnectException: Connection refused
> > 2015-01-12 16:56:57,551 WARN  [c.c.s.d.DownloadMonitorImpl] (main:null)
> > Only realhostip.com ssl cert is supported, ignoring self-signed and
> other
> > certs
> > 2015-01-12 16:56:57,730 WARN  [c.c.c.ConsoleProxyManagerImpl] (main:null)
> > Empty console proxy domain, explicitly disabling SSL
> > 2015-01-12 16:57:10,073 INFO  [c.c.h.x.r.XenServerConnectionPool]
> > (main:null) XenServer Connection Pool Configs:
> sleep.interval.on.error=10000
> > 2015-01-12 16:57:13,570 WARN  [o.a.c.alerts]
> > (Cluster-Notification-1:ctx-6e6c9629)  alertType:: 14 // dataCenterId:: 0
> > // podId:: 0 // clusterId:: null // message:: Management server node
> > 172.16.206.50 is up
> > 2015-01-12 16:57:13,805 WARN  [c.c.c.ClusterManagerImpl]
> > (Cluster-Notification-1:ctx-6e6c9629) Notifying management server join
> > event took 379 ms
> > 2015-01-12 16:57:15,096 WARN  [c.c.a.m.AgentManagerImpl]
> > (AgentManager-Handler-5:null) Throwing away a request because it came
> > through as the first command on a connect: Seq 0-41800:  { Cmd , MgmtId:
> > -1, via: 0, Ver: v1, Flags: 11,
> >
> [{"com.cloud.agent.api.PingCommand":{"hostType":"ConsoleProxy","hostId":0,"wait":0}}]
> > }
> > 2015-01-12 16:57:15,725 WARN  [c.c.a.m.AgentManagerImpl]
> > (AgentManager-Handler-10:null) Throwing away a request because it came
> > through as the first command on a connect: Seq 0-5358:  { Cmd , MgmtId:
> -1,
> > via: 0, Ver: v1, Flags: 11,
> >
> [{"com.cloud.agent.api.PingRoutingWithNwGroupsCommand":{"newGroupStates":{},"newStates":{},"_hostVmStateReport":{"i-2-53-VM":{"state":"PowerOn","host":"
> > cloud-node002.omnesysindia.com
> "}},"_gatewayAccessible":true,"_vnetAccessible":true,"hostType":"Routing","hostId":0,"wait":0}}]
> > }
> > 2015-01-12 16:57:22,770 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-5:ctx-1ac3e02a ctx-a266ead6) Received unknown parameters
> for
> > command listRegions. Unknown parameters : listall
> > 2015-01-12 16:57:25,543 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-8:ctx-5f1a2859 ctx-4c8c7bcd) Received unknown parameters
> for
> > command listZones. Unknown parameters : listall
> > 2015-01-12 16:57:25,634 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-12:ctx-c25a0f76 ctx-ca7dd015) Received unknown parameters
> > for command listPods. Unknown parameters : listall
> > 2015-01-12 16:57:25,725 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-1:ctx-3c89ae04 ctx-4976b536) Received unknown parameters
> for
> > command listClusters. Unknown parameters : listall
> > 2015-01-12 16:57:25,804 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-13:ctx-bf36c88a ctx-44742f02) Received unknown parameters
> > for command listHosts. Unknown parameters : listall
> > 2015-01-12 16:57:25,916 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-16:ctx-86e57b7a ctx-5f80737e) Received unknown parameters
> > for command listStoragePools. Unknown parameters : listall
> > 2015-01-12 16:57:26,028 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-15:ctx-eec3ccc8 ctx-7c2755dd) Received unknown parameters
> > for command listImageStores. Unknown parameters : listall type
> > 2015-01-12 16:57:26,124 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-14:ctx-0ba82b9f ctx-e9be8cb7) Received unknown parameters
> > for command listSystemVms. Unknown parameters : listall
> > 2015-01-12 16:57:26,787 WARN  [c.c.a.m.AgentManagerImpl]
> > (StatsCollector-1:ctx-3872619a) Unsupported Command: Unsupported command
> > issued:com.cloud.agent.api.GetGPUStatsCommand.  Are you sure you got the
> > right type of server?
> > 2015-01-12 16:57:26,801 WARN  [c.c.a.m.AgentManagerImpl]
> > (StatsCollector-1:ctx-3872619a) Unsupported Command: Unsupported command
> > issued:com.cloud.agent.api.GetGPUStatsCommand.  Are you sure you got the
> > right type of server?
> > 2015-01-12 16:57:28,292 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-2:ctx-77d34862 ctx-7aa6f791) Received unknown parameters
> for
> > command listSystemVms. Unknown parameters : listall
> > 2015-01-12 16:57:28,557 WARN  [c.c.a.d.ParamGenericValidationWorker]
> > (catalina-exec-5:ctx-41c86850 ctx-38e47f1f) Received unknown parameters
> for
> > command listHosts. Unknown parameters : listall
> > 2015-01-12 16:58:11,022 WARN  [o.a.c.f.j.AsyncJobExecutionContext]
> > (UserVm-Scavenger-1:ctx-fc82b0e0) Job is executed without a context,
> setup
> > psudo job for the executing thread
> > 2015-01-12 16:58:11,162 WARN  [c.c.u.d.Merovingian2]
> > (UserVm-Scavenger-1:ctx-fc82b0e0) Was unable to find lock for the key
> > vm_instance45 and thread id 767297483
> > 2015-01-12 16:58:13,341 WARN  [c.c.v.UserVmManagerImpl]
> > (UserVm-Scavenger-1:ctx-fc82b0e0) Unable to expunge VM[User|i-2-45-VM]
> > com.cloud.utils.exception.CloudRuntimeException: Unable to locate
> > datastore with id 3
> > 2015-01-12 17:00:13,366 WARN  [o.a.c.f.j.AsyncJobExecutionContext]
> > (UserVm-Scavenger-1:ctx-dcb1cf38) Job is executed without a context,
> setup
> > psudo job for the executing thread
> > 2015-01-12 17:00:13,385 WARN  [c.c.u.d.Merovingian2]
> > (UserVm-Scavenger-1:ctx-dcb1cf38) Was unable to find lock for the key
> > vm_instance45 and thread id 767297483
> > 2015-01-12 17:00:15,489 WARN  [c.c.v.UserVmManagerImpl]
> > (UserVm-Scavenger-1:ctx-dcb1c
> >
> >
> > *Hypervisor Log :- *
> >
> > When I reload the cloudstack-agent on hypervisor I got this below error.
> > but all my VMs are working.
> >
> > 2015-01-12 17:40:51,742 DEBUG [kvm.resource.LibvirtComputingResource]
> > (main:null) failing to get physical interface from bridge cloud0, did not
> > find an eth*, bond*, vlan*, em*, or p*p* in
> > /sys/devices/virtual/net/cloud0/brif
> > 2015-01-12 17:40:51,744 DEBUG [kvm.resource.LibvirtComputingResource]
> > (main:null) failing to get physical interface from bridge virbr0, did not
> > find an eth*, bond*, vlan*, em*, or p*p* in
> > /sys/devices/virtual/net/virbr0/brif
> > 2015-01-12 17:40:52,949 WARN  [kvm.resource.LibvirtComputingResource]
> > (Agent-Handler-1:null) Could not read cpuinfo_max_freq
> >
> >
> > Please help me on this.
> >
> > Thanks
> > AR
> >
> > On 12 January 2015 at 17:29, Gopalakrishnan S <gopal@assistanz.com>
> wrote:
> >
> >> Hi Abdul,
> >>
> >> Did you check the management server logs when you try to reconnect your
> >> agent?
> >> Check the agant status in your hypervisor machine.
> >>
> >> Please make sure you haven't any issue with the firewall.
> >>
> >> Thank You.
> >> Gopalakrishnan.S
> >>
> >>   ----- Original Message -----
> >>   From: Abdul Rasool
> >>   To: users@cloudstack.apache.org
> >>   Sent: Monday, January 12, 2015 5:03 PM
> >>   Subject: SSVM agent state is Disconnected
> >>
> >>
> >>   Hi,
> >>
> >>
> >>   After rebooting my management & hypervisor server my SSVM agent state
> >> is showing disconnected. could you please help me to fix this issue.
> >>
> >>
> >>
> >>
> >>
> >>
> >>    ACS .4.4.1
> >>   Management server with NFS (Ubuntu 12.04 64bit)
> >>   Hypervisor = KVM(Ubuntu 12.04 64bit)
> >>
> >>
> >>
> >>
> >>   OS = Ubuntu
> >>
> >>
> >>   Thanks
> >>   AR
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message