cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Duffy <...@ianduffy.ie>
Subject Re: The Simplest way to Run CloudStack on VirtualBox
Date Sun, 16 Nov 2014 18:15:01 GMT
Hi Imesh,

I'm going to need a lot more logs than that. You should be able to find
them in /var/log/cloudstack/management.

On 16 November 2014 18:06, Imesh Gunaratne <imesh@apache.org> wrote:

> Thanks again Ian! Appreciate all the help and information!
>
> I imported Ubuntu 12.04 64bit iso into the templates and tried to spawn an
> instance out of it, here I noticed the below error:
>
> Unable to create a deployment for
> VM[User|VM-dd218219-06c5-4b5e-affb-ae8a6f19f19e]
>
> I could find the following information in the events:
> Failed to deploy Vm with Id: 20, on Host with Id: null
>
> On Sun, Nov 16, 2014 at 10:35 AM, Ian Duffy <ian@ianduffy.ie> wrote:
>
> > Great to hear Imesh. If you hit any more issues just shout.
> >
> > Thinks to keep in mind.... Devcloud runs VMs in PV mode. When you upload
> an
> > ISO it will be registered as hvm only. There's a HVM flag in the DB under
> > the templates table you can flick to 0 so it boots on PV.
> >
> > Ubuntu will install no problem just make sure you do it on a service
> > offering that gives 256mb of ram.
> >
> > Also keep in mind the default CloudStack service offerings are set to use
> > shared storage. In devcloud we only have local storage.
> >
> > If your machine has lots of ram 16gb> let me know and we can discuss
> giving
> > more ram to the hypervisor and system VMS to get better performance.
> > On 16 Nov 2014 03:17, "Imesh Gunaratne" <imesh@apache.org> wrote:
> >
> > > Hi Ian,
> > >
> > > Great! It worked! The vagrant binary advanced installation completed
> > > succefully and I was able to access the CloudStack client without any
> > > problem. It has also executed the deployment configuration with Marvin
> > > successfully.
> > >
> > > Thank you very much for your help! I'm now going to create an Ubuntu
> > > template and integrate Stratos with it.
> > >
> > > Many Thanks
> > >
> > > On Sun, Nov 16, 2014 at 8:23 AM, Imesh Gunaratne <imesh@apache.org>
> > wrote:
> > >
> > > > Hi Ian,
> > > >
> > > > Thanks for the quick response, I just started a new installation with
> > > your
> > > > latest changes. Will let you know the status soon. Appreciate it.
> > > >
> > > > Many Thanks
> > > >
> > > > On Sun, Nov 16, 2014 at 6:35 AM, Thomas Munn <symgryph@gmail.com>
> > wrote:
> > > >
> > > >> What is the URL for the new branch?
> > > >>
> > > >> Sent from my iPad
> > > >>
> > > >> > On Nov 15, 2014, at 17:44, Ian Duffy <ian@ianduffy.ie>
wrote:
> > > >> >
> > > >> > That almost looks like a vagrant-omnibus book.... 11.16.0 is
a
> valid
> > > >> > version.
> > > >> >
> > > >> > Anyways, I've changed it to use :latest.
> > > >> >
> > > >> > Can you do a git pull again? Should hopefully fix it.
> > > >> >
> > > >> > My testing just finished, It worked successfully with the earlier
> > > >> changes.
> > > >> >
> > > >> >> On 15 November 2014 22:08, Imesh Gunaratne <imesh@apache.org>
> > wrote:
> > > >> >>
> > > >> >> Hi Ian,
> > > >> >>
> > > >> >> I got your fix and did another test, I see the below error
with
> the
> > > >> latest
> > > >> >> changes:
> > > >> >>
> > > >> >> ==> management: Machine booted and ready!
> > > >> >> ==> management: Checking for guest additions in VM...
> > > >> >> ==> management: Configuring and enabling network interfaces...
> > > >> >> ==> management: Mounting shared folders...
> > > >> >>    management: /vagrant =>
> > > >> >>
> > > >> >>
> > > >>
> > >
> >
> /Users/imesh/sandboxes/apache/cloudstack/vagrant/devcloud4/binary-installation-advanced
> > > >> >>    management: /tmp/vagrant-chef-2/chef-solo-1/cookbooks
=>
> > > >> >>
> > > >> >>
> > > >>
> > >
> >
> /Users/imesh/sandboxes/apache/cloudstack/vagrant/devcloud4/common/management/cookbooks
> > > >> >> There are errors in the configuration of this machine. Please
fix
> > > >> >> the following errors and try again:
> > > >> >>
> > > >> >> vagrant-omnibus:
> > > >> >> * '11.16.0' is not a valid version of Chef.
> > > >> >>
> > > >> >> Many Thanks
> > > >> >>
> > > >> >>> On Sun, Nov 16, 2014 at 3:28 AM, Imesh Gunaratne <
> > imesh@apache.org>
> > > >> wrote:
> > > >> >>>
> > > >> >>> Great thanks Ian, will do a vagrant destroy, vagrant
up now.
> > > >> >>>
> > > >> >>> Thanks
> > > >> >>>
> > > >> >>> On Sun, Nov 16, 2014 at 3:24 AM, Ian Duffy <ian@ianduffy.ie>
> > wrote:
> > > >> >>>
> > > >> >>>>> No problem at all, I really appreciate your help
on this.
> > > >> >>>>
> > > >> >>>> No worries, the breaks are my fault. I often forget
how many
> > > linking
> > > >> >>>> dependencies are involved with devcloud.
> > > >> >>>>
> > > >> >>>> I'm after pushing a fix for the marvin issue, you
can do a git
> > pull
> > > >> and
> > > >> >>>> try
> > > >> >>>> do a vagrant destroy vagrant up if you wish. I'm
testing it at
> > the
> > > >> >> moment
> > > >> >>>> if you prefer to wait :)
> > > >> >>>>
> > > >> >>>>> On 15 November 2014 21:48, Imesh Gunaratne <imesh@apache.org>
> > > >> wrote:
> > > >> >>>>>
> > > >> >>>>> Hi Ian,
> > > >> >>>>>
> > > >> >>>>> No problem at all, I really appreciate your help
on this.
> > > >> >>>>>
> > > >> >>>>> Asanka: I tried your instructions but the marvin
deploy
> command
> > > >> fails
> > > >> >>>> with
> > > >> >>>>> the following:
> > > >> >>>>>
> > > >> >>>>> 2014-11-15 21:43:39,438 - DEBUG - Parsing Test
data successful
> > > >> >>>>> 2014-11-15 21:43:39,438 - DEBUG - Payload: {'account':
> 'admin',
> > > >> >>>> 'command':
> > > >> >>>>> 'listUsers', 'response': 'json'}
> > > >> >>>>> 2014-11-15 21:43:39,438 - DEBUG - ========Sending
GET Cmd :
> > > >> >>>>> listUsers=======
> > > >> >>>>> 2014-11-15 21:43:39,467 - ERROR - __sendGetReqToCS
: Exception
> > > >> >> Occurred:
> > > >> >>>>> ('Connection aborted.', error(111, 'Connection
refused'))
> > > >> >>>>>
> > > >> >>>>> May be the xenserver credentials provided (root/password)
are
> > not
> > > >> >>>> correct.
> > > >> >>>>>
> > > >> >>>>> Many Thanks
> > > >> >>>>>
> > > >> >>>>>> On Sun, Nov 16, 2014 at 3:09 AM, Ian Duffy
<ian@ianduffy.ie>
> > > >> wrote:
> > > >> >>>>>>
> > > >> >>>>>> Hi Imesh,
> > > >> >>>>>>
> > > >> >>>>>> Sorry about that. I've moved some things
around recently. I
> > will
> > > >> >> push
> > > >> >>>>> out a
> > > >> >>>>>> fix for that.
> > > >> >>>>>>
> > > >> >>>>>> On 15 November 2014 21:27, Asanka sanjaya
Herath <
> > > >> >> angal.sh@gmail.com>
> > > >> >>>>>> wrote:
> > > >> >>>>>>
> > > >> >>>>>>> Hi Imesh,
> > > >> >>>>>>>
> > > >> >>>>>>> If the management server is up, I think
you don't need to
> run
> > > >> >>>> 'vagrant
> > > >> >>>>>> up'
> > > >> >>>>>>> command again. So try follow these steps.
> > > >> >>>>>>>
> > > >> >>>>>>> 1. Find the Marvin-0.1.0.tar.gz from
a locally build
> > repository
> > > of
> > > >> >>>>>>> cloudstack.
> > > >> >>>>>>> 2. Run this command. "pip install Marvin-0.1.0.tar.gz"
> > > >> >>>>>>> 3. Change IPs in advanced/advanced.json
file according to
> vbox
> > > >> >>>>>>> adapters(22-24).
> > > >> >>>>>>> 4. Run this command. python -m marvin.deployDataCenter
-i
> > > >> >>>>>>> advanced/advanced.json
> > > >> >>>>>>>
> > > >> >>>>>>>
> > > >> >>>>>>>
> > > >> >>>>>>> On Sun, Nov 16, 2014 at 1:06 AM, Imesh
Gunaratne <
> > > >> >> imesh@apache.org>
> > > >> >>>>>> wrote:
> > > >> >>>>>>>
> > > >> >>>>>>>> Hi Ian,
> > > >> >>>>>>>>
> > > >> >>>>>>>> Great! Thanks! Your suggestion worked,
the advance binary
> > > >> >>>>> installation
> > > >> >>>>>>> went
> > > >> >>>>>>>> much far afterwards. Now I can see
the below error, seems
> > like
> > > >> >> the
> > > >> >>>>>> marvin
> > > >> >>>>>>>> tar is not there at the below link:
> > > >> >>>>>>>>
> > > >> >>>>>>>> http://ianduffy.ie/Marvin-0.1.0.tar.gz
> > > >> >>>>>>>>
> > > >> >>>>>>>> ==> management: [2014-11-15T19:26:55+00:00]
INFO:
> > > >> >>>>>>>> template[/etc/sysconfig/nfs] sending
restart action to
> > > >> >>>> service[nfs]
> > > >> >>>>>>>> (delayed)
> > > >> >>>>>>>> ==> management: [2014-11-15T19:26:59+00:00]
INFO:
> > service[nfs]
> > > >> >>>>>> restarted
> > > >> >>>>>>>> ==> management: [2014-11-15T19:26:59+00:00]
INFO:
> > > >> >>>>>> template[/etc/exports]
> > > >> >>>>>>>> sending run action to execute[exportfs]
(delayed)
> > > >> >>>>>>>> ==> management: [2014-11-15T19:26:59+00:00]
INFO:
> > > >> >>>> execute[exportfs]
> > > >> >>>>> ran
> > > >> >>>>>>>> successfully
> > > >> >>>>>>>> ==> management: [2014-11-15T19:26:59+00:00]
ERROR: Running
> > > >> >>>> exception
> > > >> >>>>>>>> handlers
> > > >> >>>>>>>> ==> management: [2014-11-15T19:26:59+00:00]
ERROR:
> Exception
> > > >> >>>> handlers
> > > >> >>>>>>>> complete
> > > >> >>>>>>>> ==> management: [2014-11-15T19:26:59+00:00]
FATAL:
> Stacktrace
> > > >> >>>> dumped
> > > >> >>>>> to
> > > >> >>>>>>>> /var/chef/cache/chef-stacktrace.out
> > > >> >>>>>>>> ==> management: [2014-11-15T19:26:59+00:00]
ERROR:
> > bash[Install
> > > >> >>>>>>> Cloudstack
> > > >> >>>>>>>> Marvin] (cloudstack::management-server
line 67) had an
> error:
> > > >> >>>>>>>> Mixlib::ShellOut::ShellCommandFailed:
Expected process to
> > exit
> > > >> >>>> with
> > > >> >>>>>> [0],
> > > >> >>>>>>>> but received '2'
> > > >> >>>>>>>> ==> management: ---- Begin output
of "bash"
> > > >> >>>>>>>> "/tmp/chef-script20141115-3008-8jnekm"
----
> > > >> >>>>>>>> ==> management: STDOUT: Downloading/unpacking
> > > >> >>>>>>>> http://ianduffy.ie/Marvin-0.1.0.tar.gz
> > > >> >>>>>>>> ==> management:   HTTP error 404
while getting
> > > >> >>>>>>>> http://ianduffy.ie/Marvin-0.1.0.tar.gz
> > > >> >>>>>>>> ==> management: Cleaning up...
> > > >> >>>>>>>>
> > > >> >>>>>>>> While seeing this error I tried to
access the CloudStack
> > > >> >> console (
> > > >> >>>>>>>> http://localhost:8080/client) and
it seems to be working.
> Do
> > > >> >> you
> > > >> >>>>>> think I
> > > >> >>>>>>>> can ignore the above error and use
CloudStack or will I
> need
> > to
> > > >> >>>> fix
> > > >> >>>>> it
> > > >> >>>>>>> and
> > > >> >>>>>>>> re-install?
> > > >> >>>>>>>>
> > > >> >>>>>>>> Really appreciate your help.
> > > >> >>>>>>>>
> > > >> >>>>>>>> Many Thanks
> > > >> >>>>>>>>
> > > >> >>>>>>>> On Sun, Nov 16, 2014 at 12:29 AM,
Ian Duffy <
> ian@ianduffy.ie
> > >
> > > >> >>>> wrote:
> > > >> >>>>>>>>
> > > >> >>>>>>>>> Hi Imesh,
> > > >> >>>>>>>>>
> > > >> >>>>>>>>> Yes use 192.168.22.1 - 192.168.24.1.
Sorry I meant to add
> a
> > > >> >> /24
> > > >> >>>>>> prefix
> > > >> >>>>>>> in
> > > >> >>>>>>>>> on my original email.
> > > >> >>>>>>>>>
> > > >> >>>>>>>>> On 15 November 2014 18:16, Imesh
Gunaratne <
> > imesh@apache.org>
> > > >> >>>>> wrote:
> > > >> >>>>>>>>>
> > > >> >>>>>>>>>> Hi Ian,
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>> Thanks again for the quick
feedback. Yes it was my
> fault, I
> > > >> >>>> have
> > > >> >>>>>> used
> > > >> >>>>>>>>> some
> > > >> >>>>>>>>>> other IPv4 addresses in hostonly
vboxnet adapters. I just
> > > >> >>>> started
> > > >> >>>>>>>> another
> > > >> >>>>>>>>>> test with the ones you have
mentioned.
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>> Just to clarify, the README
file in the devcloud4 says to
> > > >> >> set
> > > >> >>>>> these
> > > >> >>>>>>>>> values
> > > >> >>>>>>>>>> to 192.168.22.1 - 192.168.24.1.
Would there be any
> > > >> >> difference?
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>> Thanks
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>> On Sat, Nov 15, 2014 at 3:59
PM, Ian Duffy <
> > ian@ianduffy.ie
> > > >> >>>
> > > >> >>>>>> wrote:
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>>> Hi Imesh,
> > > >> >>>>>>>>>>>
> > > >> >>>>>>>>>>> That almost looks like
a possible issue with the vboxnet
> > > >> >>>>>> adapters.
> > > >> >>>>>>>>>>> Can you confirm you have
3 host only adapters assigned
> > > >> >>>>>>> 192.168.22.0 -
> > > >> >>>>>>>>>>> 192.168.24.0 with dhcp
disabled on each?
> > > >> >>>>>>>>>>> On 15 Nov 2014 02:19,
"Imesh Gunaratne" <
> imesh@apache.org
> > > >> >>>
> > > >> >>>>>> wrote:
> > > >> >>>>>>>>>>>
> > > >> >>>>>>>>>>>> Hi Ian,
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>> Thanks for your quick
response. This is the issue I
> > > >> >>>>> encountered
> > > >> >>>>>>>> when
> > > >> >>>>>>>>> I
> > > >> >>>>>>>>>>>> executed devcloud4
(binary-installation-advanced):
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>> ==> management:
[2014-11-15T02:09:23+00:00] INFO:
> > > >> >> Running
> > > >> >>>>>> queued
> > > >> >>>>>>>>>> delayed
> > > >> >>>>>>>>>>>> notifications before
re-raising exception
> > > >> >>>>>>>>>>>> ==> management:
[2014-11-15T02:09:23+00:00] ERROR:
> > > >> >> Running
> > > >> >>>>>>>> exception
> > > >> >>>>>>>>>>>> handlers
> > > >> >>>>>>>>>>>> ==> management:
[2014-11-15T02:09:23+00:00] ERROR:
> > > >> >>>> Exception
> > > >> >>>>>>>> handlers
> > > >> >>>>>>>>>>>> complete
> > > >> >>>>>>>>>>>> ==> management:
[2014-11-15T02:09:23+00:00] FATAL:
> > > >> >>>> Stacktrace
> > > >> >>>>>>>> dumped
> > > >> >>>>>>>>> to
> > > >> >>>>>>>>>>>> /var/chef/cache/chef-stacktrace.out
> > > >> >>>>>>>>>>>> ==> management:
[2014-11-15T02:09:23+00:00] ERROR:
> > > >> >>>>>>>>>>>> package[cloudstack-management]
> > > >> >>>> (cloudstack::management-server
> > > >> >>>>>>> line
> > > >> >>>>>>>>> 22)
> > > >> >>>>>>>>>>> had
> > > >> >>>>>>>>>>>> an error: Timeout::Error:
execution expired
> > > >> >>>>>>>>>>>> ==> management:
[2014-11-15T02:09:23+00:00] FATAL:
> > > >> >>>>>>>>>>>> Chef::Exceptions::ChildConvergeError:
Chef run process
> > > >> >>>> exited
> > > >> >>>>>>>>>>>> unsuccessfully (exit
code 1)
> > > >> >>>>>>>>>>>> Chef never successfully
completed! Any errors should be
> > > >> >>>>> visible
> > > >> >>>>>>> in
> > > >> >>>>>>>>> the
> > > >> >>>>>>>>>>>> output above. Please
fix your recipes so that they
> > > >> >>>> properly
> > > >> >>>>>>>> complete.
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>> My host machine runs
Yosemite (OSX 10.10), Vagrant
> > > >> >> 1.6.5,
> > > >> >>>>>>>> VirtualBox
> > > >> >>>>>>>>>>>> 4.3.16. I have also
attached the chef stacktrace file
> > > >> >> with
> > > >> >>>>> this
> > > >> >>>>>>>> mail.
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>> Really appreciate
your help.
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>> Many Thanks
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>> On Fri, Nov 14, 2014
at 4:33 PM, Ian Duffy <
> > > >> >>>> ian@ianduffy.ie>
> > > >> >>>>>>>> wrote:
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>>> Hi,
> > > >> >>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>> I can help you
get devcloud up. What issues did you
> > > >> >> have?
> > > >> >>>>>>>>>>>>> On 14 Nov 2014
04:40, "Imesh Gunaratne" <
> > > >> >>>> imesh@apache.org>
> > > >> >>>>>>> wrote:
> > > >> >>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>> Hi All,
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>> We recently
introduced CloudStack support in Apache
> > > >> >>>>> Stratos
> > > >> >>>>>>> and
> > > >> >>>>>>>>>> trying
> > > >> >>>>>>>>>>>>> to
> > > >> >>>>>>>>>>>>>> figureout
the best way to demonstrate this.
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>> Really appreciate
if you could guide us on the
> > > >> >> simplest
> > > >> >>>>> way
> > > >> >>>>>> to
> > > >> >>>>>>>>>> install
> > > >> >>>>>>>>>>>>>> CloudStack
on VirtualBox (may be using Vagrant)?
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>> We tried
following but did not work perfectly:
> > > >> >>>>>>>>>>>>>> - https://github.com/bvbharatk/VagrantSimulator.git
> > > >> >>>>>>>>>>>>>> - https://github.com/imduffy15/devcloud4.git
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>> Thanks
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>> --
> > > >> >>>>>>>>>>>>>> Imesh Gunaratne
> > > >> >>>>>>>>>>>>>>
> > > >> >>>>>>>>>>>>>> Technical
Lead, WSO2
> > > >> >>>>>>>>>>>>>> Committer
& PMC Member, Apache Stratos
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>> --
> > > >> >>>>>>>>>>>> Imesh Gunaratne
> > > >> >>>>>>>>>>>>
> > > >> >>>>>>>>>>>> Technical Lead, WSO2
> > > >> >>>>>>>>>>>> Committer & PMC
Member, Apache Stratos
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>> --
> > > >> >>>>>>>>>> Imesh Gunaratne
> > > >> >>>>>>>>>>
> > > >> >>>>>>>>>> Technical Lead, WSO2
> > > >> >>>>>>>>>> Committer & PMC Member,
Apache Stratos
> > > >> >>>>>>>>
> > > >> >>>>>>>>
> > > >> >>>>>>>>
> > > >> >>>>>>>> --
> > > >> >>>>>>>> Imesh Gunaratne
> > > >> >>>>>>>>
> > > >> >>>>>>>> Technical Lead, WSO2
> > > >> >>>>>>>> Committer & PMC Member, Apache
Stratos
> > > >> >>>>>>>
> > > >> >>>>>>>
> > > >> >>>>>>>
> > > >> >>>>>>> --
> > > >> >>>>>>> Thanks,
> > > >> >>>>>>> Regards,
> > > >> >>>>>>> ASH
> > > >> >>>>>
> > > >> >>>>>
> > > >> >>>>>
> > > >> >>>>> --
> > > >> >>>>> Imesh Gunaratne
> > > >> >>>>>
> > > >> >>>>> Technical Lead, WSO2
> > > >> >>>>> Committer & PMC Member, Apache Stratos
> > > >> >>>
> > > >> >>>
> > > >> >>>
> > > >> >>> --
> > > >> >>> Imesh Gunaratne
> > > >> >>>
> > > >> >>> Technical Lead, WSO2
> > > >> >>> Committer & PMC Member, Apache Stratos
> > > >> >>
> > > >> >>
> > > >> >>
> > > >> >> --
> > > >> >> Imesh Gunaratne
> > > >> >>
> > > >> >> Technical Lead, WSO2
> > > >> >> Committer & PMC Member, Apache Stratos
> > > >> >>
> > > >>
> > > >
> > > >
> > > >
> > > > --
> > > > Imesh Gunaratne
> > > >
> > > > Technical Lead, WSO2
> > > > Committer & PMC Member, Apache Stratos
> > > >
> > >
> > >
> > >
> > > --
> > > Imesh Gunaratne
> > >
> > > Technical Lead, WSO2
> > > Committer & PMC Member, Apache Stratos
> > >
> >
>
>
>
> --
> Imesh Gunaratne
>
> Technical Lead, WSO2
> Committer & PMC Member, Apache Stratos
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message