cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrija Panic <andrija.pa...@gmail.com>
Subject Re: Broken update from 4.4 to 4.4.1
Date Sun, 26 Oct 2014 11:58:11 GMT
THe previous error happens - if you remove the Global settings value
for vm.network.throttling.rate - so if the value is empty - VM failes to
deploy

On 26 October 2014 12:27, Andrija Panic <andrija.panic@gmail.com> wrote:

> From mtmg log - VM fails to deploy - no usable log info - just roling back
> transaction...
>
> 2014-10-26 12:17:14,733 DEBUG [c.c.a.ApiServlet]
> (catalina-exec-1:ctx-a3293b6a) ===START===  89.216.x.y -- GET
>  command=deployVirtualMachine&response=json&sessionkey=KZ7%2BHIJ7rnPAlFDXUumhvAyGkdg%3D&zoneid=cff6ce66-5112-4fb7-a054-e455728c3d3a&templateid=5e93d6a5-2fc0-49f3-a6eb-5dc152b5fa4e&hypervisor=KVM&serviceofferingid=98e1a3d3-f0ae-4b25-b019-50e38ada5396&details%5B0%5D.cpuNumber=1&details%5B0%5D.cpuSpeed=2000&details%5B0%5D.memory=2048&iptonetworklist%5B0%5D.networkid=4cd93b93-5a0b-4723-a856-2f3855a13e0f&domainid=fc06f73d-5c3d-11e4-9cd3-c454441e363f&account=admin&displayname=aaaaaaa&name=aaaaaaa&_=1414322240037
> 2014-10-26 12:17:14,750 DEBUG [c.c.n.NetworkModelImpl]
> (catalina-exec-1:ctx-a3293b6a ctx-ff17c47b) Service SecurityGroup is not
> supported in the network id=206
> 2014-10-26 12:17:14,757 DEBUG [c.c.v.UserVmManagerImpl]
> (catalina-exec-1:ctx-a3293b6a ctx-ff17c47b) Allocating in the DB for vm
> 2014-10-26 12:17:14,763 DEBUG [c.c.v.VirtualMachineManagerImpl]
> (catalina-exec-1:ctx-a3293b6a ctx-ff17c47b) Allocating entries for VM:
> VM[User|i-2-15-VM]
> 2014-10-26 12:17:14,763 DEBUG [c.c.v.VirtualMachineManagerImpl]
> (catalina-exec-1:ctx-a3293b6a ctx-ff17c47b) Allocating nics for
> VM[User|i-2-15-VM]
> 2014-10-26 12:17:14,764 DEBUG [o.a.c.e.o.NetworkOrchestrator]
> (catalina-exec-1:ctx-a3293b6a ctx-ff17c47b) Allocating nic for vm
> VM[User|i-2-15-VM] in network
> Ntwk[4cd93b93-5a0b-4723-a856-2f3855a13e0f|Guest|11] with requested profile
> NicProfile[0-0-null-null-null
> 2014-10-26 12:17:14,769 DEBUG [c.c.u.d.T.Transaction]
> (catalina-exec-1:ctx-a3293b6a ctx-ff17c47b) Rolling back the transaction:
> Time = 16 Name =  catalina-exec-1; called by
> -TransactionLegacy.rollback:900-TransactionLegacy.removeUpTo:843-TransactionLegacy.close:667-Transaction.execute:41-NetworkOrchestrator.allocate:708-VirtualMachineManagerImpl$1.doInTransactionWithoutResult:409-TransactionCallbackWithExceptionNoReturn.doInTransaction:25-TransactionCallbackWithExceptionNoReturn.doInTransaction:21-Transaction.execute:37-VirtualMachineManagerImpl.allocate:401-CloudOrchestrator.createVirtualMachine:236-UserVmManagerImpl$3.doInTransaction:3028
> 2014-10-26 12:17:14,771 INFO  [c.c.a.ApiServer]
> (catalina-exec-1:ctx-a3293b6a ctx-ff17c47b) null
> 2014-10-26 12:17:14,772 DEBUG [c.c.a.ApiServlet]
> (catalina-exec-1:ctx-a3293b6a ctx-ff17c47b) ===END===  89.216.x.y -- GET
>  command=deployVirtualMachine&response=json&sessionkey=KZ7%2BHIJ7rnPAlFDXUumhvAyGkdg%3D&zoneid=cff6ce66-5112-4fb7-a054-e455728c3d3a&templateid=5e93d6a5-2fc0-49f3-a6eb-5dc152b5fa4e&hypervisor=KVM&serviceofferingid=98e1a3d3-f0ae-4b25-b019-50e38ada5396&details%5B0%5D.cpuNumber=1&details%5B0%5D.cpuSpeed=2000&details%5B0%5D.memory=2048&iptonetworklist%5B0%5D.networkid=4cd93b93-5a0b-4723-a856-2f3855a13e0f&domainid=fc06f73d-5c3d-11e4-9cd3-c454441e363f&account=admin&displayname=aaaaaaa&name=aaaaaaa&_=1414322240037
>
> On 26 October 2014 12:17, Andrija Panic <andrija.panic@gmail.com> wrote:
>
>> Vm deployment doesnt work on my KVM enviroment - clean install 4.4.1,
>> creating new VPC based on builtin VPC/Network offerings -  just get NULL
>> result after finishing new VM deployment from template, no errors in mgmt
>> log, nothing...unusable...
>>
>> On 26 October 2014 11:51, Nux! <nux@li.nux.ro> wrote:
>>
>>> Not sure what to advise. I would take those errors to the dev mailing
>>> list, it will probably ring a bell to someone.
>>>
>>> Lucian
>>>
>>> --
>>> Sent from the Delta quadrant using Borg technology!
>>>
>>> Nux!
>>> www.nux.ro
>>>
>>> ----- Original Message -----
>>> > From: "Matthew Midgett" <cloudstck@trick-solutions.com.INVALID>
>>> > To: users@cloudstack.apache.org
>>> > Sent: Sunday, 26 October, 2014 00:09:35
>>> > Subject: RE: Broken update from 4.4 to 4.4.1
>>>
>>> > Oh snap Nux! I read that announcement wrong :(.. Well I am not sure
>>> how to
>>> > enable debugging on xenserver and I did a google and either I'm not
>>> searching
>>> > correctly or no one has wrote about it. In which file did you see a
>>> problem
>>> > with ssl? I'm not running any ssl at all. I have a cluster of HAProxy
>>> doing ssl
>>> > termination in front so I'm not sure where I'm using SSL at.
>>> >
>>> >
>>> > -----Original Message-----
>>> > From: Nux! [mailto:nux@li.nux.ro]
>>> > Sent: Saturday, October 25, 2014 5:33 PM
>>> > To: users@cloudstack.apache.org
>>> > Subject: Re: Broken update from 4.4 to 4.4.1
>>> >
>>> > Hello Matthew,
>>> >
>>> > AFAIK the root resize feature applies only to KVM hypervisors for now,
>>> so if you
>>> > are after that one feature, don't rush.
>>> >
>>> > Having said that, though the errors do not make much sense for me, is
>>> there any
>>> > possibility you can enable DEBUG logging in the agent/HV? It looks like
>>> > something related to SSL.
>>> >
>>> > --
>>> > Sent from the Delta quadrant using Borg technology!
>>> >
>>> > Nux!
>>> > www.nux.ro
>>> >
>>> > ----- Original Message -----
>>> >> From: "Matthew Midgett" <cloudstck@trick-solutions.com.INVALID>
>>> >> To: users@cloudstack.apache.org
>>> >> Sent: Saturday, 25 October, 2014 20:38:09
>>> >> Subject: RE: Broken update from 4.4 to 4.4.1
>>> >
>>> >> I tried again to update from 4.4.0 to 4.4.1 with centos management
>>> >> server and xenserver 6.2. Here is the logs from the management server
>>> >> and the catalina.out
>>> >>
>>> >> http://pastebin.com/mS0wjug7
>>> >>
>>> >> http://pastebin.com/gwVCitvb
>>> >>
>>> >> I have to down grade and restore the db to get things working again.
I
>>> >> would really like to try out the root disk resize option.
>>> >>
>>> >> I did fresh install with a single vm witg the db and management server
>>> >> on the same host just installed just fine.
>>> >>
>>> > > What should I do next ?
>>>
>>
>>
>>
>> --
>>
>> Andrija Panić
>> --------------------------------------
>>   http://admintweets.com
>> --------------------------------------
>>
>
>
>
> --
>
> Andrija Panić
> --------------------------------------
>   http://admintweets.com
> --------------------------------------
>



-- 

Andrija Panić
--------------------------------------
  http://admintweets.com
--------------------------------------

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message