cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From benoit lair <kurushi4...@gmail.com>
Subject Re: [ACS43][MGMT Server][Load Balancing]
Date Thu, 23 Oct 2014 07:48:44 GMT
Any advice ? Any feedback ? Does somebody already did that ?

Thanks for your responses.

2014-10-13 10:51 GMT+02:00 benoit lair <kurushi4000@gmail.com>:

> Hello,
>
>
> Is there somebody already accomplished some load balancing on the
> management app server ?
>
>
>
> Thanks for your responses.
>
> Regards.
>
> 2014-10-09 16:24 GMT+02:00 benoit lair <kurushi4000@gmail.com>:
>
>> Here are the logs entries i have in the other mgmt node :
>>
>> DEBUG [c.c.a.m.ClusteredAgentManagerImpl] (AgentManager-Handler-8:null)
>> Seq 1-289341441: MgmtId 104425904713066: Resp: Routing to peer
>>
>> 2014-10-09 16:21 GMT+02:00 benoit lair <kurushi4000@gmail.com>:
>>
>>> What i was thinking of..
>>>
>>> Here are the logs entries in one of my mgmt server :
>>>
>>> 2014-10-09 15:47:27,451 ERROR [c.c.c.ClusterManagerImpl]
>>> (Cluster-Heartbeat-1:cx-71073990) We have detected that at least one
>>> management server peer reports tat this management server is down, perform
>>> active fencing to avoid split-brain ituation
>>>
>>> So this one has been shutdown. How to recover my 2 mgmt nodes in normal
>>> state ?
>>>
>>> Thanks.
>>> Regards, Benoit
>>>
>>> 2014-10-09 16:20 GMT+02:00 benoit lair <kurushi4000@gmail.com>:
>>>
>>>> Hello,
>>>>
>>>>
>>>> I would like to do some load balancing on the mgmt server, i would like
>>>> to know if i am on the good way :
>>>>
>>>> I installed Two management servers.
>>>>
>>>> The first with the "deploy-as" in the command
>>>> cloudstack-setup-databases with the netscalerlbip as the management server
>>>> :
>>>>
>>>> cloudstack-setup-databases cloud:password@192.168.0.10
>>>> --deploy-as=root:mypassroot -e file -m mypassphrase -k mypassphrase -i
>>>> netscalerlbip
>>>>
>>>> The second node was deployed with
>>>> cloudstack-setup-databases cloud:password@192.168.0.10 -e file -m
>>>> mypassphrase -k mypassphrase -i netscalerlbip
>>>>
>>>> So my netscaler is doing load balancing on the 2 nodes availables
>>>> accross netscalerlbip.
>>>>
>>>> I have confgured the "host" global parameter with the netscalerlbip as
>>>> ip and restarted the 2 mgmt servers.
>>>>
>>>> How to be sure that my mgmts servers are working correctly ? Am i sure
>>>> not to have split brain ?
>>>>
>>>> Thanks for your responses.
>>>>
>>>> Regards,
>>>> Benoit
>>>>
>>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message