cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Ceylani <sam.ceyl...@mistercertified.com>
Subject Re: upgraded to 4.4.1, management console is broken
Date Fri, 03 Oct 2014 23:21:03 GMT
make sure loopback address in the database and actual address on nic are same, check this info
and let us know, which hypervisor?

sam

Sent from my iPhone

> On Oct 3, 2014, at 7:14 PM, "Ian Young" <iyoung@ratespecial.com> wrote:
> 
> Since the database had allegedly not been upgraded, I downgraded to 4.4.0.
> The management console was now available but I can't start instances.
> Thinking I would have to back up all the instances and reinstall CloudStack
> from scratch again, I converted one of the instances to a template but was
> unable to download it.  The browser times out while trying to connect to
> the SSVM.  I can't connect to the SSVM using the RSA key either, although
> the console proxy shows it up and running, with the login prompt.  I port
> scanned the SSVM and the only ports open were 80 and 443, not 22.
> 
>> On Fri, Oct 3, 2014 at 1:51 PM, Ian Young <iyoung@ratespecial.com> wrote:
>> 
>> It looks like this is the root of the problem:
>> 
>> 2014-10-03 13:44:47,131 DEBUG [c.c.u.d.Upgrade440to441] (main:null)
>> Updating System Vm template IDs
>> 2014-10-03 13:44:47,136 DEBUG [c.c.u.d.Upgrade440to441] (main:null)
>> Updating LXC System Vms
>> 2014-10-03 13:44:47,137 WARN  [c.c.u.d.Upgrade440to441] (main:null) 4.4.0
>> LXC SystemVm template not found. LXC hypervisor is not used, so not failing
>> upgrade
>> 2014-10-03 13:44:47,138 DEBUG [c.c.u.d.Upgrade440to441] (main:null)
>> Updating KVM System Vms
>> 2014-10-03 13:44:47,141 ERROR [c.c.u.DatabaseUpgradeChecker] (main:null)
>> Unable to upgrade the database
>> com.cloud.utils.exception.CloudRuntimeException: 4.4.0 KVM SystemVm
>> template not found. Cannot upgrade system Vms
>> 
>> Any ideas about how I can fix this?  I had a 4.4.0 KVM SystemVm template
>> prior to the upgrade.
>> 
>>> On Fri, Oct 3, 2014 at 1:39 PM, Ian Young <iyoung@ratespecial.com> wrote:
>>> 
>>> I tried upgrading from 4.4.0 to 4.4.1 but now I get a 404 error when I
>>> try to access the management console.  The localhost.2014-10-03.log shows
>>> this error:
>>> 
>>> Caused by: java.io.IOException: Resource
>>> [jar:file:/usr/share/cloudstack-management/webapps/client/WEB-INF/lib/cloud-api-4.4.1.jar!/META-INF/cloudstack/api-config/module.properties]
>>> and
>>> [jar:file:/usr/share/cloudstack-management/webapps/client/WEB-INF/lib/cloud-api-4.4.0.jar!/META-INF/cloudstack/api-config/module.properties]
>>> do not appear to be the same resource, please ensure the name property is
>>> correct or that the module is not defined twice
>>> 
>>> Where is this value defined?  The full log can be viewed here:
>>> 
>>> pastebin.com/nrdEsxZK
>>> 
>>> I also noticed the error "4.4.0 KVM SystemVm template not found. Cannot
>>> upgrade system Vms."  The URL for the system VM template in the 4.4.1
>>> upgrade instructions is the same as the one I used when I installed 4.4.0
>>> initially.  Is there really a need to install the same template again?
>> 
>> 

Mime
View raw message