cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Kimlaychuk <Vadim.Kimlayc...@Elion.ee>
Subject CS 4.4.0 and XenServer 6.2. Stopping VM destroys it.
Date Mon, 06 Oct 2014 12:10:38 GMT
Hello,

            Have found very unplesent behaviour : when I execute „stop instance“ command
Cloudstack actually destroys VM from hypervisor. No errors or other warnings has been issued.
Management log shows:

2014-10-06 14:55:37,365 DEBUG [c.c.a.t.Request] (Work-Job-Executor-70:ctx-ea29a5b5 job-158/job-159
ctx-65d35099) Seq 1-1867586470475218798: Sending  { Cmd , MgmtId: 90520745720479, via: 1(xcp1),
Ver: v1, Flags: 100011, [{"com.cloud.agent.api.StopCommand":{"isProxy":false,"executeInSequence":false,"checkBeforeCleanup":false,"vmName":"i-2-13-VM","wait":0}}]
}
2014-10-06 14:55:37,365 DEBUG [c.c.a.t.Request] (Work-Job-Executor-70:ctx-ea29a5b5 job-158/job-159
ctx-65d35099) Seq 1-1867586470475218798: Executing:  { Cmd , MgmtId: 90520745720479, via:
1(xcp1), Ver: v1, Flags: 100011, [{"com.cloud.agent.api.StopCommand":{"isProxy":false,"executeInSequence":false,"checkBeforeCleanup":false,"vmName":"i-2-13-VM","wait":0}}]
}

……

Then shortly after that:
2014-10-06 14:56:24,867 DEBUG [c.c.h.x.r.CitrixResourceBase] (DirectAgent-282:ctx-29a6d080)
10. The VM i-2-13-VM is in Stopped state

But when I go to XEN dom0 and run „xe vm-list“ there is no VM anymore.  And I can’t
obviously start it again. Shows error “Job failed due to exception Unable to create a deployment
for VM[User|i-2-13-VM]“

Is it a bug or what?

Vadim Kimlaychuk
integratsiooni arhitekt
tel. 640 2297
mob. 5233474

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message