cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Asanka sanjaya Herath <angal...@gmail.com>
Subject Re: cannot ping to cloudstack instance
Date Thu, 25 Sep 2014 11:05:51 GMT
​Hi Gopalakrishnan,

I added that. But still the same problem. I'll check my VMs Gateway and IP
settings.

Thank you.​

On Thu, Sep 25, 2014 at 4:28 PM, GopalaKrishnan <gopal@assistanz.com> wrote:

> Hi Sanjaya,
>
> Just add the following entries in your VMs /etc/resolv.conf
>
> nameserver 4.2.2.2
> nameserver 8.8.4.4
>
> if it does not work, then you should check VMs Gateway and ip settings.
>
> Thank you.
> Gopalakrishnan.S
>
> ----- Original Message ----- From: "Asanka sanjaya Herath" <
> angal.sh@gmail.com>
> To: <users@cloudstack.apache.org>
> Sent: Thursday, September 25, 2014 4:15 PM
>
> Subject: Re: cannot ping to cloudstack instance
>
>
> Hi GopalaKrishnan,
>
> My /etc/conf file shows these information.
>
> search citrite.net
> nameserver 10.216.4.21
> nameserver 10.216.4.34
> nameserver 10.9.47.59
> nameserver 172.16.2.66
> search cs1cloud.internal
> nameserver 192.168.56.111
> nameserver 8.8.8.8
> nameserver 8.8.4.4
>
> But still when I ping to www.google.com it gives the bad address error.
>
>
>
> On Thu, Sep 25, 2014 at 3:21 PM, GopalaKrishnan <gopal@assistanz.com>
> wrote:
>
>  Hi,
>>
>> Check /etc/resolv.conf file nameserver.
>>
>> ex:
>> nameserver 4.2.2.2
>>
>> Thank You.
>> Gopalakrishnan.S
>>
>> ----- Original Message ----- From: "Asanka sanjaya Herath" <
>> angal.sh@gmail.com>
>> To: <users@cloudstack.apache.org>
>> Sent: Thursday, September 25, 2014 3:06 PM
>> Subject: Re: cannot ping to cloudstack instance
>>
>>
>>
>> Hi,
>> I have another problem.  My instances cannot access internet now. How can
>> I
>> solve that?
>>
>> On Thu, Sep 25, 2014 at 3:04 PM, Outback Dingo <outbackdingo@gmail.com>
>> wrote:
>>
>>  Ahhh So its via vagrant and vbox... got it.... not what i was hoping for,
>>
>>> but Thanks
>>>
>>> On Thu, Sep 25, 2014 at 7:21 PM, Asanka sanjaya Herath <
>>> angal.sh@gmail.com
>>> >
>>> wrote:
>>>
>>> > hi Dingo,
>>> > I used this for installation.
>>> >
>>> > https://github.com/imduffy15/devcloud4
>>> >
>>> > On Thu, Sep 25, 2014 at 2:34 PM, Outback Dingo <outbackdingo@gmail.com
>>> >
>>> > wrote:
>>> >
>>> > > Curious...... Is this a single machine single nic install on a
>>> > workstation?
>>> > > If so... How did you manage that?
>>> > >
>>> > > On Thu, Sep 25, 2014 at 6:51 PM, Asanka sanjaya Herath <
>>> > angal.sh@gmail.com
>>> > > >
>>> > > wrote:
>>> > >
>>> > > > Problem solved. Thank you again.
>>> > > >
>>> > > > On Thu, Sep 25, 2014 at 2:16 PM, Jayapal Reddy Uradi <
>>> > > > jayapalreddy.uradi@citrix.com> wrote:
>>> > > >
>>> > > > > Did you open ports 22-22 ?
>>> > > > > Earlier mail you mentioned port 80-80 only.
>>> > > > >
>>> > > > > Please see the ports are opened and service is running in
the
>>> > > vm/server.
>>> > > > >
>>> > > > > Thanks,
>>> > > > > Jayapal
>>> > > > > On 25-Sep-2014, at 2:12 PM, Asanka sanjaya Herath <
>>> > angal.sh@gmail.com>
>>> > > > >  wrote:
>>> > > > >
>>> > > > > > Sorry this is the error:
>>> > > > > > # ssh root@192.168.56.135
>>> > > > > > # ssh: connect to host 192.168.56.135 port 22: Connection
timed
>>> out
>>> > > > > >
>>> > > > > > On Thu, Sep 25, 2014 at 2:05 PM, Asanka sanjaya Herath
<
>>> > > > > angal.sh@gmail.com>
>>> > > > > > wrote:
>>> > > > > >
>>> > > > > >> Now I'm trying to ssh to that server. But it I got
this error.
>>> > > > > >>
>>> > > > > >> # ssh root@192.168.56.180
>>> > > > > >> # ssh: connect to host 192.168.56.135 port 22: Connection
> >
>>> > > >> timed
>>> > out
>>> > > > > >>
>>> > > > > >> I used default template(cent-os) provided by cloudstak.
>>> > > > > >> So where is the fault?
>>> > > > > >>
>>> > > > > >>
>>> > > > > >> On Thu, Sep 25, 2014 at 1:59 PM, Asanka sanjaya
Herath <
>>> > > > > angal.sh@gmail.com
>>> > > > > >>> wrote:
>>> > > > > >>
>>> > > > > >>> Hi Gopalakrishnan,
>>> > > > > >>>
>>> > > > > >>> That works. Thank you for your help. And thank
you Jayapal >
>>> > > > >>> for
>>> > > > detailed
>>> > > > > >>> information.
>>> > > > > >>>
>>> > > > > >>> On Thu, Sep 25, 2014 at 1:55 PM, Jayapal Reddy
Uradi <
>>> > > > > >>> jayapalreddy.uradi@citrix.com> wrote:
>>> > > > > >>>
>>> > > > > >>>> For ping icmp is type 8 and code 0.
>>> > > > > >>>> Add icmp type, code -1,-1 to allow all icmp
types and codes.
>>> > > > > >>>>
>>> > > > > >>>> -Jayapal
>>> > > > > >>>>
>>> > > > > >>>> On 25-Sep-2014, at 1:31 PM, Asanka sanjaya
Herath <
>>> > > > angal.sh@gmail.com
>>> > > > > >
>>> > > > > >>>> wrote:
>>> > > > > >>>>
>>> > > > > >>>>> Hi GopalaKrishnan,
>>> > > > > >>>>>
>>> > > > > >>>>> Thank you for help. I added Egress and
Ingress rules as
>>> > follows.
>>> > > > > >>>>>
>>> > > > > >>>>> TCP: start port-80 endport-80 CIDR-0.0.0.0/0
>>> > > > > >>>>> ICMP: type-0 code-0 CIDR-0.0.0.0./0
>>> > > > > >>>>>
>>> > > > > >>>>> But still I cannot ping to the instance
from the host
>>> machine.
>>> > > But
>>> > > > I
>>> > > > > >>>> can
>>> > > > > >>>>> ping to the host machine from the instance.
>>> > > > > >>>>>
>>> > > > > >>>>>
>>> > > > > >>>>> On Thu, Sep 25, 2014 at 12:35 PM, GopalaKrishnan
<
>>> > > > > gopal@assistanz.com>
>>> > > > > >>>>> wrote:
>>> > > > > >>>>>
>>> > > > > >>>>>> Hi Sanjaya,
>>> > > > > >>>>>>
>>> > > > > >>>>>> You should check Security Groups
and Egress, Ingress rules
>>> for
>>> > > > your
>>> > > > > >>>>>> instance user. Enable ICMP in Egress
to ping your server.
>>> > > > > >>>>>>
>>> > > > > >>>>>> Thank You.
>>> > > > > >>>>>> GopalaKrishnan.S
>>> > > > > >>>>>> Cloud Architect at Fogpanel.
>>> > > > > >>>>>>
>>> > > > > >>>>>>
>>> > > > > >>>>>> ----- Original Message ----- From:
"Asanka sanjaya Herath"
>>> > > > > >>>>>> <
>>> > > > > >>>>>> angal.sh@gmail.com>
>>> > > > > >>>>>> To: <users@cloudstack.apache.org>
>>> > > > > >>>>>> Sent: Thursday, September 25, 2014
11:51 AM
>>> > > > > >>>>>> Subject: cannot ping to cloudstack
instance
>>> > > > > >>>>>>
>>> > > > > >>>>>>
>>> > > > > >>>>>>
>>> > > > > >>>>>> I installed cloudstack in my local
computer and added an
>>> > > instance
>>> > > > > >>>>>> successfully. Then I tried to ping
to the instance created
>>> in
>>> > > > > >>>> cloudstack.
>>> > > > > >>>>>> But I cannot ping to instance. 
But I can ping to the
>>> gateway.
>>> > > > > >>>>>>
>>> > > > > >>>>>> These are my network configurations(used
basic > > > >
>>> >>>>>> networking):
>>> > > > > >>>>>>
>>> > > > > >>>>>> dns1: 8.8.8.8
>>> > > > > >>>>>> dns2: 8.8.4.4
>>> > > > > >>>>>>
>>> > > > > >>>>>> POD:
>>> > > > > >>>>>> startip: 192.168.56.200
>>> > > > > >>>>>> endip:192.168.56.220
>>> > > > > >>>>>>
>>> > > > > >>>>>> Guest IP Ranges:
>>> > > > > >>>>>> startip: 192.168.56.100
>>> > > > > >>>>>> endip: 192.168.56.199
>>> > > > > >>>>>> netmask: 255.255.255.0
>>> > > > > >>>>>> gateway: 192.168.56.5
>>> > > > > >>>>>>
>>> > > > > >>>>>> Instance IP: 192.168.56.135
>>> > > > > >>>>>>
>>> > > > > >>>>>> Any ideas?
>>> > > > > >>>>>>
>>> > > > > >>>>>>
>>> > > > > >>>>>> --
>>> > > > > >>>>>> Thanks,
>>> > > > > >>>>>> Regards,
>>> > > > > >>>>>> A
>>> > > > > >>>>>> ​sanka
>>> > > > > >>>>>>
>>> > > > > >>>>>> ---
>>> > > > > >>>>>> This email is free from viruses
and malware because avast!
>>> > > > Antivirus
>>> > > > > >>>>>> protection is active.
>>> > > > > >>>>>> http://www.avast.com
>>> > > > > >>>>>>
>>> > > > > >>>>>>
>>> > > > > >>>>>
>>> > > > > >>>>>
>>> > > > > >>>>> --
>>> > > > > >>>>> Thanks,
>>> > > > > >>>>> Regards,
>>> > > > > >>>>> ASH
>>> > > > > >>>>
>>> > > > > >>>>
>>> > > > > >>>
>>> > > > > >>>
>>> > > > > >>> --
>>> > > > > >>> Thanks,
>>> > > > > >>> Regards,
>>> > > > > >>> ASH
>>> > > > > >>>
>>> > > > > >>
>>> > > > > >>
>>> > > > > >>
>>> > > > > >> --
>>> > > > > >> Thanks,
>>> > > > > >> Regards,
>>> > > > > >> ASH
>>> > > > > >>
>>> > > > > >
>>> > > > > >
>>> > > > > >
>>> > > > > > --
>>> > > > > > Thanks,
>>> > > > > > Regards,
>>> > > > > > ASH
>>> > > > >
>>> > > > >
>>> > > >
>>> > > >
>>> > > > --
>>> > > > Thanks,
>>> > > > Regards,
>>> > > > ASH
>>> > > >
>>> > >
>>> >
>>> >
>>> >
>>> > --
>>> > Thanks,
>>> > Regards,
>>> > ASH
>>> >
>>>
>>>
>>>
>>
>> --
>> Thanks,
>> Regards,
>> ASH
>>
>>
>> ---
>> This email is free from viruses and malware because avast! Antivirus
>> protection is active.
>> http://www.avast.com
>>
>>
>>
>
> --
> Thanks,
> Regards,
> ASH
>
>
> ---
> This email is free from viruses and malware because avast! Antivirus
> protection is active.
> http://www.avast.com
>
>


-- 
Thanks,
Regards,
ASH

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message