cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anshul Gangwar <anshul.gang...@citrix.com>
Subject RE: Building hyper-V agent agent issue
Date Wed, 17 Sep 2014 06:42:40 GMT
You don't have to download dependencies manually. Script does that for you.

There seems to be some problem with your environment.

Can you try setting RestorePackages to true in (cloudstack root directory)/plugins/hypervisors/hyperv/DotNet/ServerResource/.nuget/NuGet.targets
This can be changed by setting value from false to true in line no. 6.

After change line will look like 
        <!-- Enable the restore command to run before builds -->
        <RestorePackages Condition="  '$(RestorePackages)' == '' ">true</RestorePackages>

After change try building again.

If build still fails then you can follow method 2 below.

In this method you have to download dependencies manually.
You can download the dependencies from http://jenkins.buildacloud.org/job/cloudstack-master-hyperv-agent/.
The generated zip files contains all the dependencies.

From the zip files you have to put dependencies in packages folder in certain folder structure.

Folder structure will be as follows

packages\AWSSDK.1.5.23.0\lib\AWSSDK.dll
packages\xunit.1.9.2\lib\net20\xunit.dll
packages\log4net.2.0.0\lib\net40-full\log4net.dll
packages\DotNetZip.1.9.1.8\lib\net20\Ionic.Zip.dll
packages\Newtonsoft.Json.4.5.11\lib\net40\Newtonsoft.Json.dll
packages\NSubstitute.1.6.1.0\lib\NET40\NSubstitute.dll
packages\xunit.1.9.2\lib\net20\xunit.dll

where packages folder will be in (cloudstack-root-directory)/plugins/hypervisors/hyperv/DotNet/ServerResource.

For example:
 You have to put  AWSSDK.dll at location (cloudstack-root-directory)/plugins/hypervisors/hyperv/DotNet/ServerResource/packages/AWSSDK.1.5.23.0/lib/AWSSDK.dll
 You will get AWSSDK.dll from zip downloaded from Jenkins job.


-----Original Message-----
From: tawfiq zidi [mailto:tawfiq.zidi@gmail.com] 
Sent: Tuesday, September 16, 2014 4:40 PM
To: users
Cc: dev@cloudstack.apache.org
Subject: Re: Building hyper-V agent agent issue

Hi,

I am trying to build hyperV agent and I am facing the same errors.

Is there any dependencies that I need to download seprately ?

On Tue, Sep 16, 2014 at 7:04 AM, Anshul Gangwar <anshul.gangwar@citrix.com>
wrote:

> Are you able to download nuget?
>
> Build is failing because it is not able to download nuget packages 
> dependencies.
>
> Are you able to see something like this in starting of build
>
> --2014-09-16 10:23:46--  http://nuget.org/nuget.exe Resolving 
> nuget.org (nuget.org)... 168.62.110.126 Connecting to nuget.org 
> (nuget.org)|168.62.110.126|:80... connected.
> HTTP request sent, awaiting response... 301 Moved Permanently
> Location: http://www.nuget.org/nuget.exe [following]
> --2014-09-16 10:23:46--  http://www.nuget.org/nuget.exe Resolving 
> www.nuget.org (www.nuget.org)... 168.62.110.126 Reusing existing 
> connection to nuget.org:80.
> HTTP request sent, awaiting response... 302 Found
> Location: http://az320820.vo.msecnd.net/downloads/nuget.exe 
> [following]
> --2014-09-16 10:23:47--  
> http://az320820.vo.msecnd.net/downloads/nuget.exe
> Resolving az320820.vo.msecnd.net (az320820.vo.msecnd.net)...
> 192.229.145.200, 2606:2800:10c:249:f81:1c8d:1178:1364
> Connecting to az320820.vo.msecnd.net (az320820.vo.msecnd.net)|192.229.145.200|:80...
> connected.
> HTTP request sent, awaiting response... 200 OK
> Length: 1670320 (1.6M) [application/x-msdownload] Saving to: 
> `nuget.exe'
>
> 100%[===============================================================================================================================================>]
> 16,70,320    404K/s   in 4.0s
>
> 2014-09-16 10:23:51 (405 KB/s) - `nuget.exe' saved [1670320/1670320]
>
>  running tests
> XBuild Engine Version 3.0.6.0
> Mono, Version 3.0.6.0
> Copyright (C) Marek Sieradzki 2005-2008, Novell 2008-2011.
>
>
>
>
> -----Original Message-----
> From: Fedi Ben Ali [mailto:ben.ali.fedi1@gmail.com]
> Sent: Monday, September 15, 2014 9:38 PM
> To: dev@cloudstack.apache.org; users@cloudstack.apache.org
> Subject: Building hyper-V agent agent issue
>
> Hello ,
>
> I'm not able to build the hyper-V agent installer ,i'm following the 
> official documentation 
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/Creating+Hyperv
> +Agent+Installer
>
> ,i'll share my log with you
>
> running tests
> XBuild Engine Version 3.3.0.0
> Mono, Version 3.3.0.0
> Copyright (C) Marek Sieradzki 2005-2008, Novell 2008-2011.
>
> Build started 9/15/2014 2:11:22 PM.
> __________________________________________________
> Project
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\ServerResource.sln"
> (default target(s)):
> Target ValidateSolutionConfiguration:
> Building solution configuration "Debug|Any CPU".
> Target Build:
> Project
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\WmiWrappers.csproj"
> (default target(s)):
> Target PrepareForBuild:
> Configuration: Debug Platform: AnyCPU
> Created directory "bin\Debug\"
> Created directory "obj\Debug\"
> Target ResolveAssemblyReferences:
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'AWSSDK' not resolved
> For searchpath
> {CandidateAssemblyFiles}
> Warning: {CandidateAssemblyFiles}
>
> not supported currently
> For searchpath
> {HintPathFromItem}
> Considered ..\packages\AWSSDK.1.5.23.0\lib\AWSSDK.dll, but it does not 
> exist.
> For searchpath {TargetFrameworkDirectory} Considered target framework 
> dir 
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5,
> assembly named 'AWSSDK' not found.
> Considered target framework dir
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5\Facades\,
> assembly named 'AWSSDK' not found.
> For searchpath {PkgConfig}
> Considered AWSSDK, but could not find in any pkg-config files.
> For searchpath {GAC}
> Considered AWSSDK, but could not find in the GAC.
> For searchpath {RawFileName}
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\AWSSDK'
> as a file, but the file does not exist For searchpath bin\Debug\ 
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\AWSSDK'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\AWSSDK.exe'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\AWSSDK.dll'
> as a file, but the file does not exist
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'Ionic.Zip' not resolved
> For searchpath {CandidateAssemblyFiles}
> Warning: {CandidateAssemblyFiles} not supported currently For 
> searchpath {HintPathFromItem}
>
> Considered ..\packages\DotNetZip.1.9.1.8\lib\net20\Ionic.Zip.dll, but 
> it does not exist.
> For searchpath
> {TargetFrameworkDirectory}
> Considered target framework dir
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5,
> assembly named 'Ionic.Zip' not found.
> Considered target framework dir
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5\Facades\,
> assembly named 'Ionic.Zip' not found.
> For searchpath {PkgConfig}
> Considered Ionic.Zip, but could not find in any pkg-config files.
> For searchpath {GAC}
> Considered Ionic.Zip, but could not find in the GAC.
> For searchpath {RawFileName}
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\Ionic.Zip'
> as a file, but the file does not exist For searchpath bin\Debug\ 
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Ionic.Zip'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Ionic.Zip.exe'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Ionic.Zip.dll'
> as a file, but the file does not exist
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'log4net' not resolved
> For searchpath {CandidateAssemblyFiles}
> Warning: {CandidateAssemblyFiles} not supported currently For 
> searchpath {HintPathFromItem} Considered 
> ..\packages\log4net.2.0.0\lib\net40-full\log4net.dll, but it does not exist.
> For searchpath {TargetFrameworkDirectory}
>
> Considered target framework dir
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5,
> assembly named 'log4net' not found.
> Considered target framework dir
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5\Facades\,
> assembly named 'log4net' not found.
> For searchpath
> {PkgConfig}
> Considered log4net, but could not find in any pkg-config files.
> For searchpath {GAC}
> Considered log4net, but could not find in the GAC.
> For searchpath {RawFileName}
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\log4net'
> as a file, but the file does not exist For searchpath bin\Debug\ 
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\log4net'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\log4net.exe'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\log4net.dll'
> as a file, but the file does not exist
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'Newtonsoft.Json' not resolved For searchpath 
> {CandidateAssemblyFiles}
> Warning: {CandidateAssemblyFiles} not supported currently For 
> searchpath {HintPathFromItem} Considered 
> ..\packages\Newtonsoft.Json.4.5.11\lib\net40\Newtonsoft.Json.dll, but 
> it does not exist.
> For searchpath {TargetFrameworkDirectory} Considered target framework 
> dir 
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5, assembly named 'Newtonsoft.Json' not 
> found.
> Considered target framework dir
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5\Facades\,
> assembly named 'Newtonsoft.Json' not found.
> For searchpath {PkgConfig}
>
> Considered Newtonsoft.Json, but could not find in any pkg-config files.
> For searchpath
> {GAC}
> Considered Newtonsoft.Json, but could not find in the GAC.
> For searchpath {RawFileName}
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\Newtonsoft.Json'
> as a file, but the file does not exist For searchpath bin\Debug\ 
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Newtonsoft.Json'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Newtonsoft.Json.exe'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\Newtonsoft.Json.dll'
> as a file, but the file does not exist
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'NSubstitute' not resolved
> For searchpath {CandidateAssemblyFiles}
> Warning: {CandidateAssemblyFiles} not supported currently For
> searchpath {HintPathFromItem} Considered 
> ..\packages\NSubstitute.1.6.1.0\lib\NET40\NSubstitute.dll, but it does 
> not exist.
> For searchpath {TargetFrameworkDirectory} Considered target framework 
> dir 
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5, assembly named 'NSubstitute' not 
> found.
> Considered target framework dir
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5\Facades\,
> assembly named 'NSubstitute' not found.
> For searchpath {PkgConfig}
> Considered NSubstitute, but could not find in any pkg-config files.
> For searchpath {GAC}
>
> Considered NSubstitute, but could not find in the GAC.
> For searchpath
> {RawFileName}
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\NSubstitute'
> as a file, but the file does not exist For searchpath bin\Debug\ 
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\NSubstitute'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\NSubstitute.exe'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\NSubstitute.dll'
> as a file, but the file does not exist
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'xunit' not resolved
> For searchpath {CandidateAssemblyFiles}
> Warning: {CandidateAssemblyFiles} not supported currently For 
> searchpath {HintPathFromItem} Considered 
> ..\packages\xunit.1.9.2\lib\net20\xunit.dll,
> but it does not exist.
> For searchpath {TargetFrameworkDirectory} Considered target framework 
> dir 
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5,
> assembly named 'xunit' not found.
> Considered target framework dir
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.NETFramework
> \v4.5\RedistList\..\..\..\..\4.5\Facades\,
> assembly named 'xunit' not found.
> For searchpath {PkgConfig}
> Considered xunit, but could not find in any pkg-config files.
> For searchpath {GAC}
> Considered xunit, but could not find in the GAC.
> For searchpath {RawFileName}
>
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\xunit'
> as a file, but the file does not exist For searchpath bin\Debug\ 
> Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\xunit'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\xunit.exe'
> as a file, but the file does not exist Considered
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\xunit.dll'
> as a file, but the file does not exist Target 
> GenerateSatelliteAssemblies:
> No input files were specified for target GenerateSatelliteAssemblies, 
> skipping.
> Target CoreCompile:
> Tool C:\PROGRA~2\MONO-3~1.3\bin\mcs.bat execution started with arguments:
> /noconfig /debug:full /debug+ /optimize- 
> /out:obj\Debug\WmiWrappers.dll ROOT.CIMV2.Win32_OperatingSystem.cs
> root.CIMV2.Win32_PerfFormattedData_Counters_ProcessorInformation.cs
> ROOT.CIMV2.Win32_Processor.cs 
> ROOT.virtualization.v2.Msvm_ComputerSystem.cs
> ROOT.virtualization.v2.Msvm_ConcreteJob.cs
> ROOT.virtualization.v2.Msvm_EthernetPortAllocationSettingData.cs
> ROOT.virtualization.v2.Msvm_EthernetSwitchPort.cs
> ROOT.virtualization.v2.Msvm_EthernetSwitchPortBandwidthSettingData.cs
> ROOT.virtualization.v2.Msvm_EthernetSwitchPortVlanSettingData.cs
> ROOT.virtualization.v2.Msvm_ExternalEthernetPort.cs
> ROOT.virtualization.v2.Msvm_ImageManagementService.cs
> ROOT.virtualization.v2.Msvm_KvpExchangeComponent.cs
> ROOT.virtualization.v2.Msvm_KvpExchangeComponentSettingData.cs
> ROOT.virtualization.v2.Msvm_KvpExchangeDataItem.cs
> ROOT.virtualization.v2.Msvm_LANEndpoint.cs
> ROOT.virtualization.v2.Msvm_MemorySettingData.cs
> ROOT.virtualization.v2.Msvm_MigrationJob.cs
> ROOT.virtualization.v2.Msvm_ProcessorSettingData.cs
> ROOT.virtualization.v2.Msvm_ResourceAllocationSettingData.cs
> ROOT.virtualization.v2.Msvm_StorageAllocationSettingData.cs
> ROOT.virtualization.v2.Msvm_StorageJob.cs
> ROOT.virtualization.v2.Msvm_SummaryInformation.cs
> ROOT.virtualization.v2.Msvm_SyntheticEthernetPortSettingData.cs
> ROOT.virtualization.v2.Msvm_VirtualEthernetSwitch.cs
> ROOT.virtualization.v2.Msvm_VirtualEthernetSwitchManagementService.cs
> ROOT.virtualization.v2.Msvm_VirtualHardDiskSettingData.cs
> ROOT.virtualization.v2.Msvm_VirtualSystemManagementService.cs
> ROOT.virtualization.v2.Msvm_VirtualSystemManagementServiceSettingData.
> cs ROOT.virtualization.v2.Msvm_VirtualSystemMigrationService.cs
> ROOT.virtualization.v2.Msvm_VirtualSystemMigrationSettingData.cs
> ROOT.virtualization.v2.Msvm_VirtualSystemSettingData.cs 
> /target:library /define:"DEBUG;TRACE"
>
> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.N
> ETFramework\v4.5\RedistList\..\..\..\..\4.5\System.dll
>
> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.N
> ETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Management.dll
>
> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.N
> ETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Xml.Linq.dll
>
> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.N
> ETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Data.DataSetExtensi
> ons.dll
>
> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.N
> ETFramework\v4.5\RedistList\..\..\..\..\4.5\Microsoft.CSharp.dll
>
> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.N
> ETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Data.dll
>
> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.N
> ETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Xml.dll
>
> /reference:C:\PROGRA~2\MONO-3~1.3\lib\mono\4.5\..\xbuild-frameworks\.N
> ETFramework\v4.5\RedistList\..\..\..\..\4.5\System.Core.dll
> /warn:4
> Target DeployOutputFiles:
> Copying file from
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\obj\Debug\WmiWrappers.dll.mdb'
> to
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\WmiWrappers.dll.mdb'
> Copying file from
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\obj\Debug\WmiWrappers.dll'
> to
>
> 'C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\bin\Debug\WmiWrappers.dll'
> Done building project
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\WmiWrappers\WmiWrappers.csproj".
> Project
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\HypervResource.csproj"
> (default target(s)):
> Target RestorePackages:
> Executing: mono --runtime=v4.0.30319
>
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hype
> rvisors\hyperv\DotNet\ServerResource\.nuget\NuGet.exe
> install
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\packages.config"
> -source "" -RequireConsent -solutionDir
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hyp
> ervisors\hyperv\DotNet\ServerResource
> "
> Restoring NuGet packages...
> To prevent NuGet from downloading packages during build, open the 
> Visual Studio Options dialog, click on the Package Manager node and 
> uncheck 'Allow NuGet to download missing packages'.
> WARNING: Error getting response stream (Write: The authentication or 
> decryption has failed.): SendFailure Unable to find version '1.5.23.0' 
> of package 'AWSSDK'.
>
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\\.nuget\NuGet.targets:
> error : Command 'mono --runtime=v4.0.30319 
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hype
> rvisors\hyperv\DotNet\ServerResource\.nuget\NuGet.exe
> install
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\packages.config"
> -source "" -RequireConsent -solutionDir
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hyp
> ervisors\hyperv\DotNet\ServerResource
> " ' exited with code: 1.
> Task "Exec" execution – FAILED
> Done building target "RestorePackages" in project
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hyp
> ervisors\hyperv\DotNet\ServerResource\HypervResource\HypervResource.cs
> proj".--
> FAILED
> Done building project
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hyp
> ervisors\hyperv\DotNet\ServerResource\HypervResource\HypervResource.cs
> proj".--
> FAILED
> Task "MSBuild" execution – FAILED
> Done building target "Build" in project
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hyp
> ervisors\hyperv\DotNet\ServerResource\ServerResource.sln".--
> FAILED
> Done building project
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hyp
> ervisors\hyperv\DotNet\ServerResource\ServerResource.sln".--
> FAILED
>
> Build FAILED.
>
> Warnings:
>
>
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hype
> rvisors\hyperv\DotNet\ServerResource\ServerResource.sln
> (default targets) ->
> (Build target) ->
>
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hype
> rvisors\hyperv\DotNet\ServerResource\WmiWrappers\WmiWrappers.csproj
> (default targets) ->
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets
> (ResolveAssemblyReferences target) ->
>
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'AWSSDK' not resolved
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'Ionic.Zip' not resolved
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'log4net' not resolved
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'Newtonsoft.Json' not resolved
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'NSubstitute' not resolved
> C:\PROGRA~2\MONO-3~1.3\lib\mono\4.0\Microsoft.Common.targets: warning :
> Reference 'xunit' not resolved
>
> Errors:
>
>
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hype
> rvisors\hyperv\DotNet\ServerResource\ServerResource.sln
> (default targets) ->
> (Build target) ->
>
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hype
> rvisors\hyperv\DotNet\ServerResource\HypervResource\HypervResource.csp
> roj
> (default targets) ->
>
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hype
> rvisors\hyperv\DotNet\ServerResource\\.nuget\NuGet.targets
> (RestorePackages target) ->
>
>
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\\.nuget\NuGet.targets:
> error : Command 'mono --runtime=v4.0.30319 
> C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hype
> rvisors\hyperv\DotNet\ServerResource\.nuget\NuGet.exe
> install
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hypervisors\hyperv\DotNet\ServerResource\HypervResource\packages.config"
> -source "" -RequireConsent -solutionDir
>
> "C:\cygwin\home\cloudstack-oss\apache-cloudstack-4.4.0-src\plugins\hyp
> ervisors\hyperv\DotNet\ServerResource
> " ' exited with code: 1.
>
> 6 Warning(s)
> 1 Error(s)
>
> Time Elapsed 00:00:06.7054854
>
Mime
View raw message