cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kirk Kosinski <kirkkosin...@gmail.com>
Subject Re: VM Import
Date Thu, 11 Sep 2014 04:51:03 GMT
Hi, John.  The easiest way is to skip any conversion and copy the VHD
directly from the SR to use as a template.  This requires a file-based
SR, either NFS or local EXT3.  From the log entries you shared I can't
tell what went wrong, so please share more of the log if you still need
help with it.

Best regards,
Kirk

On 09/10/2014 08:52 AM, John Muckley wrote:
> Hi Guys,
> 
> I have a VM which is on a standalone XenServer hypervisor.
> 
> I want to bring this VM into cloudstack.
> 
> I have tried exporting the VM to a .ova file, converting that to a VHD file and importing.
> It imported fine as a template, but upon trying to deploy that VM, I get a 'failed to
deploy' error.
> 
> On examining the logs, I see the following error...
> 
> INFO  [c.c.h.x.r.CitrixResourceBase] (DirectAgent-272:ctx-c6aa3885) VM does not exist
on XenServer012ffb72-a098-41c8-8df4-e5682e074c38
> ERROR [c.c.v.VmWorkJobHandlerProxy] (Work-Job-Executor-152:job-836/job-837 ctx-6951591f)
Invocation exception, caused by: com.cloud.exception.InsufficientServerCapacityException:
Unable to create a deployment for VM[User|i-4-84-VM]Scope=interface com.cloud.dc.DataCenter;
id=1
> 
> XenServerXXX is the naming convention of our old xenservers that were migrating away
from... not sure how this info has ended up being in the cloud logs.
> 
> Anyway, ignoring the error, my actual question is this: what is the easiest / most simple
way to import existing VMs from a XenServer hypervisor into cloudstack?
> 
> I have accomplished this previously by messing around setting up NFS shares etc, but
I wondered what the tried and tested method would be rather than a bodge it and hope it works
method!
> 
> Thanks!
> 
> John
> 
> 

Mime
View raw message