cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ilya musayev <ilya.mailing.li...@gmail.com>
Subject Re: 4.4 install observations
Date Wed, 06 Aug 2014 06:20:34 GMT
Thanks Carlos..
On 8/4/14, 9:23 PM, Carlos Reátegui wrote:
> Hi All
> I just did a new install of 4.4 on Ubuntu 12.04 with XenServer 6.2 using:
>
> $ cat /etc/apt/sources.list.d/cloudstack.list
> deb http://cloudstack.apt-get.eu/ubuntu precise 4.4
>
> This is a basic networking deployment with no security groups (defaultGuestNetwork).
>
> 1) I seeded the templates with:
> $ /usr/share/cloudstack-common/scripts/storage/secondary/cloud-install-sys-tmplt -m /mnt/secondary
-u http://cloudstack.apt-get.eu/systemvm/4.4/systemvm64template-4.4.0-6-xen.vhd.bz2 -h xenserver
-F
>
> The above template is the one put into into the secondary tmpl/1/1, however the DB does
not reflect this download source (see sql below).  Although the template is correct, something
about this mechanism that goes out of band to seed the template does not feel right.  Why
not have the management server process be the one to download the template and place it on
the secondary storage?  The initial entry can be part of the sql scripts so no need for the
install template script. This would also make the upgrade process simpler so that one does
not have to add the new template before shutting down the management process, an entry could
be made by the upgrade sql.
>
> $ mysql -ucloud -p cloud -e "select url from template_view where id=1;"
> Enter password:
> +------------------------------------------------------------------------------------------+
> | url                                                                               
      |
> +------------------------------------------------------------------------------------------+
> | http://download.cloud.com/templates/4.3/systemvm64template-2014-01-14-master-xen.vhd.bz2
|
> +------------------------------------------------------------------------------------------+
>
> 2) XenServer 6.2 hosts do not get vhd-util deployed to them.  I assume it is because
default vhd-util in 6.2 has appropriate functions.  Install doc should state this.
>
> 2a) As an aside, I believe doc has the wrong location to put vhd-util for the other XenServer
versions. It should be placed here:  /usr/share/cloudstack-management/webapps/client/WEB-INF/classes/scripts/vm/hypervisor/xenserver
>
> 3) bridge networking is required to add hosts for basic networking even if not using
security groups otherwise will fail.  It is my understanding that ova is ok without SG but
this is not possible as you can’t add hosts with ova.
>
> 4) optional IP address in "Step 6 Network" of the launch instance does not appear to
work or is misleading.  I hoped it would allow me to request an IP from my range but I am
guessing it is for something else and does not apply to my offering type.  Is it possible
to disable this screen so my users are not confused?
>
>
> Otherwise things apear to be working correctly.  I’ll report back if I run into anything.
>
> Cheers,
> -Carlos


Mime
View raw message