cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sandeep khandekar <cloudstack.sand...@gmail.com>
Subject Re: Error while deploying a new VM
Date Mon, 28 Jul 2014 05:01:15 GMT
I am unable to solve these
http://pastebin.com/ZQR3uQFU
managements server log - time from starting of the management server to the
deployment of new instance.
got exceptions and warnings.

Thanks but, I tried enable maintenance mode didn't worked.
It seems I need to start from scratch again.


On Mon, Jul 28, 2014 at 9:53 AM, Rajani Karuturi <Rajani.Karuturi@citrix.com
> wrote:

> enabling maintenance mode on primary and then cancelling it might help. It
> sends the mount commands again.
>
> ~Rajani
>
>
>
> On 26-Jul-2014, at 10:40 am, sandeep khandekar <
> cloudstack.sandeep@gmail.com> wrote:
>
> > you are right rajesh my primary storage is not coming up now.
> > I dont know how to fix it now. I used certain set of mount commands to
> > mount secondary and primary. If I mount primary first secondary doesnt
> > comes up, and vice versa also. as secondary is keeping all the zones pods
> > and clusters hosts templates work properly I am mounting secondary first
> > and primary next. Any commands how to bring primary up in ubuntu, to
> bring
> > back my cloudstack in running stage.
> >
> >
> > On Fri, Jul 25, 2014 at 1:38 PM, Rajesh Battala <
> rajesh.battala@citrix.com>
> > wrote:
> >
> >> To deploy the VM, first virtual router will be deployed.
> >> From the logs, to deploy the virtual router there is an issue.
> >> Deployment for virtual router is failing due to its not able to find any
> >> storage pool ( local, cluster, zone) wide pool to allocate the root disk
> >> for the VR. Hence VR deployment is failing causing the VM deployment
> >> failure.
> >> Can you check what's wrong with the primary storage!
> >>
> >>
> >> 2014-07-25 11:43:42,859 DEBUG
> >> [storage.allocator.LocalStoragePoolAllocator] (Job-Executor-6:job-15 = [
> >> 06e5b887-a9ef-4668-a1b3-623911e16ab4 ]) LocalStoragePoolAllocator
> returning
> >> 0 suitable storage pools
> >> 2014-07-25 11:43:42,860 DEBUG
> >> [storage.allocator.ClusterScopeStoragePoolAllocator]
> (Job-Executor-6:job-15
> >> = [ 06e5b887-a9ef-4668-a1b3-623911e16ab4 ])
> >> ClusterScopeStoragePoolAllocator looking for storage pool
> >> 2014-07-25 11:43:42,860 DEBUG
> >> [storage.allocator.ZoneWideStoragePoolAllocator] (Job-Executor-6:job-15
> = [
> >> 06e5b887-a9ef-4668-a1b3-623911e16ab4 ]) ZoneWideStoragePoolAllocator to
> >> find storage pool
> >> 2014-07-25 11:43:42,860 DEBUG
> [cloud.deploy.DeploymentPlanningManagerImpl]
> >> (Job-Executor-6:job-15 = [ 06e5b887-a9ef-4668-a1b3-623911e16ab4 ]) No
> >> suitable pools found for volume: Vol[4|vm=4|ROOT] under cluster: 1
> >> 2014-07-25 11:43:42,860 DEBUG
> [cloud.deploy.DeploymentPlanningManagerImpl]
> >> (Job-Executor-6:job-15 = [ 06e5b887-a9ef-4668-a1b3-623911e16ab4 ]) No
> >> suitable pools found
> >> 2014-07-25 11:43:42,860 DEBUG
> [cloud.deploy.DeploymentPlanningManagerImpl]
> >> (Job-Executor-6:job-15 = [ 06e5b887-a9ef-4668-a1b3-623911e16ab4 ]) No
> >> suitable storagePools found under this Cluster: 1
> >> 2014-07-25 11:43:42,861 DEBUG
> [cloud.deploy.DeploymentPlanningManagerImpl]
> >> (Job-Executor-6:job-15 = [ 06e5b887-a9ef-4668-a1b3-623911e16ab4 ]) Could
> >> not find suitable Deployment Destination for this VM under any clusters,
> >> returning.
> >>
> >>
> >>
> >> Thanks
> >> Rajesh Battala
> >>
> >> -----Original Message-----
> >> From: sandeep khandekar [mailto:cloudstack.sandeep@gmail.com]
> >> Sent: Friday, July 25, 2014 1:24 PM
> >> To: users@cloudstack.apache.org
> >> Subject: Re: Error while deploying a new VM
> >>
> >> Please find the  copy of log the details on the link below for  job-15
> >> http://paste.algolibre.com/115
> >> Thank you
> >>
> >>
> >>
> >> On Fri, Jul 25, 2014 at 12:05 PM, sandeep khandekar <
> >> cloudstack.sandeep@gmail.com> wrote:
> >>
> >>> Dear ALL,
> >>>
> >>> Previously I used to have cloudstack, it was running properly, created
> >>> the instances successfully also.  I destroyed the prevoius
> >>> installation of cloudstack.  not removed any of the files of previous
> >>> cloudstack(/export/secondary, /export/primary) . I just wiped the
> >>> database "drop database cloud;"  and again created the database and
> >>> installed/downloaded isos everything properly.
> >>>
> >>> Everything is coming up except my virtual router. is these causing
> >> problem?
> >>> Any idea how to solve these ?
> >>>
> >>>
> >>> On Fri, Jul 25, 2014 at 11:44 AM, sandeep khandekar <
> >>> cloudstack.sandeep@gmail.com> wrote:
> >>>
> >>>>
> >>>> root@cloudstack:/home/cloudstack# tail -f
> >>>> /var/log/cloudstack/management/management-server.log|grep exception
> >>>> com.cloud.exception.InsufficientServerCapacityException: Unable to
> >>>> create a deployment for VM[DomainRouter|r-4-VM]Scope=interface
> >>>> com.cloud.dc.DataCenter; id=1
> >>>> 2014-07-25 11:43:45,754 INFO  [user.vm.DeployVMCmd]
> >>>> (Job-Executor-6:job-15 = [ 06e5b887-a9ef-4668-a1b3-623911e16ab4 ])
> >>>> com.cloud.exception.InsufficientServerCapacityException: Unable to
> >>>> create a deployment for VM[User|a]Scope=interface
> >>>> com.cloud.dc.DataCenter; id=1
> >>>> com.cloud.exception.InsufficientServerCapacityException: Unable to
> >>>> create a deployment for VM[User|a]Scope=interface
> >>>> com.cloud.dc.DataCenter; id=1
> >>>>
> >>>>
> >>>>
> >>>> On Fri, Jul 25, 2014 at 11:39 AM, Suresh Sadhu
> >>>> <Suresh.Sadhu@citrix.com>
> >>>> wrote:
> >>>>
> >>>>> Dear Sandeep,
> >>>>>
> >>>>> Please cut and paste the error/exception content from the logs.
> >>>>> without  logs it difficult to analyse the problem.
> >>>>>
> >>>>> Regards
> >>>>> Sadhu
> >>>>>
> >>>>>
> >>>>> -----Original Message-----
> >>>>> From: sandeep khandekar [mailto:cloudstack.sandeep@gmail.com]
> >>>>> Sent: 25 July 2014 10:31
> >>>>> To: users@cloudstack.apache.org
> >>>>> Subject: Re: Error while deploying a new VM
> >>>>>
> >>>>> host is up and running
> >>>>>
> >>>>>
> >>>>> On Fri, Jul 25, 2014 at 10:29 AM, sandeep khandekar <
> >>>>> cloudstack.sandeep@gmail.com> wrote:
> >>>>>
> >>>>>> I am working on single node.
> >>>>>>
> >>>>>>
> >>>>>> On Fri, Jul 25, 2014 at 9:42 AM, Suresh Sadhu
> >>>>>> <Suresh.Sadhu@citrix.com>
> >>>>>> wrote:
> >>>>>>
> >>>>>>> Sandeep,
> >>>>>>>
> >>>>>>> Please provide error log(MSlog) content .
> >>>>>>>
> >>>>>>>
> >>>>>>> It seems your host  is not up. Check your host state.
> >>>>>>>
> >>>>>>>
> >>>>>>> Regards
> >>>>>>> sadhu
> >>>>>>>
> >>>>>>>
> >>>>>>> -----Original Message-----
> >>>>>>> From: sandeep khandekar [mailto:cloudstack.sandeep@gmail.com]
> >>>>>>> Sent: 25 July 2014 09:37
> >>>>>>> To: users@cloudstack.apache.org
> >>>>>>> Subject: Error while deploying a new VM
> >>>>>>>
> >>>>>>> Dear Cloudstackers,
> >>>>>>>
> >>>>>>> I downloaded ubunut.iso, I deployed it, the following error
I got.
> >>>>>>>
> >>>>>>> Failed to deploy Vm with Id: 3, on Host with Id: null
> >>>>>>>
> >>>>>>> 2014-07-25 09:34:38,575 INFO
> >>>>>>> [cloud.ha.HighAvailabilityManagerImpl]
> >>>>>>> (HA-2:null) checking health of usage server
> >>>>>>> 2014-07-25 09:34:38,577 DEBUG
> >>>>>>> [cloud.ha.HighAvailabilityManagerImpl]
> >>>>>>> (HA-2:null) usage server running? false, heartbeat: null
> >>>>>>> 2014-07-25 09:34:38,578 WARN  [apache.cloudstack.alerts]
> >>>>>>> (HA-2:null)
> >>>>>>> alertType:: 13 // dataCenterId:: 0 // podId:: 0 // clusterId::
> >>>>>>> null //
> >>>>>>> message:: No usage server process running
> >>>>>>>
> >>>>>>>
> >>>>>>> Virtual router is unable to start. Everything is running
properly
> >>>>>>> including templates.
> >>>>>>>
> >>>>>>> Any help.
> >>>>>>> --
> >>>>>>> SANDEEP KHANDEKAR
> >>>>>>> Assistant Professor
> >>>>>>> Department of Computer science and engineering Sreenidhi
> >>>>>>> Institute of science and Technology Hyderabad
> >>>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> --
> >>>>>> SANDEEP KHANDEKAR
> >>>>>> Assistant Professor
> >>>>>> Department of Computer science and engineering Sreenidhi Institute
> >>>>>> of science and Technology Hyderabad
> >>>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>> --
> >>>>> SANDEEP KHANDEKAR
> >>>>> Assistant Professor
> >>>>> Department of Computer science and engineering Sreenidhi Institute
> >>>>> of science and Technology Hyderabad
> >>>>>
> >>>>
> >>>>
> >>>>
> >>>> --
> >>>> SANDEEP KHANDEKAR
> >>>> Assistant Professor
> >>>> Department of Computer science and engineering
> >>>> Sreenidhi Institute of science and Technology
> >>>> Hyderabad
> >>>>
> >>>
> >>>
> >>>
> >>> --
> >>> SANDEEP KHANDEKAR
> >>> Assistant Professor
> >>> Department of Computer science and engineering
> >>> Sreenidhi Institute of science and Technology
> >>> Hyderabad
> >>>
> >>
> >>
> >>
> >> --
> >> SANDEEP KHANDEKAR
> >> Assistant Professor
> >> Department of Computer science and engineering
> >> Sreenidhi Institute of science and Technology
> >> Hyderabad
> >>
> >
> >
> >
> > --
> > SANDEEP KHANDEKAR
> > Assistant Professor
> > Department of Computer science and engineering
> > Sreenidhi Institute of science and Technology
> > Hyderabad
>
>


-- 
SANDEEP KHANDEKAR
Assistant Professor
Department of Computer science and engineering
Sreenidhi Institute of science and Technology
Hyderabad

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message