cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prashant Kumar Mishra <prashantkumar.mis...@citrix.com>
Subject RE: VM's using custom offerings wont let us use the migrate host from UI !!!
Date Tue, 27 May 2014 09:15:06 GMT
If you are seeing error message like below I mentioned  please open a ticket ,If not can you
please some relevant logs .


Log
====
2014-02-03 10:07:25,234 DEBUG [c.c.a.m.a.i.FirstFitAllocator] (catalina-exec-16:ctx-fca502c2
ctx-cb0c10a8) FirstFitAllocator has 1 hosts to check for allocation: [Host[-4-Routing]]
2014-02-03 10:07:25,237 DEBUG [c.c.a.m.a.i.FirstFitAllocator] (catalina-exec-16:ctx-fca502c2
ctx-cb0c10a8) Found 1 hosts for allocation after prioritization: [Host[-4-Routing]]
2014-02-03 10:07:25,238 ERROR [c.c.a.ApiServer] (catalina-exec-16:ctx-fca502c2 ctx-cb0c10a8)
unhandled exception executing api command: findHostsForMigration
java.lang.NullPointerException
at com.cloud.agent.manager.allocator.impl.FirstFitAllocator.allocateTo(FirstFitAllocator.java:267)
at com.cloud.agent.manager.allocator.impl.FirstFitAllocator.allocateTo(FirstFitAllocator.java:238)
at com.cloud.server.ManagementServerImpl.listHostsForMigrationOfVM(ManagementServerImpl.java:1195)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:317)
at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:183)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:150)
at org.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:91)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)
at $Proxy210.listHostsForMigrationOfVM(Unknown Source)
at org.apache.cloudstack.api.command.admin.host.FindHostsForMigrationCmd.execute(FindHostsForMigrationCmd.java:75)
at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:161)

-----Original Message-----
From: Amin Samir [mailto:amin@opencloud.net.au] 
Sent: Tuesday, May 27, 2014 2:36 PM
To: users@cloudstack.apache.org
Subject: RE: VM's using custom offerings wont let us use the migrate host from UI !!!

Sorry forgot to mention this cloud stack is migrated twice before from 2.2.14 to 4.2.1 then
4.3 if this helps

Kind Regards
Amin 

-----Original Message-----
From: Amin Samir
Sent: Tuesday, 27 May 2014 5:04 PM
To: users@cloudstack.apache.org
Subject: RE: VM's using custom offerings wont let us use the migrate host from UI !!!

Hi Devdeep,

Thanks for replying, it is one cluster with 7 hosts, we still have room to migrate this host,
in fact other machines created from pre-defined offerings do migrate fine.

All hosts are running the same version Xen Server 6.2 SP1, 

There is no logs the when you click the migrate to host icon it does not pop up, while another
vm created from pre-defined offer and from the same browser show the pop up when migrate to
host is clicked.

Kind Regards
Amin 

   



-----Original Message-----
From: Devdeep Singh [mailto:devdeep.singh@citrix.com]
Sent: Tuesday, 27 May 2014 4:58 PM
To: users@cloudstack.apache.org
Subject: RE: VM's using custom offerings wont let us use the migrate host from UI !!!

How many hosts do you have in your setup and how are they distributed across clusters? Are
all hosts running the same version of the xenserver hypervisor? Do you see the issue only
with custom offering; or is it seen if an instance has been created with any other offering?
Anything in the cloudstack logs when you try and list the hosts for migration from the UI?

Regards,
Devdeep

> -----Original Message-----
> From: Amin Samir [mailto:amin@opencloud.net.au]
> Sent: Friday, May 23, 2014 8:12 AM
> To: users@cloudstack.apache.org
> Subject: VM's using custom offerings wont let us use the migrate host 
> from UI !!!
> 
> Hello,
> 
> 
> We have cloud stack 4.3 over centos our hypervisors are xen server 6.2
> SP1 with latest updates, the VM's that are created from custom 
> offering don't let us use the migrate host icon from the UI, however 
> you can move them from the xen center console.
> 
> 
> Has anyone faced this issue before?
> 
> 
> Kind Regards
> 
> 




Mime
View raw message