cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebgoa <run...@gmail.com>
Subject Re: Documentation question/verification (upgrade from 4.0 to 4.2.1)
Date Wed, 30 Apr 2014 13:05:44 GMT

On Apr 30, 2014, at 3:12 AM, Pierre-Luc Dion <pdion@cloudops.com> wrote:

> Nick,
> 
> You have to set the version you want to upgrade to, so if you want to
> upgrade to latest: 4.3
> package repo line:
> 
> deb http://cloudstack.apt-get.eu/ubuntu precise 4.3
> 
> if you have to install 4.2.1 :
> 
> deb http://cloudstack.apt-get.eu/ubuntu precise 4.2
> 
> 
> I will update documentation, thanks for pointing this mistake.
> 
> 

Pierre Luc, I pushed you change, but going through it there seems to be lost of other places
where there is a mix up between 4.0, 4.1 and what should be 4.3

any luck you can go through it again and make a pr for the appropriate changes ?

To everyone: if you see errors like these, feel free to click on 'edit on github' button,
make the change and send a pull request.

thanks

> 
> Pierre-Luc Dion
> Architecte de Solution Cloud | Cloud Solutions Architect
> 855-OK-CLOUD (855-652-5683) x1101
> - - -
> 
> *CloudOps*420 rue Guy
> Montréal QC  H3J 1S6
> www.cloudops.com
> @CloudOps_
> 
> 
> On Tue, Apr 29, 2014 at 2:28 PM, Nick Burke <nick@nickburke.com> wrote:
> 
>> Thank you for the reply!
>> 
>> The document:
>> 
>> 
>> 
>> http://docs.cloudstack.apache.org/projects/cloudstack-release-notes/en/4.3/rnotes.html#upgrade-from-4-0-x-to-4-3
>> 
>> Still has this in section: 8.1
>> 
>> *This file should have one line, which contains:*
>> 
>> *deb http://cloudstack.apt-get.eu/ubuntu
>> <http://cloudstack.apt-get.eu/ubuntu> precise 4.0
>> *
>> 
>> *We’ll change it to point to the new package repository:*
>> 
>> *deb http://cloudstack.apt-get.eu/ubuntu
>> <http://cloudstack.apt-get.eu/ubuntu> precise 4.1
>> *
>> 
>> *If you’re using your own package repository, change this line to read as
>> appropriate for your 4.1.0 repository.*
>> Should it be 4.3 or 4.1?
>> 
>> 
>> On Tue, Apr 29, 2014 at 12:39 AM, sebgoa <runseb@gmail.com> wrote:
>> 
>>> 
>>> On Apr 28, 2014, at 9:46 PM, Nick Burke <nick@nickburke.com> wrote:
>>> 
>>>> If this has already been addressed, my apologies, I did do a search
>>> first.
>>>> :-)
>>>> 
>>>> In the documentation located at:
>>>> 
>>>> 
>>> 
>> http://cloudstack.apache.org/docs/en-US/Apache_CloudStack/4.2.1/html/Release_Notes/upgrade-instructions.html#upgrade-from-4.0-to-4.2.1
>>>> 
>>>> In section 9.a it states:
>>>> 
>>>> *This file should have one line, which contains: *
>>>> 
>>>> *deb http://cloudstack.apt-get.eu/ubuntu
>>>> <http://cloudstack.apt-get.eu/ubuntu> precise 4.0*
>>>> 
>>>> * We'll change it to point to the new package repository: *
>>>> 
>>>> *deb http://cloudstack.apt-get.eu/ubuntu
>>>> <http://cloudstack.apt-get.eu/ubuntu> precise 4.1*
>>>> 
>>>> * If you're using your own package repository, change this line to read
>>> as
>>>> appropriate for your 4.1.0 repository. *
>>>> 
>>>> Is it correct in that I should be using the 4.1 branch for some
>> reason? I
>>>> checked in the repo and there is a 4.2 branch. Is it an incremental
>>> upgrade
>>>> (IE: from 4.0 to 4.1 and then to 4.2) that I missed in the
>> documentation?
>>>> 
>>>> Thanks in advance!
>>>> 
>>> 
>>> Hi, 4.3 is out so you might want to consider upgrading to 4.3 instead of
>>> 4.2:
>>> 
>>> 
>>> 
>> http://docs.cloudstack.apache.org/projects/cloudstack-release-notes/en/4.3/rnotes.html#upgrade-from-4-0-x-to-4-3
>>> 
>>> 
>>>> --
>>>> Nick
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> *'What is a human being, then?' 'A seed' 'A... seed?' 'An acorn that is
>>>> unafraid to destroy itself in growing into a tree.' -David Zindell, A
>>>> Requiem for Homo Sapiens*
>>> 
>>> 
>> 
>> 
>> --
>> Nick
>> 
>> 
>> 
>> 
>> 
>> *'What is a human being, then?' 'A seed' 'A... seed?' 'An acorn that is
>> unafraid to destroy itself in growing into a tree.' -David Zindell, A
>> Requiem for Homo Sapiens*
>> 


Mime
View raw message