cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marty Sweet <msweet....@gmail.com>
Subject Re: Nginx reverse proxy to cloud stack
Date Tue, 25 Feb 2014 07:38:47 GMT
Hi Amin,

The error shown should have hopefully been fixed by adjusting the
proxy_pass, did you restart nginx?
Just to confirm, does navigating to https://amin.com.au/client/ load
fully but still result in a username/password incorrect (giving the
error shown above)?

Thanks,
Marty

On Tue, Feb 25, 2014 at 4:54 AM, Amin Samir <aminsamiramin@hotmail.com> wrote:
>
>
>
> Hi Marty,
> thanks for you fast reply, editing the proxy_pass to be http://localhost:8080 ; does
not help, in regards to the location /, when I recall the server from the browser I use "amin.com.au"
and I have this domain name set in the local hosts file.  One more thing to mention is cloud
stack is working with its own URL fine.
> The F12 error output is as follows:
> <html><head><title>Apache Tomcat/6.0.35 - Error report</title><style><!--H1
{font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;}
H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;}
H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;}
BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;}
P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color
: black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP
Status 404 - /client/client/api</h1><HR size="1" noshade="noshade"><p><b>type</b>
Status report</p><p><b>message</b> <u>/client/client/api</u></p><p><b>description</b>
<u>The requested resource (/client/client/api) is not available.</u></p><HR
size="1" noshade="noshade"><h3>Apache Tomcat/6.0.35</h3></body></html>
>
> --------Seems there is a duplication in /client/client/api-------------
> I dont know how rectify this I am newbie cloudstack and nginx.
>
> Thanks in advance.
> Amin
>
>
>> Date: Tue, 25 Feb 2014 04:15:40 +0000
>> Subject: Re: Nginx reverse proxy to cloud stack
>> From: msweet.dev@gmail.com
>> To: users@cloudstack.apache.org
>> CC: aminsamiramin@hotmail.com
>>
>> Hi Amin,
>>
>> From first glance it seems that it could be related to your location
>> being '/' - although I personally haven't setup CS behind NGinx
>> before.
>> Is there any improvement if 'proxy_pass http://localhost:8080;' is
>> used? This should make the paths be the 'same' - although it should
>> all be relative anyway - worth a try.
>>
>> You may also be able to see if any web errors are occurring by
>> profiling network on most new browsers (F12).
>> Also is there anything obvious in your management logs?
>>
>> Let us know how you get on,
>> Marty
>>
>> On Tue, Feb 25, 2014 at 1:57 AM, Amin Samir <aminsamiramin@hotmail.com> wrote:
>> > Hello,
>> >
>> > I am trying to configure Nginx to reverse proxy cloud stack to offload SSL,
I have done the following:
>> > Installed the NginxCreated a virtual host with the following:server {
>> >     server_name  amin.com.au;
>> >  location / {
>> >         proxy_set_header X-Forwarded-Host $host;
>> >         proxy_set_header X-Forwarded-Server $host;
>> >         proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
>> >         proxy_pass http://localhost:8080/client/;
>> >     }
>> > When trying to log on to cloud stack it gives me wrong user name and password.I
even added the root to be root /usr/share/cloudstack-management/webapps/client/; index index.jsp;
(still does not authenticate me).
>> > however when trying to log in using http://amin.com.au it authenticates me and
works smoothly.
>> >
>> > Any idea why is this happening.
>> >
>> > Thanks in advance for advise what might be the cause.
>> >
>> >
>> > Amin
>> >
>> >
>>
>>
>>
>> --
>> Marty
>
>



-- 
Marty

Mime
View raw message