cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Kumar <rohit...@outlook.com>
Subject RE: Cloudstack:KVM:: Snapshot stuck in Creating Status forever.
Date Tue, 25 Feb 2014 12:07:34 GMT
Hi,
I am working on CloudStack infrastructure service to build our organization framework.For
this purpose, RHEL 6.4, Cloudstack 4.2.1 and KVM are being used.
I have been working around for long to figure out the below mentioned Issue but unfortunately
could not.
Issue: Snapshot gets stuck in the state "Creating" forever(Screenshot attached).
Impact: Couldn't get the snapshot consequently and thus, the instance from the CloudStack's
UI could not be started/Stopped.
Please see below trace from Management Server log which I think is the reason behind (full
log attached).
Unexpected exception while executing org.apache.cloudstack.api.command.user.vmsnapshot.CreateVMSnapshotCmdcom.cloud.utils.exception.CloudRuntimeException:
com.cloud.agent.api.UnsupportedAnswer cannot be cast to com.cloud.agent.api.CreateVMSnapshotAnswer
Please see below trace from agent log which was written at the moment I clicked on Snapshot
button in the Cloudstack's UI:
2014-02-25 17:27:09,129 WARN  [kvm.resource.LibvirtComputingResource] (agentRequest-Handler-4:null)
Unsupported command
In order to restart the instance again, I manually delete the row from the table vm_snapshots
in mysql database corresponding to this stuck snapshot.
Please suggest me the fix with proper explanation for this issue.
Thanks in advance.
Regards,Rohit  		 	   		   		 	   		  
Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message