cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Battala <rajesh.batt...@citrix.com>
Subject RE: hyper-v agent building on cloudstack 4.3
Date Mon, 03 Feb 2014 03:14:24 GMT
Hi Tejas, 
Good to know agent is running now.
What you have fixed to run the agent?

Thanks
Rajesh Battala

-----Original Message-----
From: Tejas Gadaria [mailto:refond.gmrt@gmail.com] 
Sent: Thursday, January 30, 2014 8:57 PM
To: Anshul Gangwar; users@cloudstack.apache.org
Subject: Re: hyper-v agent building on cloudstack 4.3

Hi,

Thanks for support.
Hyper-V agent is working now.!

Regards,
Tejas


On Thu, Jan 30, 2014 at 12:14 PM, Tejas Gadaria <refond.gmrt@gmail.com>wrote:

> Hi,
>
> Recent log are as below,
>
> 2014-01-30 11:33:01,691 [1] DEBUG CloudStack.Plugin.AgentShell.Program
> [(null)] - CloudStack Hyper-V Agent arg is
> 2014-01-30 11:33:01,833 [1] INFO  CloudStack.Plugin.AgentShell.Program
> [(null)] - Installing and running CloudStack Hyper-V Agent
> 2014-01-30 11:33:03,511 [1] INFO  CloudStack.Plugin.AgentShell.Program
> [(null)] - CloudStack Hyper-V Agent running as Windows Service
> 2014-01-30 11:33:03,741 [1] INFO
>  CloudStack.Plugin.AgentShell.AgentService [(null)] - Starting 
> CloudStack agent
> 2014-01-30 11:33:19,437 [1] ERROR CloudStack.Plugin.AgentShell.Program
> [(null)] -  Error occured in starting service Cannot start service 
> CloudStack Hyper-V Agent on computer '.'.
>
> As describe in earlier mail, service is visible in services.msc , but 
> its service status = Stop.
>
> When I am trying to start service by manually it says Error 1053: The 
> service did not respond to the start or control request in a timely 
> fashion ".
>
>  I found below link, I am facing same issues except that my system is 
> in domain so my primay dns suffix is set, Also I am getting similar 
> pop-up as mentioned in url http://imgur.com/NMan0S2
>
>
> http://mail-archives.apache.org/mod_mbox/cloudstack-dev/201401.mbox/%3
> Ccebd9db60ab9492aa023b5aa9d074048@AMXPR07MB117.eurprd07.prod.outlook.c
> om%3E
>
> Regards,
> Tejas
>
>
>
>
> On Thu, Jan 30, 2014 at 11:27 AM, Anshul Gangwar < 
> anshul.gangwar@citrix.com> wrote:
>
>>  Hi,
>>
>>
>>
>> Are you able to resolve your issue?
>>
>>
>>
>> If not can you look into cloudstack-agent log. That will be present 
>> in same folder as agentshell.exe
>>
>>
>>
>> Regards,
>>
>> Anshul
>>
>>
>>
>> *From:* Tejas Gadaria [mailto:refond.gmrt@gmail.com]
>> *Sent:* Thursday, January 30, 2014 11:23 AM
>>
>> *To:* Anshul Gangwar
>> *Subject:* Re: hyper-v agent building on cloudstack 4.3
>>
>>
>>
>> Hi Anshul,
>>
>> I didn't notice that I am replying to your personal id.
>>
>> Sorry for that and thanks for reply.
>>
>> Regards,
>>
>> Tejas
>>
>>
>>
>> On Wed, Jan 29, 2014 at 5:44 PM, Tejas Gadaria 
>> <refond.gmrt@gmail.com>
>> wrote:
>>
>> Hi Anshul,
>>
>>
>>
>> Sorry for late reply,
>>
>> Firewall completely disabled and I have log on as service rights 
>> available.
>>
>>
>>
>> Regards,
>>
>> Tejas
>>
>>
>>
>> On Wed, Jan 29, 2014 at 4:20 PM, Anshul Gangwar < 
>> anshul.gangwar@citrix.com> wrote:
>>
>> Have you disabled firewall? If not try that or open up the 8250 port  
>> and check if service comes up now.
>>
>>
>>
>>
>>
>> *From:* Anshul Gangwar
>> *Sent:* Wednesday, January 29, 2014 4:13 PM
>> *To:* 'Tejas Gadaria'
>>
>>
>> *Subject:* RE: hyper-v agent building on cloudstack 4.3
>>
>>
>>
>> Can you verify whether the user has log on as service rights?
>>
>>
>>
>> *From:* Tejas Gadaria [mailto:refond.gmrt@gmail.com]
>>
>> *Sent:* Wednesday, January 29, 2014 3:33 PM
>> *To:* Anshul Gangwar
>>
>> *Subject:* Re: hyper-v agent building on cloudstack 4.3
>>
>>
>>
>> Hi Anshul,
>>
>>
>>
>> DNS Suffix is already set on the host.
>>
>>
>>
>> I re-installed Hyperv Agent with Domain\Administrator Privileges. I 
>> think Agent has installed, but service is not started.
>>
>> In services.msc ,  I got service called "CloudStack Hyper-V Agent", 
>> service type=Automatic, Service Status = Stop
>>
>>
>>
>> When I tried to start service by clicking on 'start' button, I 
>> received "Error
>> 1053: The service did not respond to the start or control request in 
>> a timely fashion "
>>
>>
>>
>> Logs for hyperv agent are as below,
>>
>>
>>
>> 2014-01-29 14:36:42,264 [1] DEBUG 
>> CloudStack.Plugin.AgentShell.Program
>> [(null)] - CloudStack Hyper-V Agent arg is
>>
>> 2014-01-29 14:36:42,373 [1] INFO  
>> CloudStack.Plugin.AgentShell.Program
>> [(null)] - Installing and running CloudStack Hyper-V Agent
>>
>> 2014-01-29 14:36:43,467 [1] INFO  
>> CloudStack.Plugin.AgentShell.Program
>> [(null)] - CloudStack Hyper-V Agent running as Windows Service
>>
>> 2014-01-29 14:36:43,686 [1] INFO
>>  CloudStack.Plugin.AgentShell.AgentService [(null)] - Starting 
>> CloudStack agent
>>
>> 2014-01-29 14:36:59,356 [1] ERROR 
>> CloudStack.Plugin.AgentShell.Program
>> [(null)] -  Error occured in starting service Cannot start service 
>> CloudStack Hyper-V Agent on computer '.'.
>>
>>
>>
>>
>>
>> Regards,
>>
>> Tejas
>>
>>
>>
>> On Wed, Jan 29, 2014 at 10:28 AM, Anshul Gangwar < 
>> anshul.gangwar@citrix.com> wrote:
>>
>> Hi Tejas,
>>
>> Can you verify weather dns suffix is set on host?
>>
>> You can use ipconfig to verify that.
>>
>> If it is blank you can use below command to set the dns suffix
>>
>> netdom computername hostname.domain.com 
>> /add:newhostname.newdomain.comnetdom computername hostname.domain.com 
>> /makeprimary:newhostname.newdomain.com
>>
>> then uninstall the Agent
>>
>> AgentShell.exe --uninstall
>>
>> And then reinstall the agent.
>>
>> Regards,
>> Anshul
>>
>>
>>
>> -----Original Message-----
>> From: Anshul Gangwar
>> Sent: Wednesday, January 29, 2014 10:08 AM
>> To: Ram Ganesh; users@cloudstack.apache.org
>> Cc: Devdeep Singh; Rajesh Battala
>> Subject: RE: hyper-v agent building on cloudstack 4.3
>>
>> Hi Tejas,
>>
>> Can you look into following mail threads and see if that resolves 
>> your problem
>>
>> https://www.mail-archive.com/dev@cloudstack.apache.org/msg21392.html
>>
>> https://www.mail-archive.com/dev@cloudstack.apache.org/msg20556.html
>>
>> PS : Its Anshul not Anush
>>
>> Regards,
>> Anshul
>>
>>
>>
>> -----Original Message-----
>> From: Ram Ganesh
>> Sent: Tuesday, January 28, 2014 11:02 PM
>> To: users@cloudstack.apache.org
>> Cc: Anshul Gangwar; Devdeep Singh; Rajesh Battala
>>
>> Subject: RE: hyper-v agent building on cloudstack 4.3
>>
>> > -----Original Message-----
>> > From: Tejas Gadaria [mailto:refond.gmrt@gmail.com]
>> > Sent: 28 January 2014 21:29
>> > To: users@cloudstack.apache.org
>> > Subject: Re: hyper-v agent building on cloudstack 4.3
>> >
>> > Hi Anush,
>> >
>> > I was trying to add hyper-v host to the Zone, and log was 
>> > indicating agent is not running on hyper-v host.
>> > I checked on hyper-v host but I could not find any service running 
>> > in
>> > *services.msc* named Cloudstack Agent.
>> > Execution of AgentShell.exe is not logged in *Windows Event log*.
>> >
>> > Also I tried to re-install the Agent, and indicates,
>> >
>> > 2014-01-28 18:43:05,288 [1] DEBUG 
>> > CloudStack.Plugin.AgentShell.Program
>> > [(null)] - CloudStack Hyper-V Agent arg is
>> > 2014-01-28 18:43:05,427 [1] INFO  
>> > CloudStack.Plugin.AgentShell.Program
>> > [(null)] - Installing and running CloudStack Hyper-V Agent
>> > 2014-01-28 18:43:05,519 [1] ERROR 
>> > CloudStack.Plugin.AgentShell.Program
>> > [(null)] -  Error occured in starting service Cannot start service 
>> > CloudStack Hyper-V Agent on computer '.'.
>> >
>> > AgentShell.exe --install -u <username> -p <password>
>> >
>> > I have tried executed this command where username is domainuser and 
>> > localadministrator both, but didn't work this time.
>>
>> [RamG] I think the user should be a domain admin and also belong to 
>> HyperV-Admin group as well to inherit rights around migrating a VM 
>> from one host to another. Can you check on that?
>>
>>
>> >
>> > Regards,
>> > Tejas
>> >
>> >
>> > On Tue, Jan 28, 2014 at 12:14 PM, Tejas Gadaria
>> > <refond.gmrt@gmail.com>wrote:
>> >
>> > > Hi Anush,
>> > >
>> > > Thanks It worked for me, I have installed Certificate also.
>> > > Log file indicates Cloudstack hyper v agent  is running on 
>> > > windows system.
>> > >
>> > > Regards,
>> > > Tejas
>> > >
>> > >
>> > > On Tue, Jan 28, 2014 at 11:22 AM, Anshul Gangwar < 
>> > > anshul.gangwar@citrix.com> wrote:
>> > >
>> > >> Yes that exe will install everything except the certificate. To 
>> > >> install the ssl certificate you can follow the link
>> > >>
>> > https://cwiki.apache.org/confluence/display/CLOUDSTACK/Manually+Cre
>> > at
>> > >>
>> > ing+and+installing+self+signed+certificate+for+CloudStack+Management+
>> > >> Server+communication+with+Hyper-V+agent
>> > >> .
>> > >>
>> > >> You have to execute AgentShell.exe as follows
>> > >>
>> > >> *AgentShell.exe --install -u <username> -p <password>
>> > >>
>> > >>               where username is of form domain\username or 
>> > >> username for example Administrator or blr\Administrator
>> > >>
>> > >>               This user should be part of local Administrators 
>> > >> and Hyper-V Administrators group on the host
>> > >>
>> > >> I have updated the wiki with above details
>> > >>
>> > >> Regards,
>> > >> Anshul
>> > >>
>> > >> -----Original Message-----
>> > >> From: Tejas Gadaria [mailto:refond.gmrt@gmail.com]
>> > >> Sent: Tuesday, January 28, 2014 10:49 AM
>> > >> To: users@cloudstack.apache.org
>> > >> Subject: Re: hyper-v agent building on cloudstack 4.3
>> > >>
>> > >> Hi Anshul,
>> > >>
>> > >> I had not clone repo from git, So I don't have buildagent.sh
>> available.
>> > >> I am going to follow this now, by the way this Jenkins job hyper 
>> > >> v agent lokks like polished form of agent for hyper v , Will it 
>> > >> install everything from .exe ?
>> > >>
>> > >> Regards,
>> > >> Tejas
>> > >>
>> > >>
>> > >> On Tue, Jan 28, 2014 at 10:30 AM, Anshul Gangwar
>> > >> <anshul.gangwar@citrix.com>wrote:
>> > >>
>> > >> > Have you cloned the asf cloudstack git repo 
>> > >> > https://git-wip-us.apache.org/repos/asf/cloudstack.git ?. The

>> > >> > (cloudstack src folder) is pointing to root of the git repo.
>> > >> >
>> > >> > Have you tried giving executable permissions(chmod +x
>> > >> > buildagent.sh) to buildagent.sh if file is already there?
>> > >> >
>> > >> > If you want you can build the agent zip using Jenkins job 
>> > >> > http://jenkins.buildacloud.org/view/4.3/job/HyperVAgent4.3/ .
>> > >> >
>> > >> > Regards,
>> > >> > Anshul
>> > >> >
>> > >> > -----Original Message-----
>> > >> > From: Tejas Gadaria [mailto:refond.gmrt@gmail.com]
>> > >> > Sent: Tuesday, January 28, 2014 10:11 AM
>> > >> > To: users@cloudstack.apache.org
>> > >> > Subject: hyper-v agent building on cloudstack 4.3
>> > >> >
>> > >> > I am trying to build hyper-v agent and following below link,
>> > >> >
>> > >> >
>> > >> >
>> > https://cwiki.apache.org/confluence/display/CLOUDSTACK/Creating+Hyp
>> > >> > erv
>> > >> > +Agent+Installer
>> > >> >
>> > >> > I have executed "mozroots --import --ask-remove" successfully
>> > >> >
>> > >> > now i am trying to execute buildagent.sh script through 
>> > >> > Cygwin, but link says script is located on (cloudstack src 
>> > >> > folder)/plugins/hypervisors/hyperv/ but I could not find this

>> > >> > path on Cygwin or on Management server.
>> > >> >
>> > >> > I don't understand where I am missing.
>> > >> >
>> > >> > Regards,
>> > >> > Tejas
>> > >> >
>> > >>
>> > >
>> > >
>>
>>
>>
>>
>>
>>
>>
>
>

Mime
View raw message