cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Melnik" <v.mel...@tucha.co.uk>
Subject httpd on console proxy VM
Date Tue, 25 Feb 2014 12:02:25 GMT
Dear colleagues,

I'm installing CloudStack-4.2.1 on the new setup and I've faced an odd
thing. Alas, httpd on the console proxy VM doesn't start, because it's
trying to bind to 10.1.1.1 address, but the instance does NOT have such
address bound to any of its' interfaces, and that's okay, because I have
such configuration:
    lo: 127.0.0.1/8
    eh0: 169.254.1.72/16
    eth1: 172.24.64.250/24
    eth2: x.x.x.x/24

But in httpd's configuration I can see lots of mentions of 10.1.1.1:
    /etc/apache2/ports.conf:NameVirtualHost 10.1.1.1:80
    /etc/apache2/ports.conf:Listen 10.1.1.1:80
    /etc/apache2/ports.conf:    Listen 10.1.1.1:443
    /etc/apache2/ports.conf:    Listen 10.1.1.1:443
    /etc/apache2/sites-available/default.orig:<VirtualHost 10.1.1.1:80>
    /etc/apache2/sites-available/default-ssl.orig:<VirtualHost 10.1.1.1:443>
    /etc/apache2/sites-available/default:<VirtualHost 10.1.1.1:80>
    /etc/apache2/sites-available/default-ssl:<VirtualHost 10.1.1.1:443>
    /etc/apache2/vhostexample.conf:<VirtualHost 10.1.1.1:80>
    /etc/apache2/vhostexample.conf:<VirtualHost 10.1.1.1:443>
    /etc/apache2/vhostexample.conf:Listen 10.1.1.1:80
    /etc/apache2/vhostexample.conf:    Listen 10.1.1.1:443
    /etc/apache2/vhostexample.conf:    Listen 10.1.1.1:443

Where does it take 10.1.1.1? As I understand, CloudStack should have change
it while deploying this VM, but it hasn't. :(

Of course, I tried to delete and create console proxy VM, but it doesn't
help.

Where is the glitch?

Thank you!

-- 
With best regards, wishes and so on,
Vladimir Melnik :)


Mime
View raw message