cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjeev Neelarapu <sanjeev.neelar...@citrix.com>
Subject RE: problem converting a snapshoot to a template
Date Thu, 09 Jan 2014 05:13:30 GMT
Hi,

Is your environment installed freshly with 4.2.0 or you uninstalled previous version of CS
(say 3.x) and installed 4.2 on that?
If yes please remove all the directories with name cloud and try again?
This worked well for us in 4.2

Thanks,
Sanjeev

-----Original Message-----
From: Hollman Enciso R. [mailto:hollman.enciso@gmail.com] 
Sent: Thursday, January 09, 2014 2:56 AM
To: users@cloudstack.apache.org
Subject: problem converting a snapshoot to a template

Hello, i have a volume and to this volume i tooke a snapshoot. then i try to conver the snapshoot
in to a template. But i have the following problem.

the UI show me the following error:

Failed to create template
/usr/local/cloud/systemvm/scripts/storage/secondary/create_privatetemplate_from_snapshot_xen.sh:
line 65: /bin/vhd-util: Permission denied30#failed to query /mnt/SecStorage/df01c799-874e-3ee6-9372-ca4d582be42e/snapshots/2/9/4c3ea37b-4d69-4471-9b71-26575a973145.vhd


i tried to read this file but this file doesn't exist on this path. i search the file and
it's located on:
/usr/share/cloudstack-common/scripts/storage/secondary/create_privatetemplate_from_snapshot_xen.sh

so i made a symbolink link from
/usr/share/cloudstack-common/scripts to
/usr/local/cloud/systemvm/
 This it's a bug or something wrong on my installation? - i have CS 4.2.0

And the second part of the error it's: failed to query
/mnt/SecStorage/df01c799-874e-3ee6-9372-ca4d582be42e/snapshots/2/9/4c3ea37b-4d69-4471-9b71-26575a973145.vhd:

this path not exist on my CS management, but i searched this file on my secondary stoarge
that it's a second server ith nfs i can located:

[root@nfs mnt]# find / -name 4c3ea37b-4d69-4471-9b71-26575a973145.vhd
/secondary/snapshots/2/9/4c3ea37b-4d69-4471-9b71-26575a973145.vhd

maybe the problem it's that on the management it's not mounted the nfs server ?
it's extrage becouse i have my secondary storage OK and working uploading isos, and snapshoots
of instances


some idea ?

PD: this it's the log http://paste.algolibre.com/108



--
Hollman Eduardo Enciso R.
http://nexxuz.com
http://algolibre.com <http://www.hollmanenciso.com/> @hollman
Mime
View raw message