cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dag Sonstebo <...@sonstebo.co.uk>
Subject Re: Cloudstack 4.2.1 / Xenserver 6.1 GRE tunnelling / createTunnelNetwork failed
Date Fri, 17 Jan 2014 00:05:09 GMT
Hi Tuna,

Thanks for your feedback. I’ve just built the RPMs from source (apache-cloudstack-4.2.1-src.tar.bz2),
unfortunately I still get the same error:

2014-01-16 23:52:01,442 WARN  [xen.resource.CitrixResourceBase] (DirectAgent-13:null) createTunnelNetwork
failed

Should your updated GRE modules have come down with the source files or do I have to do a
full git pull to get this?

Regards,
Dag

On 15 Jan 2014, at 03:50, Nguyen Anh Tu <tuna@apache.org> wrote:

> Hi Dag,
> 
> I updated GRE modules to make it work fine with XenServer and XCP during
> the summer. It now appears on master branch. Maybe it will added to future
> releases.
> 
> Will looking into your issue to find out the problem.
> 
> Thanks,
> 
> --Tuna
> 
> Sent from my GT-N7000
> On Jan 15, 2014 5:53 AM, "Dag Sonstebo" <dag@sonstebo.co.uk> wrote:
> 
>> Hi,
>> 
>> I’ve spent a fair bit of lab time trying to get GRE tunnelling working in
>> CloudStack 4.2.1 / Xenserver 6.1 but have had no luck so far.
>> 
>> As per various posts, documents and wiki articles I’ve got:
>> 
>> - Xenserver 6.1 cluster with all patches, CloudStack 4.2.1 installed from
>> RPMs (CentOS 6.5).
>> - Advanced zone configuration (no security groups).
>> - Public and management networks configured with VLAN isolation (bonds).
>> - sdn.ovs.controller set to “true", sdn.ovs.controller.default.label set
>> to network label of the guest network.
>> - Guest network traffic configured for GRE,  IP interfaces configured on
>> the guest network and “VLAN range” configured.
>> 
>> The problem is tunnels won’t come up, tagged networks are created but no
>> GRE tunnels are created between XS hosts. Whilst the SSVM and CP come
>> online the domain router and the first VM fail to start.
>> Checking the management server logs the root cause seems to point to a
>> “createTunnelNetwork failed” error.
>> 
>> Doing a bit more digging I found the following bug logged back in
>> September:
>> 
>> https://issues.apache.org/jira/browse/CLOUDSTACK-4599
>> 
>> 1) Considering the bug above was logged for CS4.1 - is GRE under active
>> development as per 4.2.1/4.3? Is it considered to be a working component of
>> CloudStack?
>> 2) Has anyone managed to get GRE tunnelling working - if so are there any
>> patches / workarounds / specific component versions required?
>> 
>> Regards,
>> Dag
>> 
>> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message