cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "e.angieri@libero.it" <e.angi...@libero.it>
Subject agent can't start
Date Mon, 27 Jan 2014 15:35:58 GMT
Hi to all.I'm trying to install cloudstack 4.1 on Ubuntu 12.04 LTS. I have service-management
and agent on the same computer.The network works fine, my configuration was:
(/etc/network/interfaces):
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

# Public network
auto cloudbr0
iface cloudbr0 inet static
    address 10.0.0.50
    netmask 255.255.0.0
    gateway 10.0.0.1
    dns-nameservers 10.0.0.1
    bridge_ports eth0
    bridge_fd 5
    bridge_stp off
    bridge_maxwait 1

# Private network
auto cloudbr1
iface cloudbr1 inet manual
    bridge_ports none
    bridge_fd 5
    bridge_stp off
    bridge_maxwait 1
The management server works fine instead the agent do not start.The agent-setup was:cloudstack-setup-agent

Welcome to the CloudStack Agent Setup:
Please input the Management Server Hostname/IP-Address:[localhost]
Please input the Zone Id:[default]
Please input the Pod Id:[default]
Please input the Cluster Id:[default]
Please choose which network used to create VM:[cloudbr0]
Starting to configure your system:
Configure Apparmor ...        [OK]
Configure Network ...         [OK]
Configure Libvirt ...         [OK]
Configure Firewall ...        [OK]
Configure Nfs ...             [OK]
Configure cloudAgent ...      [OK]
CloudStack Agent setup is done!


If I run:
service cloudstack-agent start
 * Starting CloudStack Agent cloud-agent                                 [ OK ] 

root@emi-pc:/home/emi# service cloudstack-agent status
 * cloud-agent is not running
the agent log say:
2014-01-27 16:34:46,659 INFO  [cloud.agent.AgentShell] (main:null) Agent started
2014-01-27 16:34:46,660 INFO  [cloud.agent.AgentShell] (main:null) Implementation Version
is 4.1.1
2014-01-27 16:34:46,661 INFO  [cloud.agent.AgentShell] (main:null) agent.properties found
at /etc/cloudstack/agent/agent.properties
2014-01-27 16:34:46,662 INFO  [cloud.agent.AgentShell] (main:null) Defaulting to using properties
file for storage
2014-01-27 16:34:46,663 INFO  [cloud.agent.AgentShell] (main:null) Defaulting to the constant
time backoff algorithm
2014-01-27 16:34:46,710 INFO  [cloud.agent.Agent] (main:null) id is 0
2014-01-27 16:34:46,721 INFO  [resource.virtualnetwork.VirtualRoutingResource] (main:null)
VirtualRoutingResource _scriptDir to use: scripts/network/domr/kvm
2014-01-27 16:34:47,194 INFO  [kvm.resource.LibvirtComputingResource] (main:null) No libvirt.vif.driver
specififed. Defaults to BridgeVifDriver.
2014-01-27 16:34:47,214 INFO  [cloud.agent.Agent] (main:null) Agent [id = 0 : type = LibvirtComputingResource
: zone = default : pod = default : workers = 5 : host = localhost : port = 8250
2014-01-27 16:34:47,227 INFO  [utils.nio.NioClient] (Agent-Selector:null) Connecting to localhost:8250
2014-01-27 16:34:47,406 INFO  [utils.nio.NioClient] (Agent-Selector:null) SSL: Handshake done
2014-01-27 16:34:47,661 INFO  [cloud.serializer.GsonHelper] (Agent-Handler-1:null) Default
Builder inited.
2014-01-27 16:34:47,732 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Proccess agent startup
answer, agent id = 0
2014-01-27 16:34:47,732 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Set agent id 0
2014-01-27 16:34:47,736 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Startup Response
Received: agent id = 0
2014-01-27 16:34:47,737 INFO  [cloud.agent.Agent] (AgentShutdownThread:null) Stopping the
agent: Reason = sig.kill

Can you help me please??
Best regardsEmiliano

 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message