cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Higginbottom <geoff.higginbot...@shapeblue.com>
Subject RE: Initial setup admin password not working
Date Mon, 09 Dec 2013 19:06:29 GMT
After deploying the DBs, rebooting, and then launching the UI, it can take a couple of minutes
before the login will be successful.  Have you given it enough time to fully initialise?

A good tip is to run the following when starting the management service

tail -f /var/log/cloudstack/management/management-server.log | grep success

When you see the message 'Cluster manager was started successfully' you should be able to
login, but not before.

Regards

Geoff Higginbottom

D: +44 20 3603 0542 | S: +44 20 3603 0540 | M: +447968161581

geoff.higginbottom@shapeblue.com

-----Original Message-----
From: Daniel Wittenberg [mailto:dwittenberg2008@gmail.com]
Sent: 09 December 2013 18:41
To: users@cloudstack.apache.org
Subject: Re: Initial setup admin password not working

I couldn't remember exactly when I changed it, so I just dropped the cloud, cloud_usage and
cloudbridge databases, restarted mysql, re-ran the cloudstack-setup-databases script, restarted
everything again, and same error.  Should that have done it?

Dan


On Dec 9, 2013, at 12:29 PM, Geoff Higginbottom <geoff.higginbottom@shapeblue.com> wrote:

> Dan, did you bump the ram to > 2GB before or after your first login attempt?
>
> The reason I ask is its the database deploy/upgrade process that runs the first time
you try and login which needs the RAM, if you did not have sufficient RAM is would have failed
and the databases would not have been deployed correctly.
>
> If you need to start again, just drop the DB schema and then re-deploy the database.
>
> Regards
>
> Geoff Higginbottom
>
> D: +44 20 3603 0542 | S: +44 20 3603 0540 | M: +447968161581
>
> geoff.higginbottom@shapeblue.com
>
> -----Original Message-----
> From: Daniel Wittenberg [mailto:dwittenberg2008@gmail.com]
> Sent: 09 December 2013 18:17
> To: users@cloudstack.apache.org
> Subject: Initial setup admin password not working
>
> So I've done the install twice thinking I did something wrong the first time, but twice
in a row now when I do a fresh install I get the error about the password being incorrect.
>
> WARN  [server.auth.SHA256SaltedUserAuthenticator] (catalina-exec-1:) The stored password
for admin isn't in the right format for this authenticator INFO  [cloud.user.AccountManagerImpl]
(catalina-exec-1:) User admin is disabled/locked
>
> I read one post that said it had to do with < 2GB of RAM in their case, so I bumped
mine from 1 to 4GB and that didn't help, I've tried resetting the password from instructions
I found about updating the user and user_view tables, but so far no luck.  So something seems
wrong with the initial out-of-the-box setup, but not sure where else to look.
>
> Ideas?
>
> Dan
>
>
> This email and any attachments to it may be confidential and are intended solely for
the use of the individual to whom it is addressed. Any views or opinions expressed are solely
those of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is a company incorporated in India and is operated
under license from Shape Blue Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated
in Brasil and is operated under license from Shape Blue Ltd. ShapeBlue is a registered trademark.

This email and any attachments to it may be confidential and are intended solely for the use
of the individual to whom it is addressed. Any views or opinions expressed are solely those
of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is a company incorporated in India and is operated
under license from Shape Blue Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated
in Brasil and is operated under license from Shape Blue Ltd. ShapeBlue is a registered trademark.

Mime
View raw message