cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Kimlaychuk <Vadim.Kimlayc...@Elion.ee>
Subject RE: CS 4.2 : installation/running usage server problem
Date Thu, 12 Dec 2013 07:44:14 GMT
Hi Tariq,



                1. Usage server is running(maybe?). I got:

                               root@mgmtweb1:~# service cloudstack-usage status

                               * cloudstack-usage is running

                2. Management log shows:

                                2013-12-12 00:04:35,092 INFO  [cloud.ha.HighAvailabilityManagerImpl]
(HA-1:null)  checking health of usage server

2013-12-12 00:04:35,096 DEBUG [cloud.ha.HighAvailabilityManagerImpl] (HA-1:null) usage server
running? false, heartbeat: null

2013-12-12 00:04:35,096 WARN  [apache.cloudstack.alerts] (HA-1:null)  alertType:

: 13 // dataCenterId:: 0 // podId:: 0 // clusterId:: null // message:: No usage server process
running



                I have tried to find process or port, but don’t know which port usage server
should be listening to. Here are all of them I have:

root@mgmtweb1:~# netstat -antp | grep jsvc.

tcp6       0      0 :::8250                 :::*                    LISTEN      24028/jsvc.exec

tcp6       0      0 :::41020                :::*                    LISTEN      24028/jsvc.exec

tcp6       0      0 :::55134                :::*                    LISTEN      24028/jsvc.exec

tcp6       0      0 :::9090                 :::*                    LISTEN      24028/jsvc.exec

tcp6       0      0 :::45219                :::*                    LISTEN      24028/jsvc.exec

tcp6       0      0 :::7080                 :::*                    LISTEN      24028/jsvc.exec

tcp6       0      0 :::20400                :::*                    LISTEN      24028/jsvc.exec

tcp6       0      0 :::8080                 :::*                    LISTEN      24028/jsvc.exec

tcp6       0      0 :::52881                :::*                    LISTEN      24028/jsvc.exec



Vadim.



-----Original Message-----
From: Tariq Iqbal [mailto:tariq.iqbal@shapeblue.com]
Sent: Wednesday, December 11, 2013 10:32 PM
To: users@cloudstack.apache.org
Subject: RE: CS 4.2 : installation/running usage server problem



Hi Vadim,



Can you check the usage service is actually running with 'service cloudstack-usage status'



Have you checked the management log for 'usage' related messages and are you able to post
the log?



Best Regards,



Tariq Iqbal



S: +44 20 3603 0540 | M: +447909911600



tariq.iqbal@shapeblue.com<mailto:tariq.iqbal@shapeblue.com> | Twitter: @TariqIqbal_



-----Original Message-----

From: Vadim Kimlaychuk [mailto:Vadim.Kimlaychuk@Elion.ee]

Sent: 11 December 2013 10:43

To: users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>

Subject: CS 4.2 : installation/running usage server problem



Hi all,



            I am a bit confused by installation instruction for usage server taken from here:

            http://cloudstack.apache.org/docs/en-US/Apache_CloudStack/4.2.0/html/Installation_Guide/install-usage-server.html



            I have my management server installed on Ubuntu and I have no idea what ./install.sh
script does this guide refer for?



            I made my usage installation by executing task like this:

            # apt-get install cloudstack-usage



Everything went well and at the end I was able to start usage server by executing “service
cloudstack-usage”. Nevertheless usage server is not working! Table usage_job is empty. And
management server can’t find usage process.

I have found only 2 files to configure usage residing in /etc/cloudstack/usage:



1.    db.properties



2.    log4j-cloud_usage.xml



Database settings I have checked manually and was able to log-in to database. I am stuck now
– can’t get the point where to find error? Usage server process does not seem to log anything
: folder /var/log/cloudstack/usage is empty.



Please, help.



Vadim Kimlaychuk



This email and any attachments to it may be confidential and are intended solely for the use
of the individual to whom it is addressed. Any views or opinions expressed are solely those
of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is a company incorporated in India and is operated
under license from Shape Blue Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated
in Brasil and is operated under license from Shape Blue Ltd. ShapeBlue is a registered trademark.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message