cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Harvey <ahar...@enmasse.com>
Subject RE: xenserver 6.2 added to pool
Date Thu, 05 Dec 2013 05:43:27 GMT
If it were only that way with these for me. They're completely stock I am at a loss of why
this is occurring.

-----Original Message-----
From: Shanker Balan [mailto:shanker.balan@shapeblue.com] 
Sent: Wednesday, December 04, 2013 8:05 PM
To: CloudStack-Users
Subject: Re: xenserver 6.2 added to pool

On 05-Dec-2013, at 4:47 am, Adam Harvey <aharvey@enmasse.com> wrote:

> 2013-12-04 23:13:44,097 DEBUG [utils.script.Script] 
> (DirectAgent-119:null) Looking for 
> scripts/vm/hypervisor/xenserver/xenserver60/patch in the classpath
> 2013-12-04 23:13:44,097 DEBUG [utils.script.Script] 
> (DirectAgent-119:null) System resource: null
> 2013-12-04 23:13:44,097 DEBUG [utils.script.Script] 
> (DirectAgent-119:null) Classpath resource: 
> file:/usr/share/cloudstack-management/webapps/client/WEB-INF/classes/s
> cripts/vm/hypervisor/xenserver/xenserver60/patch
> 2013-12-04 23:13:44,098 DEBUG [utils.script.Script] 
> (DirectAgent-119:null) Absolute path =  
> /usr/share/cloudstack-management/webapps/client/WEB-INF/classes/script
> s/vm/hypervisor/xenserver/xenserver60/patch
> 2013-12-04 23:13:44,098 DEBUG [xen.resource.CitrixResourceBase] 
> (DirectAgent-119:null) Copying 
> /usr/share/cloudstack-management/webapps/client/WEB-INF/classes/script
> s/vm/hypervisor/xenserver/xenserver60/../cloudstack_pluginlib.py to 
> /etc /xapi.d/plugins on *removed* with permission 0755
> 2013-12-04 23:13:44,163 DEBUG [xen.resource.CitrixResourceBase] 
> (DirectAgent-119:null) Copying 
> /usr/share/cloudstack-management/webapps/client/WEB-INF/classes/script
> s/vm/hypervisor/xenserver/xenserver60/../vmopsSnapshot to 
> /etc/xapi.d/pl ugins on *removed* with permission 0755
> 2013-12-04 23:13:44,164 DEBUG [xen.resource.CitrixResourceBase] 
> (DirectAgent-119:null) Unable to create destination path: 
> /etc/xapi.d/plugins on *removed* but trying anyway
> 2013-12-04 23:13:44,245 DEBUG [xen.resource.CitrixResourceBase] 
> (DirectAgent-119:null) Copying 
> /usr/share/cloudstack-management/webapps/client/WEB-INF/classes/script
> s/vm/hypervisor/xenserver/xenserver60/../ovs-vif-flows.py to 
> /etc/xapi.d /plugins on *removed* with permission 0755
> 2013-12-04 23:13:44,245 DEBUG [xen.resource.CitrixResourceBase] 
> (DirectAgent-119:null) Unable to create destination path: 
> /etc/xapi.d/plugins on *removed* but trying anyway
> 2013-12-04 23:13:44,327 DEBUG [xen.resource.CitrixResourceBase] 
> (DirectAgent-119:null) Copying 
> /usr/share/cloudstack-management/webapps/client/WEB-INF/classes/script
> s/vm/hypervisor/xenserver/xenserver60/../cloud-setup-bonding.sh to 
> /opt/ xensource/bin on *removed* with permission 0755
>
> This occurring w/anyone else?  Running CS 4.2 with xenserver 6.2 I've 
> verified vhd-util is the proper one recommended in the documentation and I have it placed
in:

The only place I put vhd-util is under /usr/share/cloudstack-common/scripts/vm/hypervisor/xenserver/
ON the management server before adding the XenServer hosts to ACS. See below ansible recipe.

- name: Copy vhd-util
  action: copy src=vhd-util dest=/usr/share/cloudstack-common/scripts/vm/hypervisor/xenserver/vhd-util
mode=0755
  tags: cloudstack

The management server then does:

[root@csman1-1 ~]# grep vhd-util /var/log/cloudstack/management/management-server.log
2013-12-05 00:01:02,612 DEBUG [xen.resource.CitrixResourceBase] (DirectAgent-1:null) Copying
/usr/share/cloudstack-common/scripts/vm/hypervisor/xenserver/xenserver60/../vhd-util to /opt/xensource/bin
on 192.168.44.23 with permission 0755
2013-12-05 00:01:12,294 DEBUG [xen.resource.CitrixResourceBase] (DirectAgent-9:null) Copying
/usr/share/cloudstack-common/scripts/vm/hypervisor/xenserver/xenserver60/../vhd-util to /opt/xensource/bin
on 192.168.44.24 with permission 0755


> /usr/share/cloudstack-common/scripts/vm/hypervisor/xenserver/vhd-util
> /usr/share/cloudstack-common/scripts/vm/hypervisor/xenserver/xenserver
> 60/vhd-util 
> /usr/share/cloudstack-management/webapps/client/WEB-INF/classes/script
> s/vm/hypervisor/xenserver/xenserver60/vhd-util

Been adding and removing XenServer 6.2 clusters all day yesterday on stock ACS 4.2.0 without
issues.

Regards.

--
@shankerbalan

M: +91 98860 60539 | O: +91 (80) 67935867 shanker.balan@shapeblue.com | www.shapeblue.com
| Twitter:@shapeblue ShapeBlue Services India LLP, 22nd floor, Unit 2201A, World Trade Centre,
Bangalore - 560 055

This email and any attachments to it may be confidential and are intended solely for the use
of the individual to whom it is addressed. Any views or opinions expressed are solely those
of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is a company incorporated in India and is operated
under license from Shape Blue Ltd. Shape Blue Brasil Consultoria Ltda is a company incorporated
in Brasil and is operated under license from Shape Blue Ltd. ShapeBlue is a registered trademark.

Mime
View raw message