cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Reategui <car...@reategui.com>
Subject Re: How to re-connect hosts
Date Thu, 07 Nov 2013 21:18:41 GMT
I am using XenServer hosts.  The cloudstack-agent is for KVM hosts.


On Thu, Nov 7, 2013 at 1:16 PM, Carlos Miranda Molina (Mstaaravin) <
mstaaravin@gmail.com> wrote:

> A simple question...
>
> Do you upgrade cloudstack on hosts servers...?
>
>
> On Thu, Nov 7, 2013 at 6:10 PM, Carlos Reategui <carlos@reategui.com>
> wrote:
>
> > I think you meant management-server.log.
> >
> > Here is an exerp that I think shows the problem:
> > 2013-11-07 11:58:10,828 DEBUG [host.dao.HostDaoImpl]
> (ClusteredAgentManager
> > Timer:null) Resetting hosts suitable for reconnect
> > 2013-11-07 11:58:10,833 DEBUG [host.dao.HostDaoImpl]
> (ClusteredAgentManager
> > Timer:null) Completed resetting hosts suitable for reconnect
> > 2013-11-07 11:58:10,833 DEBUG [host.dao.HostDaoImpl]
> (ClusteredAgentManager
> > Timer:null) Acquiring hosts for clusters already owned by this management
> > server
> > 2013-11-07 11:58:10,834 DEBUG [host.dao.HostDaoImpl]
> (ClusteredAgentManager
> > Timer:null) Completed acquiring hosts for clusters already owned by this
> > management server
> > 2013-11-07 11:58:10,835 DEBUG [host.dao.HostDaoImpl]
> (ClusteredAgentManager
> > Timer:null) Acquiring hosts for clusters not owned by any management
> server
> > 2013-11-07 11:58:10,845 DEBUG [host.dao.HostDaoImpl]
> (ClusteredAgentManager
> > Timer:null) Completed acquiring hosts for clusters not owned by any
> > management server
> > 2013-11-07 11:58:10,851 DEBUG [agent.manager.ClusteredAgentManagerImpl]
> > (ClusteredAgentManager Timer:null) Found 2 unmanaged direct hosts,
> > processing connect for them...
> > 2013-11-07 11:58:10,852 DEBUG [agent.manager.ClusteredAgentManagerImpl]
> > (ClusteredAgentManager Timer:null) Loading directly connected host
> > 1(srvengxen01)
> > 2013-11-07 11:58:13,461 DEBUG [xen.resource.XenServerConnectionPool]
> > (ClusteredAgentManager Timer:null) Failed to slave local login to
> > 172.30.45.31
> > 2013-11-07 11:58:13,461 WARN  [cloud.resource.DiscovererBase]
> > (ClusteredAgentManager Timer:null) Unable to configure resource due to
> Can
> > not create slave connection to 172.30.45.31
> > 2013-11-07 11:58:13,463 WARN  [agent.manager.AgentManagerImpl]
> > (ClusteredAgentManager Timer:null) Unable to load the resource: 1
> > 2013-11-07 11:58:13,463 DEBUG [cloud.host.Status] (ClusteredAgentManager
> > Timer:null) Transition:[Resource state = Enabled, Agent event =
> > AgentDisconnected, Host id = 1, name = srvengxen01]
> > 2013-11-07 11:58:13,474 DEBUG [cloud.host.Status] (ClusteredAgentManager
> > Timer:null) Agent status update: [id = 1; name = srvengxen01; old status
> =
> > Disconnected; event = AgentDisconnected; new status = Disconnected; old
> > update count = 608; new update count = 609]
> > 2013-11-07 11:58:13,474 DEBUG [agent.manager.ClusteredAgentManagerImpl]
> > (ClusteredAgentManager Timer:null) Loading directly connected host
> > 2(srvengxen02)
> > 2013-11-07 11:58:15,190 DEBUG [xen.resource.XenServerConnectionPool]
> > (ClusteredAgentManager Timer:null) Failed to slave local login to
> > 172.30.45.32
> > 2013-11-07 11:58:15,190 WARN  [cloud.resource.DiscovererBase]
> > (ClusteredAgentManager Timer:null) Unable to configure resource due to
> Can
> > not create slave connection to 172.30.45.32
> > 2013-11-07 11:58:15,190 WARN  [agent.manager.AgentManagerImpl]
> > (ClusteredAgentManager Timer:null) Unable to load the resource: 2
> > 2013-11-07 11:58:15,191 DEBUG [cloud.host.Status] (ClusteredAgentManager
> > Timer:null) Transition:[Resource state = Enabled, Agent event =
> > AgentDisconnected, Host id = 2, name = srvengxen02]
> > 2013-11-07 11:58:15,200 DEBUG [cloud.host.Status] (ClusteredAgentManager
> > Timer:null) Agent status update: [id = 2; name = srvengxen02; old status
> =
> > Disconnected; event = AgentDisconnected; new status = Disconnected; old
> > update count = 608; new update count = 609]
> > 2013-11-07 11:58:15,859 DEBUG [network.lb.LBHealthCheckManagerImpl]
> > (LBHealthCheck-1:null) LB HealthCheck Manager is running and getting the
> > updates from LB providers and updating service status
> > 2013-11-07 11:58:15,875 DEBUG [network.lb.LBHealthCheckManagerImpl]
> > (LBHealthCheck-1:null) LB HealthCheck Manager is running and getting the
> > updates from LB providers and updating service status
> >
> >
> > There is a copy of my logs from an early start/stop with this same
> problem
> > here: http://reategui.com/cloudstack/management-server.2013-11-06.log
> >
> >
> >
> >
> > On Thu, Nov 7, 2013 at 12:32 PM, Carlos Miranda Molina (Mstaaravin) <
> > mstaaravin@gmail.com> wrote:
> >
> > > On Thu, Nov 7, 2013 at 5:09 PM, Carlos Reategui <creategui@gmail.com>
> > > wrote:
> > >
> > > > After the update from 4.1.1 to 4.2, both my XenServer 6.0.2 hosts
> show
> > a
> > > > state of "Disconnected".  How do I re-connect them? The only 3
> options
> > I
> > > > see in the UI are: "Dedicate Host", "Enable Maintenance Mode" and
> > "Remove
> > > > Host".
> > > >
> > >
> > > What do you see in logs...?
> > >
> > > /var/log/cloudstack/management/catalina.out
> > >
> > > regards.
> > >
> > > --
> > > "La Voluntad es el Ășnico motor de nuestros logros"
> > > http://blog.ngen.com.ar/
> > >
> >
>
>
>
> --
> "La Voluntad es el Ășnico motor de nuestros logros"
> http://blog.ngen.com.ar/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message