cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjeev Neelarapu <sanjeev.neelar...@citrix.com>
Subject RE: Multiple Public IP ranges
Date Tue, 01 Oct 2013 05:19:43 GMT
Hi Travis,

This is just a restriction from the CS side. There is no technical reason for not supporting
it. As I said earlier this may be supported in future versions of CS.

Thanks,
Sanjeev

-----Original Message-----
From: Travis Graham [mailto:tgraham@tgraham.us] 
Sent: Wednesday, September 25, 2013 5:34 PM
To: users@cloudstack.apache.org
Subject: Re: Multiple Public IP ranges

Hello Sanjeev,

>From a networking perspective I'm not sure why that's even an issue. By default all things
in a network are VLAN 1, so by having different subnets in an untagged VLAN is logically the
same as having everything in VLAN 1. Why would that be problematic for CS? It's the same collision
domain and a very typical network setup.

Perhaps you can explain how large installs handle multiple subnets efficiently? Or how CS
uses the VLAN ID for each subnet in relation to the physical network.

It sounds to me like I can't add multiple CIDRs without making changes to our switching gear
to allow traffic to pass into our existing network. Does that sound on par with normal large
installs?

Thanks,
Travis

On Sep 25, 2013, at 1:55 AM, Sanjeev Neelarapu <sanjeev.neelarapu@citrix.com> wrote:

> Hi Travis,
> 
> We don't support multiple subnets in the same vlan for public IP ranges. Since all the
subnets you are using are untagged,  all the CIDRs will be treated as part of same vlan and
CS throws error when you try to add multiple subnets.
> 
> This feature may be supported in future versions of CS. 
> 
> Thanks,
> Sanjeev
> 
> -----Original Message-----
> From: Travis Graham [mailto:tgraham@tgraham.us] 
> Sent: Tuesday, September 24, 2013 8:48 PM
> To: users@cloudstack.apache.org
> Subject: Multiple Public IP ranges
> 
> I have a testing CloudStack install setup with 4.1.1 running on CentOS 6.4 for both Management
and KVM compute hosts.
> 
> I'm trying to add additional public IP ranges to a zone that uses Advanced Networking
and I keep getting errors.
> 
> My first range is a subset of an existing /24 we have that provides 10 IPs for testing.
This range has an unset VLAN so that it defaults to "untagged" which is how our physical network
is setup, no tagging at the port level.
> 
> When I try to add an additional range from another /24 we have I get this error:
> 
> "The Untagged ip range with different subnet already exists in zone 2"
> 
> I can add an additional range of IPs within the first /24 without any problems.
> 
> Is there some reason we can't add multiple IP ranges from different subnets that are
untagged?
> 
> 
> Thanks,
> Travis
> 
> 


Mime
View raw message