cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Murugappan, Vairavan" <vmurugap...@miners.utep.edu>
Subject Network Setup Problem 4.1.1
Date Tue, 22 Oct 2013 18:28:23 GMT
Hi,
I am trying to setup a basic cloudstack 4.1.1 installation (test setup) with
1 Management (mgmt) server (centos 6.4), 1 host machine(cents 6.4) and 1 dell6248 switch

Mgmt has 2 NIC's
            * One connected to the internet
            * Another with local ip 20.1.1.1 (which acts a gateway) net mask 255.0.0.0
                        * I have added NAT rules to forward internet to rest of the network
                        * And this runs a dns server
                        * Also this hosts the Mysql and NFS (/export/primary, /export/secondary)
                        * But No dhcp server
            * I followed the instructions in the document and the management server is running
and I can access it through browser

DELL6248 Switch
            * I assigned ip as 20.2.1.1 netmask 255.0.0.0 gateway 20.1.1.1
            * No Vlan configured, left it at default config

Host Machine has 1 NIC
            * It is connected to the Switch
            * I followed the steps in the document (installation for KVM) for creating bridges
            * I Assigned ip 20.1.1.2 to the vlan em1.100 [ Netmask 255.0.0.0 Gateway 20.1.1.1
] (em is my eth) and no ip on em1, Amd configured 2 bridges as said.
-> But, With this setup the host machine cannot even ping the switch and mgmt server.
-> I tried assigning the 192.*.*.* ip to em1.100 with the ip at virbr0(192.*.*.1) as gateway
but same result cannot ping the switch or mgmt..
* So removed all vlan's and bridges and just set 20.1.1.2 to em1 [ Netmask 255.0.0.0 Gateway
20.1.1.1]. Now it works as expected and I can access the internet as well.

Setup:

*         I proceeded with the basic installation

*         Pod - Gateway:20.1.1.1, Netmask:255.0.0.0, iprange - 20.1.1.5 -> 20.1.1.20

*         Guest - Gateway:20.1.1.1, Netmask:255.0.0.0, iprange - 20.1.1.30 -> 20.1.1.200

*         The Zone gets added successfully. No error on that.

It creates cloubr0 bridge  on host by itself and moves the ip from em1 to cloudbr0 and also
starts the SSVM and Console VM on the host machine. But I get this "There is no secondary
storage VM for secondary storage host nfs://20.1.1.1/export/secondary"
On the management server log.

SSVM Guest Machine

*         I can log into the SSVM from host using iplink local and I ran the SSVM test script,
it seems it cannot connect to the gateway (20.1.1.1).

*         Following are the ip assigned to SSVM

o    Public - 20.1.1.30 (eth2) , Private - 20.1.111 (eth1) , Link Local - 169.254.2.151 (eth0)
,

o    And on eth3 20.1.1.20 (Not sure what this is for)

Problems:

*         SSVM cannot access switch or gateway server (mgmt,nfs,mysql) or internet

*         And I cannot add any iso's or the cannot see the system default iso on the add instance
screen.

So there's something wrong in my network configuration over here but I couldn't figure out
what it is. So any help on this would be much appreciated.

Regards,
Vairavan M.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message