cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chirag Choudhary <chirag200...@gmail.com>
Subject Re: System VMs not starting
Date Thu, 10 Oct 2013 11:12:40 GMT
Hi,

        thanks @Hiroki
with the new iso both of my systems VMs are up.
But i am facing another problem while adding new Templates and ISO images,
The templated are added in the UI and shows template registered but in a few
seconds after refreshing the UI they are gone, only system temoplate
remains. I checked the secondary storage, cloudstack is creating new
folders and template.properties files but no qcow/iso image and the
properties files are all empty.


here are logs while adding ubuntu 12.04 iso to the template iso
2013-10-10 16:33:13,761 DEBUG [agent.transport.Request]
(AgentManager-Handler-13:null) Seq 3-2022179871: Processing:  { Ans: ,
MgmtId: 181122461670954, via: 3, Ver: v1, Flags: 10,
[{"com.cloud.agent.api.storage.DownloadAnswer":{"jobId":"830812cb-abc1-44ae-a0c4-c1f1ddf9ed24","downloadPct":0,"errorString":"Connection
refused","downloadStatus":"DOWNLOAD_ERROR","downloadPath":"/mnt/SecStorage/870569f8-ac26-35e0-bc9a-6728912ae642/template/tmpl/2/207/dnld6540943554975655823tmp_","installPath":"template/tmpl/2/207","templateSize":0,"templatePhySicalSize":0,"result":true,"details":"Connection
refused","wait":0}}] }
http://pastebin.centos.org/4911/

Who is refusing connection and from whom ?

yet more logs
http://pastebin.centos.org/4906/


Thanks & Regards


On Wed, Oct 9, 2013 at 6:54 PM, Hiroki Ohashi <silvernshell@gmail.com>wrote:

> Hi Chirg
>
> It seems that old System VM template cause this error.
> System VM template is updated at version 4.2.0, so old System VM
> template is useless.
> You have to download new System VM template.
> However, wrong urls are written in installation guide of 4.2.0
> and there's no notice in release notes of 4.2.0 "3.1. Upgrade from
> 4.1.x to 4.2.0".
> Correct ones are below.
>
> Xenserver:
>
> http://download.cloud.com/templates/4.2/systemvmtemplate-2013-07-12-master-xen.vhd.bz2
> KVM:
>
> http://download.cloud.com/templates/4.2/systemvmtemplate-2013-06-12-master-kvm.qcow2.bz2
> VMware:
>   http://download.cloud.com/templates/4.2/systemvmtemplate-4.2-vh7.ova
>
> At least, Sysmte VM template for KVM works fine.
>
> best regards
>
> 2013/10/9 Chirag Choudhary <chirag200666@gmail.com>:
> > Hi,
> >     I create a new zone, pod, cluster and added a KVM(RHEL 6.4) host ,
> But
> > the two System VMs are not coming up, throwing the error :
> >
> >    1. com.cloud.exception.AgentUnavailableException: Resource [Host:3] is
> >    unreachable: Host 3: Unable to start instance due to Unable to start
> >    VM[SecondaryStorageVm|s-102-VM] due to error in finalizeStart, not
> retrying
> >
> >
> > I tried to login in the VMs but not able to , I used nmap to scan for IPs
> > of VMs there was no host up with the IP assigned by cloudstack, neither
> the
> > local 169.254.*.* nor the internal and external IPs.
> >
> > detailed logs:
> > Management Server logs
> > from: /var/log/cloudstack/management/management-server.log
> > http://pastebin.com/aXjazPb3
> >
> > KVM host logs from: /var/log/cloudstack/agent/agent.log
> > http://pastebin.com/WzYveDpi
> >
> > How to fix this issue ?
> >
> > Thanks & Regards,
> > --
> > Chirag Choudhary,
> > Software Engineer
>
>
>
> --
> 大橋 宏樹
> mail: silvernshell@gmail.com
> TEL: 080-5493-8347
>



-- 
Chirag Choudhary,
Software Engineer

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message