cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Goasguen <run...@gmail.com>
Subject Re: Secondary storage not working
Date Tue, 29 Oct 2013 07:37:11 GMT

On Oct 29, 2013, at 3:11 AM, Mario Giammarco <mgiammarco@gmail.com> wrote:

> Hello,
> I have just installed a cloudstack management server and I have problems
> with secondary storage.
> I get my first problem when I issued the command to "prepare system vm template"
> I discovered that cloud user and cloud database were not present.
> Then I discovered that the "cloudstack-setup-databases" command gave me a
> list of "ok" but it did not install the db.
> So I manually run the mysql scripts and the server went up.
> 
> I was able to add the same host that runs management server also as host for
> virtual machines without errors.
> 
> But now I see that the system vms like ssvm are in state "starting" and not
> "UP", and I cannot see templates and isos.
> 
> What can I do? Can you please help me?

This tends to happen if you don't have enough ram in your host. Check the management logs,
if you see an error like "Unsufficient capacity" then RAM may be your issue.

If you downloaded the source, the service_offering for systemVMs require quite a bit of RAM.
Go in the database and see how much RAM is required:

>use cloud;
>select * from service_offering;

set the RAM for the console proxy, VR and ssvm to 256….then restart the mgt server...

> 
> Thanks,
> Mario
> 


Mime
View raw message