cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Shafer <ryan.sha...@ecommerce.com>
Subject Unable to Build 4.2.0 From Source Using Maven 3.1
Date Thu, 24 Oct 2013 06:10:47 GMT
Hello,

I am attempting to build CS 4.2.0 from source eventually using noss dependencies from vmware.
 The problem is that I cannot resolve the dependencies for the other cloudstack projects to
build.  In this specific case cloud-api cannot be built because.

[ERROR] Failed to execute goal on project cloud-api: Could not resolve dependencies for project
org.apache.cloudstack:cloud-api:jar:4.2.0: Could not find artifact org.apache.cloudstack:cloud-utils:jar:4.2.0
in central (http://repo.maven.apache.org/maven2) -> [Help 1]

I cannot locate cloud-utils-4.2.0.jar or cloud-utils-4.2.0.pom in the central repository.
 In fact I cannot find a couple of the files in http://repo.maven.apache.org/maven2.  Please
confirm that I am using the correct repository and if it has changed, please provide some
insight on where I can change this to work through my issues.  Because of the nature of our
environment we must be able to build from source.  Any help would be appreciated.

Anyone who would like to contact me directly about potentially working with my company on
our cloudstack related issues we would be willing to entertain any offers, thank you. 

-- 
Sincerely,
Ryan Shafer
System Engineer
Ecommerce Inc.
(800)861-9394 x4213
ryan.shafer@ecommerce.com

Mime
View raw message