cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Higginbottom <geoff.higginbot...@shapeblue.com>
Subject Re: Change public IP range assigned to system VMs
Date Sun, 01 Sep 2013 13:23:03 GMT
Indra,

To change the public IPs you need to release all of them first, and as you have discovered
the problem is they are being used by System VMs which get recreated as soon as you destroy
them.

If you have no VRs using public IPs, then simply disable the zone and then destroy the System
VMs.  Disabling the Zone will prevent them from being instantly recreated and grabbing a new
Public IP.  Once they have been expunged the Public IPs will be released so you can then delete
the existing range and add a new one.

If you do have VRs using public IPs this becomes trickier as you will also need to delete
all of these as well.

However if your goal is to have system VMs using one Public IP range, and Guest VRs using
another this is a lot trickier and is not what the system was designed to do.

You can allocate a block of Public IPs and a unique VLAN to an account, but you would need
to do this for every account.  You then need to release the Public IPs the VRs have which
came from the default IP Range leaving them with only their dedicated IPs.

Regards

Geoff Higginbottom
CTO / Cloud Architect


D: +44 20 3603 0542<tel:+442036030542> | S: +44 20 3603 0540<tel:+442036030540>
| M: +447968161581<tel:+447968161581>

geoff.higginbottom@shapeblue.com<mailto:geoff.higginbottom@shapeblue.com> | www.shapeblue.com

ShapeBlue Ltd, 53 Chandos Place, Covent Garden, London, WC2N 4HS



On 31 Aug 2013, at 14:10, "Indra Pramana" <indra@sg.or.id<mailto:indra@sg.or.id>>
wrote:

Dear all,

Anyone had changed their public IP allocation for the system VMs before and
can share some advice? :)

Looking forward to your reply, thank you.

Cheers.



On Fri, Aug 30, 2013 at 12:01 PM, Indra Pramana <indra@sg.or.id<mailto:indra@sg.or.id>>
wrote:

Dear all,

I am using CloudStack 4.1.1 with KVM hypervisors. I would like to change
the public IP address range used by the system VMs (i.e. SSVM and CPVM).

I went to CloudStack GUI > Infrastructure > Zones > Select my zone >
Physical Network > cloudbr0 (the cloud interface used for public IP) >
Public - Configure > IP Ranges.

I added the new range of public IP addresses (Gateway, Netmask, VLAN,
Start IP, End IP) and assigned to the "System" account, similar to the
existing public IP addresses. However, when I tried to delete the existing
IP range, I encounter this error message:

"The IP range can't be deleted because it has allocated public IP
addresses."

I tried to destroy the system VMs and quickly delete the existing IP
range, but still not able to do so since it seems that the system VMs are
quickly being re-created after being destroyed, and the system VMs are
still using the old IP range when re-created.

Note that I am using another different shared network range for the guest
VMs and the virtual routers

Is there a way how I can make system VMs to use the new IP range I have
added, so that I can safely delete the old IP range?

Looking forward to your reply, thank you.

Cheers.

This email and any attachments to it may be confidential and are intended solely for the use
of the individual to whom it is addressed. Any views or opinions expressed are solely those
of the author and do not necessarily represent those of Shape Blue Ltd or related companies.
If you are not the intended recipient of this email, you must neither take any action based
upon its contents, nor copy or show it to anyone. Please contact the sender if you believe
you have received this email in error. Shape Blue Ltd is a company incorporated in England
& Wales. ShapeBlue Services India LLP is operated under license from Shape Blue Ltd. ShapeBlue
is a registered trademark.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message