cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Hertanu <d...@unixmob.com>
Subject Management IP address pool exhausted
Date Mon, 23 Sep 2013 14:08:20 GMT
Hi

I'm running CS 4.1.1 on CentOS 6.4 64 bit with one host Citrix Xenserver
6.1.

Few days ago I ran into a problem while I was configuring CS. The zone was
active, Xen host added, SSVM and CPVM up & running  when someone from our
team rebooted the Xen host for whatever reason. Even though CloudStack was
complaining about the missing host in the logs, it deleted the old SSVM and
tried to deploy another one, it failed, then another one, and so on, until
the management IP addresses pool was exhausted, moment when CloudStack
reported the new error - that there are not enough management IPs. The host
came back online later but the situation didn't changed. I lowered the
expunge.delay and expunge.interval to 5 minutes, still no change.
I wiped out CS installation and I start all over again. I was curious about
the previous issue, so I manually rebooted the Xen host (without putting it
in Maintenance mode in CS) and the issue showed up again.
While I admit that having one host is not ideal, I have two questions:
- why would CS try to deploy any VM when it actually knows there are no
valid hosts
- how do I make those management IPs available again after CS tried to
deploy 10-20 SSVMs and it exhausted the management IPs pool?

Thanks,

Daniel

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message