cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tracy Phillips <tracp...@mantoso.com>
Subject Re: URGENT: Unable to upgrade from 4.1.1 to 4.2.0
Date Thu, 12 Sep 2013 18:59:10 GMT
This is a known issue and is currently being worked on.

You do realize that 4.2 has not been released yet and is in the testing
phase right?


On Thu, Sep 12, 2013 at 2:35 PM, Indra Pramana <indra@sg.or.id> wrote:

> Dear all,
>
> I proceed to upgrade my CloudStack 4.1.1 to 4.2.0 by compiling it from
> source. However, after upgrading the management servers and all the KVM
> hosts, I am not able to start the management server with this error
> message:
>
> ===
> 2013-09-13 02:18:00,512 INFO  [cloud.upgrade.DatabaseUpgradeChecker]
> (Timer-1:null) DB version = 4.1.1 Code Version = 4.2.0
> 2013-09-13 02:18:00,512 INFO  [cloud.upgrade.DatabaseUpgradeChecker]
> (Timer-1:null) Database upgrade must be performed from 4.1.1 to 4.2.0
> 2013-09-13 02:18:00,512 ERROR [cloud.upgrade.DatabaseUpgradeChecker]
> (Timer-1:null) There is no upgrade path from 4.1.1 to 4.2.0
> 2013-09-13 02:18:00,517 ERROR [utils.component.ComponentContext]
> (Timer-1:null) System integrity check failed. Refuse to startup
> ===
>
> I checked and the documentation (Release_Notes.xml which comes with the
> tar.bz2 file) doesn't mention anything about upgrading the database.
>
> 1. How can I upgrade the database from 4.1.1 version to 4.2.0 version?
> 2. If cannot, how can I revert back to code 4.1.1 for the
> cloudstack-management server and cloudstack-agents on the KVM hosts?
>
> Urgently looking forward to your reply, thank you.
>
> Cheers.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message