cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Punit Dambiwal <hypu...@gmail.com>
Subject Re: Password Management in OS Templates Not Working
Date Thu, 08 Aug 2013 04:55:07 GMT
Hi Venkata,

Thanks for the reply....as the script run successfully and prompt the new
password...but when i try to login...i couldn't be able to login with the
prompted password....

I tried to run the script on guest VM,it throws error :-

----------------------
[root@test3 init.d]# ./cloud-set-guest-password
-bash: ./cloud-set-guest-password: /bin/bash^M: bad interpreter: No such
file or directory
[root@test3 init.d]#
-----------------------

In the VR...it seems ok...the correct path is :- /var/cache/cloud/passwords
  (The new password for the corresponding ip address listed in this file)


On Thu, Aug 8, 2013 at 12:44 PM, Venkata SwamyBabu Budumuru <
venkataswamybabu.budumuru@citrix.com> wrote:

> Since you made this as a startup script, what do you see just before the
> guest login prompt appears? Do you see any errors when the script executed
> or does it say it has set the password successfully.
>
> At the same time, you can also check on your VR for
> /var/cloud/cache/password file and see the password entry for your guest
> ip. On successfully password setup, it will set it to save_password value.
>
> You can also just check by manually executing this script before you make
> template out of it.
>
> On 08/08/13 10:04 AM, "Punit Dambiwal" <hypunit@gmail.com> wrote:
>
> >Hi,
> >
> >I Followed the following url to add the Password Management in OS
> >templates....place the "cloud-set-guest-password" in the /etc/init.d/.
> >
> >When i try to deploy the new VM with this template,VM deployed
> >successfully
> >and prompt the new password,but when try to login to VM...the new password
> >doesn't work...old password can still use.
> >
> >Thanks,
> >punit
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message